•   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 14
  •   
Linux HOW-TO compile XBMC from a GIT source
#91
i know this thread is all about upgrading to the latest development and bleeding edge git-source and i highly appreciate the work and effort put into the script! but what would one need to do to pull a git branch from a specific date? like let's say from june 1st ?
Reply
#92
Lightbulb 
I don't think you can specify a date as the checkout parameters at all only the commit strings...

FYI I asked google how to do what you ask this was one of the replies. Shocked

good luck
Reply
#93
git checkout a481848d5fccfd2b871c8dc6076cd575da9594c5

Add this before the

./bootstrap; ./configure --prefix=/usr --enable-vdpau --disable-pulse ; make -j4

line


the git checkout is a specific date/stamp?

Adding this line above the ./bootstrap line, and then run the install, not upgrade, it will put it to the version you indicated...

git checkout a481848d5fccfd2b871c8dc6076cd575da9594c5

Was a git version that others had verified did not have the scraper issue, so I pushed back to there...

If you look around and find out the checkout for when you need, maybe just try adding that line and then the install..

Seems like it should work, but I just hack at stuff, so I am sure some one else will chime in.

Hope that helps
Reply
#94
Star 
NativeCanadian Wrote:the git checkout is a specific date/stamp?

Hi

Yes that's how the link I posted suggests, thx for posting the exact placement it does stand to reason that a git checkout should precede all compile strings.

I was curious too and actually the Git hash is called a "blob" and it has nothing to do with date, apparently it's a SHA-1 hashing of the actual file contents or data... something like this sha1("blob " + filesize + "\0" + data)

cheers
Reply
#95
Hello.
Thank you for the excellent thread!
I have one question:
Is it possible to update only the skin Confluence?
The thing is that using the instructions in this topic and the information of the topic:
http://forum.xbmc.org/showthread.php?tid=86038
I updated XBMC, while adding a double audio output.
Unfortunately, now when I try to compile again, I get lots of errors while compiling dvdplayer.
Then there's a lot of errors and does not create a file xbmc.bin
Unfortunately, linux is for me totally unknown so I am not able himself handle this problem.
I have a backup copy of the running version of xbmc, but I want to update skin Confluence.
The new version is definitely better.
Thank you in advance for your help.

My English is very poor - translated by Google.
Reply
#96
X3lectric Wrote:What direct question is that? I saw no question at all, so Im presuming you made some mistake.

So let me ask you a rhetorical question... How do I know you are not responsible for these errors knowingly or otherwise?
Good question, because you do not know Smile. That is why it is good you are asking question, so that I can explain better what I've done.
X3lectric Wrote:Also looking at your post after

56 not upgraded?
Yes, 56 where not upgraded because they where all on the newest version Wink, so no need to upgrade them.

X3lectric Wrote:like I said to you before, double check your stuff... Your posts don't make it very easy, tbh.
Yes you're right, so I'll post the exact steps I did at the end of this post, because I am now able to compile without any problems.
X3lectric Wrote:I cant do anything about that, scripts run each command one after another, its well beyond my control what happens with each user.
Of course you cannot control that, I was just reflecting the things that happened with me.
X3lectric Wrote:TBH your the first person and only person to complain about this, none of the alterations I made to script affect that, so idk...
I think because it is that probably most of the people start with manual running the "apt-get build-dep xbmc -y" command, and the "upgrade" command is mostly only runned once.

So to properly test this, everytime it should start from a format disk, live install and then upgrade command. But of course that is much too work for everyone to actually do.

X3lectric Wrote:If you have a better way to do it, that is 100% foolproof for everyone, please go ahead, more hands make light work.

cheers and thx

Let me think about how to make this fool-proof. I think that the text in the fipo can be written differently. Just two headers with manual process, and script version. The updates are interesting and could be in the second post, but they make the first post harder to read and harder to follow because of all kinds of information that are no needed steps.

Anyhow here are my exact steps, so you can retrace them if you want it:

1 ) Burn xbmc live 10.1
2 ) Install on box by fdisking the system.
3 ) I installed your LIRC script on your blog (thanks for this!) because my remote is not working by default on my ion 330.
4 ) I installed the plugin "repo-installer" in order to get more plugins.
5) Via ssh, logged in as root on the box, remote via my PC.
6) Wgetted the update script
7) Executed ./XBMC_build_git.sh upgrade
8) Runned into the missing dependencies error.
9) Runned apt-get build-dep xbmc -y
10 ) Executed ./XBMC_build_git.sh upgrade

XBMC builded correctly and now I am able to perform Executed ./XBMC_build_git.sh upgrade

Happy hunting Wink
Reply
#97
nims Wrote:Yes, 56 where not upgraded because they where all on the newest version Wink, so no need to upgrade them.
I cant remember off hand but when packages are at their latest version, that's not the message you get. If it says 56 not upgraded, its because it detected 56 packages that need upgrading and are not because of some error.

nims Wrote:So to properly test this, everytime it should start from a format disk, live install and then upgrade command. But of course that is much too work for everyone to actually do.

No, the script can update a already upgrade install. also There's something called disk imaging... Also the script and instructions have been cleaned a bit.

nims Wrote:4 ) I installed the plugin "repo-installer" in order to get more plugins.
Im pretty sure since XBMC 10 dharma that this has been nuked and unsupported, so your doing something wrong somewhere.

nims Wrote:Yes you're right, so I'll post the exact steps I did at the end of this post, because I am now able to compile without any problems.
Good, finally eh. Im happy your do

nims Wrote:Happy hunting Wink

I'll get my riffle.
Reply
#98
works fine on "Xbmcfreak livecd Natty Dharma v1.1"

only changed from lucid to maverick ppa on the script.

got an error using ./XBMC_build_git.sh <upgrade>
but this works fine ./XBMC_build_git.sh upgrade

also had to install aptitude as it's missing..
Reply
#99
mmm wait your on natty using maverick packages? The ppa has natty packages.
Reply
robotm Wrote:Hello.
Thank you for the excellent thread!
I have one question:
Is it possible to update only the skin Confluence?
The thing is that using the instructions in this topic and the information of the topic:
http://forum.xbmc.org/showthread.php?tid=86038
I updated XBMC, while adding a double audio output.
Unfortunately, now when I try to compile again, I get lots of errors while compiling dvdplayer.
Then there's a lot of errors and does not create a file xbmc.bin
Unfortunately, linux is for me totally unknown so I am not able himself handle this problem.
I have a backup copy of the running version of xbmc, but I want to update skin Confluence.
The new version is definitely better.
Thank you in advance for your help.

My English is very poor - translated by Google.

I am not aware of just a skin update via any official sources, perhaps you can ask in IRC #xbmc-linux channel.

As for your errors are probably due to your patched sources are no longer compatible with main GIT again you main need to do teh following on your GIT xbmc dir.
Code:
git clean -xfd
git reset --hard
git pull --rebase
then try to compile again.

you may and most likely loose your patch if it compiles as Im pretty sure its not compatible.
Reply
X3lectric Wrote:mmm wait your on natty using maverick packages? The ppa has natty packages.

so how should i get natty?

change ppa to natty and then? upgrade or refresh.
Reply
if your distro is natty you should change to natty packages. makes sense no?

because of what you have installed you may have to purge it all and start again. idk that's what I would do, but this is ENTIRELY up to YOU and a FULL SYSTEM BACKUP IS RECOMMENDED.

to ensure you are on natty type:
uname -a it should return a kernel 2.6.38 something-generic and go from there.

You can than try to update and upgrade dont do distupgrade, thats possibly destructive.

If packages upgrade to natty version OK great if they dont you may need to purge them and start again.

You could try just rerunning the dependencis install line again see if that works including apt-get build xbmc-dep

please referr to how to.
Reply
X3lectric Wrote:Quote:
Originally Posted by nims View Post
4 ) I installed the plugin "repo-installer" in order to get more plugins.

---
Im pretty sure since XBMC 10 dharma that this has been nuked and unsupported, so your doing something wrong somewhere.

Well I was not aware of this. I need the advanced launcher plugin on my xbmc, and saw that the only place to get it, is the google-code repo. So to make things easier for me, the repo installer allows me to get the google repo. I did not run into any problems with it on 11.x so I don't know why it shouldn't be used. It seems that the repo installer, just installs the repo's the same way as a manual copy of the repo.zip, so don't know why this is nuked.

Are you not confused by the SVN addon's installer? That one has been nuked since 10.x.

I am talking about this one, which is actually supported on the XBMC wiki aswell:
http://wiki.xbmc.org/index.php?title=Uno...positories
http://passion-xbmc.org/addons/?Page=Vie....installer
Reply
@nims

er I wasn't aware that this was "updated" to addon, so thx, either way the xbmc addon repo has the addons that actually work with GIT revs of XBMC, perhaps there's a good reason for this not being included in XBMC GIT or no reason at all, I will try it out anyway.
Reply
updated first post and script a little more made it simpler and cleaner, Whoever wants to contribute feels free to do so. Thank you.
Reply
  •   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 14
  •   



Logout Mark Read Team Forum Stats Members Help
HOW-TO compile XBMC from a GIT source12
This forum uses Lukasz Tkacz MyBB addons.