Thread Rating:
  • 1 Vote(s) - 5 Average
[RELEASE] XPPR (XBMC Picasa Plugin Reloaded) Pictures Addon
#1
Thumbs Up 
Yet another Picasa addon for XBMC that supports photo upload.

Home Page: http://code.google.com/p/xppr/

Addon Features:
  • Browse Picasa Web Albums even without Google account
  • Browse Featured and Recently added photos
  • Extensive use of context menus for navigation
  • Bookmark photos, albums or users
  • Bookmark private album which was shared via email
  • Download photos
  • Upload photos (Picasa account required)
  • Search photos
Requirements:
Tested on Camelot and Dharma under Linux and Windows. Please file a bug for any compatibility issue.
Note that batch photo upload requires min. commit dcad8dbd.

Feedbacks :
Bugs reports could be posted on this thread or preferably here. Any feedback, idea or suggestion is welcome.
Reply
#2
I just tired it out. Nice job. FYI, I installed .9.2, but the addon.xml still says .9.1. Is there any way to show a progress bar when uploading a file and is it possible to upload an entire folder of images?
Read this before using these builds.
Changelog
Reply
#3
kricker Wrote:I just tired it out. Nice job.
Thanks.

Quote:FYI, I installed .9.2, but the addon.xml still says .9.1.
Embarrassing mistake. Fixed now.

Quote:Is there any way to show a progress bar when uploading a file and is it possible to upload an entire folder of images?
We'll think about these...
Reply
#4
While looking at images fullscreen, is it possible to show info about the image without having to go back to the list of images?

When running a slideshow then exiting it, the selected image is the image you started the slideshow with not the one where you exited the slideshow. Is it possible to exit the slideshow and be at that place in the image list?

Browsing images in albums always defaults back to list mode between XBMC sessions even if it was last in some other view mode.

A also noticed a strange issue I thought was my fault, but turns out it is something else. When I tried to login the first time I got an error. I went in and added the @gmail.com to my login and I thought that fixed it, but it did not. After each launch of XBMC I have to login twice to get into the plugin. The first attempt always results in an error "Authentication process failed. Message: (8, 'EOF occurred in violation of protocol')". The second attempt to login works fine.

FYI, I am using Windows 7 as my XBMC platform.

Forgive my blast of issues/requests, I just had some free time to play with this and I am just brain dumping.
Read this before using these builds.
Changelog
Reply
#5
kricker Wrote:While looking at images fullscreen, is it possible to show info about the image without having to go back to the list of images?

When running a slideshow then exiting it, the selected image is the image you started the slideshow with not the one where you exited the slideshow. Is it possible to exit the slideshow and be at that place in the image list?
Both the fullscreen image and the slideshow are displayed by XBMC and not the addon. So expect both of them work just as normal picture view and slideshow work. E.g. the default shortcut for image info is 'o' (small letter o).

kricker Wrote:Browsing images in albums always defaults back to list mode between XBMC sessions even if it was last in some other view mode.
As far as I understand the view mode is handled by XBMC itself too. On Linux it is working fine for me.

kricker Wrote:A also noticed a strange issue I thought was my fault, but turns out it is something else. When I tried to login the first time I got an error. I went in and added the @gmail.com to my login and I thought that fixed it, but it did not. After each launch of XBMC I have to login twice to get into the plugin. The first attempt always results in an error "Authentication process failed. Message: (8, 'EOF occurred in violation of protocol')". The second attempt to login works fine.

FYI, I am using Windows 7 as my XBMC platform.
Basically it doesn't matter if the user name is set with or without the gmail.com domain. Probably this error is the same or related to the Windows SSL problem you experienced with the official Picasa addon.
I personally use only Linux, but the other half of XPPR has Windows 7 and will look into the issue. Smile

kricker Wrote:Forgive my blast of issues/requests, I just had some free time to play with this and I am just brain dumping.
No problem at all, all feedback is appreciated. I have filed your suggestions on the issue tracker.
Reply
#6
@kricker: Please take a look at this download: http://xppr.googlecode.com/files/xppr-0.9.3.rc1.zip

It contains a possible solution (stolen from the official youtube addon) for the Windows login problems.

Please let me know how it goes.
Reply
#7
Tried it. And it works fine. It takes ~30 seconds to log in but it works. Nice.
Read this before using these builds.
Changelog
Reply
#8
fellbeast Wrote:Both the fullscreen image and the slideshow are displayed by XBMC and not the addon. So expect both of them work just as normal picture view and slideshow work. E.g. the default shortcut for image info is 'o' (small letter o).
Right that's it. I forgot about "o". I was trying the context menu button.

fellbeast Wrote:As far as I understand the view mode is handled by XBMC itself too. On Linux it is working fine for me.
I remember a setting for something like this a long time ago, but I can't find it now. For me at every new run of XBMC images within my albums always show as lists, but the Albums themselves show up as whatever they were last set at. Yet, images within Explore/Recent or Featured folders also retain the last view state they were set at. It only effects the images in My Albums.
Read this before using these builds.
Changelog
Reply
#9
Just made 0.9.3 available for downloading.

Changes:
  • Non-intrusive user notifications (stolen from youtubexbmc);
  • Added support for filtering photos by tag;
  • Showing photo location on map (copied from ruuk's picasaphotos-xbmc with some changes);
  • Progress bar during lengthy operations (e.g. batch upload);
  • Fixed Windows SSL problems by retrying login when it fails;
Errata Todo
  • Cancel in progress bar doesn't work.
Enjoy!!
Reply
#10
hey, just installed this addon, but I'm having some issues with it. I'm not using a gmail account for Picasa, but my own domain, so my email login address isn't xxx@gmail.com and I think that's what's causing my problems. (it looks like your plugin just changes my login to a gmail one?)

Also - Captcha issues?

From the log:
Error=CaptchaRequired
Url=https://www.google.com/accounts/ErrorMsg?Email=anders%40gmail.com&service=lh2&id=cr&timeStmp=1298489424&secTok=xxxxxxxxxxxxxxxxxxx
Reply
#11
Many thanks for the feedback.

I've uploaded a new version, which will not crop your domain: http://xppr.googlecode.com/files/xppr-0.9.4-rc1.zip

Please give it a try.

The captcha issue appeared probably because you tried to login with the 'wrong' user name a couple of times. Please let me know if you still have captcha problems with the above version.
Reply
#12
It works perfectly now, many thanks for the fast fix! Smile
Reply
#13
I'm new to XBMC but am really amazed at how powerful it is. I had a question about Picasa integration.

Is there a way to set my XBMC screensaver to use my Picasa web account's photos?

I can't figure out if that's possible.

Thanks,

Widecast
Reply
#14
Hi fellbeast,

somehow I can't find the option to add galleries shared by mail. Can you help me here?

MB
Reply
#15
Hi fellbeast,

Thanks for the great plugin!
I have a problem when using the slideshow function that the videos are not playing.
In the log file I see it is giving 'ERROR: Texture manager unable to load file: http://...' on the video files.
Any idea?

Thanks!
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] XPPR (XBMC Picasa Plugin Reloaded) Pictures Addon51