Thread Rating:
  • 0 Vote(s) - 0 Average
[AppleTV2] Can't get ATV2 to work with NAS
#1
I have a Synology NAS, UPnP enabled, on my network. When i set up XBMCATV, i have to go through UPnP devices to get to it...unlike when i set up XBMC on my Mac, which recognizes the volumes and shows it as such when adding a source. The result is that it appears that the UPnP address is being included in the media scanning process and my library is...well bizarre. This doesn't happen on my Mac.
Reply
#2
cfriedberg,
Does your NAS support SMB sharing? Most do. I think that protocol is the best one to use for XBMC. Simply add your NAS as a SMB source and see if that improves things.
Reply
#3
It's a synology ds209. It has windows file server support but I see no SMB anywhere. I'm a Mac guy so be gentle.

Reset XBMC and now can't activate library mode.
Reply
#4
Windows File support is generally for the most part SMB mode.

You won't be able to access library mode unless XMBC has content scanned and added to it's database. If you have not been successful in connecting to your NAS containing all your media, this would be the reason why you can not access library mode.
Reply
#5
So how do I get it to scan? I added one folder of tv shows. Nothing is happening.
Reply
#6
And why does this happen on the ATV but not the Mac?
Reply
#7
dazex Wrote:Windows File support is generally for the most part SMB mode.

You won't be able to access library mode unless XBMC has content scanned and added to it's database. If you have not been successful in connecting to your NAS containing all your media, this would be the reason why you can not access library mode.

here's a screenie of that page, other than checking the box, which i've tried to no avail, what else should i have done?

Image
Reply
#8
Hey, I had the same issue with my AirPortExtreme, https://public.me.com/jeparkinson and click the PDF file. I found this to be really helpful.
Reply
#9
Thanks for the PDF. But I have a NAS not an airport disk that contains my media.
Reply
#10
Just checking the box "Enable Windows File Service" should do (I am running a DS210j).
Get the PDF johnsea uploaded (for you) ann follow the instructions how to set up your nas.

add network location
=> choose windows network (SMB)
=> enter server name (nas should have a manually configured ip - if not - do so under settings => network of your synology software)
=> follow instruction (pdf)....
Reply
#11
I've also found that if you don't have Guest access enabled on your NAS/Airport that is an issue. I had to change in my Airport Extreme's settings to enable Guest access.
Reply
#12
Microsaft Wrote:Just checking the box "Enable Windows File Service" should do (I am running a DS210j).
Get the PDF johnsea uploaded (for you) ann follow the instructions how to set up your nas.

add network location
=> choose windows network (SMB)
=> enter server name (nas should have a manually configured ip - if not - do so under settings => network of your synology software)
=> follow instruction (pdf)....

I appreciate the help but that didn't work...nothing showed up under SMB when adding a source. Also, XBMC 10.0 has different menu items, no mount SMB toggle. seems like a lot of brain damage vs the Plex ATV client.

EDIT: i had already established a static ip for the NAS, which i input when going into the settings/network menu page.
Reply
#13
the thing is, this doesn't happen on the OSX version, which has no problem, just the iOS version.
Reply
#14
can anyone else help here...XBMC4ATV still not seeing NAS after following directions above.

EDIT: Figured it out thanks for the help guys!
Reply
#15
I also have a Synology device that is networked to my ATV2. Even though XBMC and the Synology have the same workgroup name set using the browse button I am not able to see the Synology. I had to manually enter the server name, share, username, and password. After I did the manual input it worked fine.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[AppleTV2] Can't get ATV2 to work with NAS00