•   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 37
  •   
[REL] PleXBMC
I had a problem watching Amazon VOD and NickJr channels on my XBMCBuntu 12.0 machine. I kept getting invalid url errors. I edit default.py to get it to work. In getLinkURL, I changed
elif path[0:5] == "rtmp:":
to
elif path[0:5] == "rtmp:" or path[0:6] == "rtmpe:":

Is there a way to submit a patch or is posting in the forum sufficient since its a one line change? I haven't tested this on any other platforms.
Reply
Hey.. Awesome tool and I'm so looking forward to using it, but I'm doing something wrong. I only get content in PleXBMC at random.

I have tried the ip of my Plex Server and just GDM, and nothing seems stable. 95% of the time PleXBMC is just empty, the once in a while I can see the content.
When I try on my android device with the official Plex app, I have no problem connecting and finding the server. There is no password and everything is on the same network/subnet.

Anybody with an idea of what i'm doing wrong?
Reply
(2013-03-25, 07:08)polloman1 Wrote: I had a problem watching Amazon VOD and NickJr channels on my XBMCBuntu 12.0 machine. I kept getting invalid url errors. I edit default.py to get it to work. In getLinkURL, I changed
elif path[0:5] == "rtmp:":
to
elif path[0:5] == "rtmp:" or path[0:6] == "rtmpe:":

Is there a way to submit a patch or is posting in the forum sufficient since its a one line change? I haven't tested this on any other platforms.

https://github.com/hippojay
My skins:

Amber
Quartz

Reply
Using Plexbmc on latest Windows XBMC with default XBMC skin (but skin doesn't matter with this problem) strange thing is that I can stream videos just fine but the mouse pointer keeps showing. Moving it shows the time progress (which is normal) but that doesn't disappear either after that. So, I'm stuck with time progress while viewing a movie or serie...
Is this some XBMC setting or has this to do with the use of Plexbmc?

regards
Reply
(2013-03-26, 22:59)EvilUnicorn Wrote: Using Plexbmc on latest Windows XBMC with default XBMC skin (but skin doesn't matter with this problem) strange thing is that I can stream videos just fine but the mouse pointer keeps showing. Moving it shows the time progress (which is normal) but that doesn't disappear either after that. So, I'm stuck with time progress while viewing a movie or serie...
Is this some XBMC setting or has this to do with the use of Plexbmc?

regards

XBMC. Either disable mouse or take a look at wiki to find out how to hide progress with your mouse/keyboard.
My skins:

Amber
Quartz

Reply
PlexBMC used to work for me to play shared videos but today it started giving errors on playback. I went and double checked the connection with playback over myPlex and the same video streams fine there... Any ideas?

Code:
21:51:37 T:1348  NOTICE: ===== PLEXBMC START =====
21:51:37 T:1348  NOTICE: PleXBMC -> running Python: (2, 6, 6, 'final', 0)
21:51:37 T:1348  NOTICE: PleXBMC -> running PleXBMC: 3.1.5
21:51:37 T:1348  NOTICE: PleXBMC -> Running with cElementTree on Python 2.5+
21:51:37 T:1348  NOTICE: PleXBMC -> Platform: Windows
21:51:37 T:1348  NOTICE: PleXBMC -> Flatten is: 0
21:51:37 T:1348  NOTICE: PleXBMC -> Settings streaming: 0
21:51:37 T:1348  NOTICE: PleXBMC -> Setting filter menus: true
21:51:37 T:1348  NOTICE: PleXBMC -> Setting debug to true
21:51:37 T:1348  NOTICE: PleXBMC -> Setting stream Control to : XBMC CONTROL (0)
21:51:37 T:1348  NOTICE: PleXBMC -> Force DVD playback: false
21:51:37 T:1348  NOTICE: PleXBMC -> SMB IP Override: false
21:51:37 T:1348  NOTICE: PleXBMC -> Script argument is 20
21:51:37 T:1348  NOTICE: == ENTER: get_params ==
21:51:37 T:1348  NOTICE: PleXBMC -> get_params: Parameter string: ?url=http%3A//xxx.xxx.xxx.xxx%3A9360/library/metadata/568%3Ft%3D4082091832&mode=5&X-Plex-Token=Wi7M8gxvQCw6qNpVxAG5
21:51:37 T:1348  NOTICE: PleXBMC -> Detected parameters: {'url': 'http%3A//xxx.xxx.xxx.xxx%3A9360/library/metadata/568%3Ft%3D4082091832', 'mode': '5', 'X-Plex-Token': 'Wi7M8gxvQCw6qNpVxAG5'}
21:51:37 T:1348  NOTICE: PleXBMC -> Mode: 5
21:51:37 T:1348  NOTICE: PleXBMC -> URL: http://xxx.xxx.xxx.xxx:9360/library/metadata/568?t=4082091832
21:51:37 T:1348  NOTICE: PleXBMC -> Name:
21:51:37 T:1348  NOTICE: PleXBMC -> identifier: None
21:51:37 T:1348  NOTICE: PleXBMC -> token: Wi7M8gxvQCw6qNpVxAG5
21:51:37 T:1348  NOTICE: == ENTER: playLibraryMedia ==
21:51:37 T:1348  NOTICE: == ENTER: gettranscodesettings ==
21:51:37 T:1348  NOTICE: == ENTER: getAudioSubtitlesMedia ==
21:51:37 T:1348  NOTICE: PleXBMC -> getAudioSubtitlesMedia: Gather media stream info
21:51:37 T:1348  NOTICE: == ENTER: getURL ==
21:51:37 T:1348  NOTICE: PleXBMC -> getURL: url = http://xxx.xxx.xxx.xxx:9360/library/metadata/568
21:51:37 T:1348  NOTICE: PleXBMC -> getURL: header = {'X-Plex-Token': 'Wi7M8gxvQCw6qNpVxAG5'}
21:51:57 T:1348  NOTICE: Unable to connect to xxx.xxx.xxx.xxx:9360
                                            Reason: timed out
21:51:57 T:1348  NOTICE: Unable to connect to xxx.xxx.xxx.xxx:9360
                                            Reason: timed out
21:51:57 T:1348   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: feed() argument 1 must be string or read-only buffer, not bool
                                            Traceback (most recent call last):
                                              File "C:\Users\devan_000\AppData\Roaming\XBMC\addons\plugin.video.plexbmc\default.py", line 4082, in <module>
                                                playLibraryMedia(param_url,force=force)
                                              File "C:\Users\devan_000\AppData\Roaming\XBMC\addons\plugin.video.plexbmc\default.py", line 1711, in playLibraryMedia
                                                streams=getAudioSubtitlesMedia(server,id, full_data)
                                              File "C:\Users\devan_000\AppData\Roaming\XBMC\addons\plugin.video.plexbmc\default.py", line 1572, in getAudioSubtitlesMedia
                                                tree=etree.fromstring(html)
                                              File "<string>", line 85, in XML
                                            TypeError: feed() argument 1 must be string or read-only buffer, not bool
                                            -->End of Python script error report<--
21:51:57 T:896   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.plexbmc/?url=http%3A//xxx.xxx.xxx.xxx%3A9360/library/metadata/568%3Ft%3D4082091832&mode=5&X-Plex-Token=Wi7M8gxvQCw6qNpVxAG5]
21:51:59 T:6024  NOTICE: Thread Background Loader start, auto delete: false
Reply
i don`t know whether it`s caused by plex or the addon but the itunes bridge is not working for me... the library appears empty ...

is anyone facing something similar?
Reply
hello hippojay!

Any progress on a plexbmc specific confluence skin? Smile

https://github.com/xbmc/xbmc/tree/master...confluence
Reply
I have aeon nox 4 installed. How do I get plexbmc to show Recent and ondeck for TV and movies?

Also for every TV Show I have to set the views for Seasons and for Episodes. They all default individually to List and I know it doesn't do this for local media...
Image
Reply
(2013-03-24, 19:43)renobles Wrote: Is there a way to have PleXBMC respect the sort name in the movies listing? Examples would be Jurassic Park 1, 2, and 3. Their names put them in very different parts of the list, but I have a sort name setup as Jurassic Park <#>. This works in Plex proper, but not PlexBMC. Thanks for the help and the awesome plugin btw.

Working now in next release, which is just in testing

(2013-03-25, 07:08)polloman1 Wrote: I had a problem watching Amazon VOD and NickJr channels on my XBMCBuntu 12.0 machine. I kept getting invalid url errors. I edit default.py to get it to work. In getLinkURL, I changed
elif path[0:5] == "rtmp:":
to
elif path[0:5] == "rtmp:" or path[0:6] == "rtmpe:":

Is there a way to submit a patch or is posting in the forum sufficient since its a one line change? I haven't tested this on any other platforms.

Thanks - have added this into the next release too.

(2013-04-01, 03:21)devanl Wrote: PlexBMC used to work for me to play shared videos but today it started giving errors on playback. I went and double checked the connection with playback over myPlex and the same video streams fine there... Any ideas?


This:

Code:
21:51:57 T:1348  NOTICE: Unable to connect to xxx.xxx.xxx.xxx:9360
                                            Reason: timed out

Means that I was unable to get a response from that particular IP/hostname. The timeout is 10 seconds, so unless you are on a very very slow link it looks like something is blocking access. Any firewalls

(2013-03-26, 17:19)Kega Wrote: Anybody with an idea of what i'm doing wrong?

Post/PM me the XBMC.log file with plexbmc debug turned on and that should tell me.
Add-on:PleXBMC (wiki) - Play Plex media through XBMC
PleXBMC Helper - Integrate Official/Unoffical Plex remote control apps into PleXBMC
PleXBMC Repository - install and manage all PleXBMC addons
Quartz3 PleXBMC - Integrate PleXBMC into home menus
Reply
(2013-04-03, 06:15)crimsonfury Wrote: I have aeon nox 4 installed. How do I get plexbmc to show Recent and ondeck for TV and movies?

Also for every TV Show I have to set the views for Seasons and for Episodes. They all default individually to List and I know it doesn't do this for local media...

Hippojay,

Any help with my last 2 questions?
Image
Reply
(2013-04-03, 06:15)crimsonfury Wrote: I have aeon nox 4 installed. How do I get plexbmc to show Recent and ondeck for TV and movies?

You would need to modify the skin to allow it to read the data set by PleXBMC. I've not looked at aeon Nox 4 for a long time, so I've no idea how eas it would be.

Quote:Also for every TV Show I have to set the views for Seasons and for Episodes. They all default individually to List and I know it doesn't do this for local media...

I thought this was also an issue for the standard xbmc library, but each tv show and season is counted as a separate item by XBMC, and therefore views are not remembered. Plexbmc has a workaround for this, but only for the quartz, quartzv3 and confluence skins. To add them in I need to know the names and IDs of the various view. I haven't done this yet for aeon Nox 4
Add-on:PleXBMC (wiki) - Play Plex media through XBMC
PleXBMC Helper - Integrate Official/Unoffical Plex remote control apps into PleXBMC
PleXBMC Repository - install and manage all PleXBMC addons
Quartz3 PleXBMC - Integrate PleXBMC into home menus
Reply
(2013-04-06, 23:16)hippojay Wrote:
Quote:Also for every TV Show I have to set the views for Seasons and for Episodes. They all default individually to List and I know it doesn't do this for local media...

I thought this was also an issue for the standard xbmc library, but each tv show and season is counted as a separate item by XBMC, and therefore views are not remembered. Plexbmc has a workaround for this, but only for the quartz, quartzv3 and confluence skins. To add them in I need to know the names and IDs of the various view. I haven't done this yet for aeon Nox 4

No when I have local media with xbmc my TV shows all obey the views I input for one show/season/episode level. It is huge hassle to go through 50+ shows and multiple seasons and set the same view for all... Is there a fix for this in plexbmc?
Image
Reply
I have attempted searching this thread for a solution to my problem, but since I couldn't fine one, I'm posting!
I just updated from XBMC 11.0 to 12.1, along with plexbmc. Both upgrades went fine.

However, when I try to upgrade Quartz V3 for plexbmc from 0.5 to 0.7.5, it says "dependencies not met". I am attempting to upgrade using the .zip file. Does anyone have an idea of what the cause could be?
I'm running Linux (Gentoo), in case that matters. Oh, and the log file says this: "ERROR: Texture manager unable to load file: /home/xbmc/skin.quartz3.plexbmc-0.7.5.zip/icon.png"
However, as far as I can tell, there is an icon.png inside the archive.

Thank you.
Reply
Running 12.0, I'm having the exact issue described here. Trying to play any queued videos I get the prompt to select the resolution (which does seem to reflect the actual resolutions available) but after selecting I immediately get URL error: Unauthorized.

Here is, I believe, the relevant log entry: http://pastebin.com/m6qbaJqA
Queued videos play fine through Plex proper on the same machine. Please let me know if I can provide you with any additional info, and thanks for an awesome plugin that gives us the best of both worlds!
Reply
  •   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 37
  •   



Logout Mark Read Team Forum Stats Members Help
[REL] PleXBMC3
This forum uses Lukasz Tkacz MyBB addons.