•   
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 22
  •   
[RELEASE] Movie Quiz - how well do you know your movie collection?
Is there a link to the repo in a .zip?
Reply
dieselboy27 Wrote:Is there a link to the repo in a .zip?

well, you should be able to install the new version from within xbmc, but if you prefer the zip you can get it here:
http://mirrors.xbmc.org/addons/eden-pre/...-0.5.0.zip

Br.
Tommy
Reply
just installed this plugin today, really impressed, I have a few bugs though, don't know if they have already been addressed but here go's

On playing a clip, confluence decides to put up the video info making the question just a little bit to easy Wink

I ran across a few questions that were impossible, ie - Who plays Dancer #34 in Enchanted - or who plays police officer #2

is there anyway to set it to skip questions like that?

Awsome work Smile
Reply
I have just installed this to, and it looks realy good. only once the game is over, the buttons to replay or go back to main menu dont work. so im left with no option but to kill xbmc and restart it. Huh

Any one have a solution??
Reply
RenZ0R Wrote:just installed this plugin today, really impressed, I have a few bugs though, don't know if they have already been addressed but here go's

On playing a clip, confluence decides to put up the video info making the question just a little bit to easy Wink

I ran across a few questions that were impossible, ie - Who plays Dancer #34 in Enchanted - or who plays police officer #2

is there anyway to set it to skip questions like that?

Awsome work Smile


Hi Renzor,
I'm not sure what you men with the video info. Can you provide a screenshot? Also what skin are you using?
I see what I can do about the generic actor names.
Meanwhile, in the settings you can exclude this question type if you don't want it.

Br.
Tommy
Reply
road king Wrote:I have just installed this to, and it looks realy good. only once the game is over, the buttons to replay or go back to main menu dont work. so im left with no option but to kill xbmc and restart it. Huh

Any one have a solution??

Hi road king,
Can you check your xbmc.log for errors when you try to click the retry or main menu button.
What OS and remote are you using?

Br.
Tommy
Reply
twinther Wrote:Hi road king,
Can you check your xbmc.log for errors when you try to click the retry or main menu button.
What OS and remote are you using?

Br.
Tommy

Im using xbmc 11.0 on windows 7. i try using mouse, keyboard and MCE remote but get the same result with all of them. i dont think anything is beeing writen to the log when i try to press retry or main menu. i can select them but clicking on/ pressing enter/ pressing OK dose nothing.

Here is the end of my log...
Quote:11:11:50 T:1852 NOTICE: onQuestionAnswered(..)
11:11:50 T:1852 NOTICE: HighscoreDatabase opened: C:\Users\Jethro\AppData\Roaming\XBMC\userdata\addon_data\script.moviequiz\highscore.db
11:11:50 T:1852 NOTICE: Migrating Highscore Database
11:11:50 T:1852 NOTICE: Highscore Database version: [0, 4, 2]
11:11:50 T:1852 NOTICE: Highscore Database is up-to-date
11:11:50 T:1852 NOTICE: LocalHighscoreDatabase closed
11:12:33 T:2028 NOTICE: SKIN == True
Reply
road king Wrote:I have just installed this to, and it looks realy good. only once the game is over, the buttons to replay or go back to main menu dont work. so im left with no option but to kill xbmc and restart it. Huh

Any one have a solution??

I have the very same issue.
Window 7 64 Eden 11
Reply
are you able to exit the menu using ESC or backspace?
Please send me your xbmc.log after you have experienced the problem.

Br
Tommy
Reply
ErlendSB Wrote:Anyone using DSPlayer with this addon?

I´m having trouble when a video starts playing. In DVDplayer it plays nicely in the cinemascreen window, but with dsplayer it jumps into fullscreen and advances to the next question before I get the chance to answer.

I realize this will not be prioritized as a bug, but I thought I´d check to see if anyone else was experiencing the same, and had found "a hidden miracle setting". This is probably more of a ffdshow/dsplayer issue anyway, but if you´re interested I can probably help with a log of some kind.

Anyway... keep up the good work.

Hi Guys,

Did anyone confirm if this works
Reply
Hi Guys,

I have an addon.py error when i try to launch the script.
I'm under OSX Lion + Eden Beta 2

Thanks for your help Smile


Code:
10:32:21 T:2959781888  NOTICE: Loaded DB settings: {'host': '192.168.1.222', 'type': 'mysql', 'user': 'xbmc', 'pass': 'xxx'}
10:32:21 T:2959781888  NOTICE: Connecting to MySQL database...
10:32:21 T:2959781888    INFO: -->Python script returned the following error<--
10:32:21 T:2959781888   ERROR: Error Type: <type 'exceptions.KeyError'>
10:32:21 T:2959781888   ERROR: Error Contents: ('name',)
10:32:21 T:2959781888   ERROR: Traceback (most recent call last):
                                              File "/Users/M/Library/Application Support/XBMC/addons/script.moviequiz/addon.py", line 20, in <module>
                                                w = MenuGui()
                                              File "/Users/M/Library/Application Support/XBMC/addons/script.moviequiz/quizlib/gui.py", line 83, in __init__
                                                self.database = db.Database.connect()
                                              File "/Users/M/Library/Application Support/XBMC/addons/script.moviequiz/quizlib/db.py", line 79, in connect
                                                return MySQLDatabase(allowedRatings, onlyWatched, settings)
                                              File "/Users/M/Library/Application Support/XBMC/addons/script.moviequiz/quizlib/db.py", line 657, in __init__
                                                dbName = self._find_newest_database(settings)
                                              File "/Users/M/Library/Application Support/XBMC/addons/script.moviequiz/quizlib/db.py", line 680, in _find_newest_database
                                                c.execute('SELECT schema_name FROM schemata WHERE schema_name LIKE "' + settings['name'] + '%"')
                                            KeyError: ('name',)
10:32:21 T:2959781888    INFO: -->End of Python script error report<--
Reply
m0v1em4n, I don't know unfortunately, I'm running XBMC on linux. Perhaps someone else know?

Minoums, it looks like you are using MySQL, but are missing some information in advancedsettings.xml - the name of the database.

Br.
Tommy
Reply
twinther Wrote:m0v1em4n, I don't know unfortunately, I'm running XBMC on linux. Perhaps someone else know?

Minoums, it looks like you are using MySQL, but are missing some information in advancedsettings.xml - the name of the database.

Br.
Tommy

Eden creates its own mysql databases (names change with version) and does not like it when you specify a name in the advancedsettings.xml

Does this script require the name to be specified in there??

Because I did try to run this script in eden (win 7) and got the addon.py failed error as well (I don't have a debug.log yet as I only tried it once with debugging turned off and haven't looked into it further)

Thanks
Reply
Hi aptalca,

Last I checked eden used the name in advancedsettings.xml as a prefix for the database name.
I don't know if that changed in later builds, it's been a while since I tried with mysql.

Are you using version 0.5.0 of the moviequiz?
Please send me a debug log so I can take a look.

Br.
Tommy
Reply
I am not sure when it changed, but I jumped into Eden with the beta 2, and at first I followed the lifehacker guide for mysql (which was originally written for Dharma) and put the <name> tags in there, but xbmc would not start up. It took me a while to figure out that was the problem.

I finally saw the wiki section with the correct advancedsettings.xml that excludes the <name> tags.

I guess the reason for the change is that Dharma was not able to create databases, so the user had to manually create them and specify the names in the xml file. But Eden is able to create and modify the databases itself; and does so with every update. The database names contain the version number, so when you update xbmc, it creates a new database with the new version in the name and moves the old content over. For instance with beta 2 my video database was named MyVideos58, but when I upgraded to RC2, it created a new database named MyVideos60.

PS. My wife is having an American Idol marathon right now and she won't let me tinker. I'll post a debug tomorrow.
Reply
  •   
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 22
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Movie Quiz - how well do you know your movie collection?5
This forum uses Lukasz Tkacz MyBB addons.