[LIVE] XBMC Live on laptop with TV
#1
Hi!

I want share my solution for a problem that i´ve seen lots of questions about here on the xbmc forum.

I´ve got an old laptop with a T7400. It´s enough to play 1080p on my LCD-tv. The laptop has a dvi output. After installation of xbmc on the laptop everything works fine but when i connect the computer to the tv i only get the resolution on the tv as i have on the laptop screen. Normaly when you got any kind of window system (MS or Linux) you can set your resolution either by the FN-Fx keys or by setting the resolution via a gui. On the xbmc-live box you dont have this opportunity.

There is lots of solution for this if you have a nvidia graphics card but not if you have intel gma950 like me.

So what you have to do is to disable the internal monitor in the xorg.conf

So this is how you do it.

get your self terminal windows either by ssh or press ctrl-alt-f1

type

xrandr -d :0 -q

then you will see what you what your outputs is called. Mine is called:

VGA1: external vga output
LVDS1: Laptop scrren
DVI1: external DVI output
TV1: external svga output

then type
sudo service xbmc-live stop
sudo xorg -configure

now you have made a xorg.con.new in your home directory.

type

sudo nano /home/xbmc/xorg.conf.new

Replace the existing Section "Monitor" with the following

#Disable TV1 output
Section "Monitor"
Identifier "TV1"
Option "Ignore" "1"
EndSection

#Disable LVDS1 output
Section "Monitor"
Identifier "LVDS1"
Option "Ignore" "1"
EndSection

#Disable VGA1 output
Section "Monitor"
Identifier "VGA1"
Option "Ignore" "1"
EndSection

#Define DVI1 as primary output
Section "Monitor"
Identifier "DVI1"
Option "primary" "1"
EndSection

in the Section "Device" section add the following lines

Option "monitor-TV1" "TV1"
Option "monitor-DVI1" "DVI1"
Option "monitor-LVDS1" "LVDS1"
Option "monitor-VGA1" "VGA1"

Replace the existing Section "Screen" with the following

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "DVI1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
modes "1920x1080"
EndSubSection
EndSection

Then press crtl-x, the y, the enter

then type
sudo cp /home/xbmc/xorg.conf.new /etc/X11/xorg.conf
sudo service xbmc-live start

Now the computer should only use the external DVI1 output to the tv.

Good luck,
Reply
#2
engstedt Wrote:Hi!

I want share my solution for a problem that i´ve seen lots of questions about here on the xbmc forum.

I´ve got an old laptop with a T7400. It´s enough to play 1080p on my LCD-tv. The laptop has a dvi output. After installation of xbmc on the laptop everything works fine but when i connect the computer to the tv i only get the resolution on the tv as i have on the laptop screen. Normaly when you got any kind of window system (MS or Linux) you can set your resolution either by the FN-Fx keys or by setting the resolution via a gui. On the xbmc-live box you dont have this opportunity.

There is lots of solution for this if you have a nvidia graphics card but not if you have intel gma950 like me.

So what you have to do is to disable the internal monitor in the xorg.conf

So this is how you do it.

get your self terminal windows either by ssh or press ctrl-alt-f1

type

xrandr -d :0 -q

then you will see what you what your outputs is called. Mine is called:

VGA1: external vga output
LVDS1: Laptop scrren
DVI1: external DVI output
TV1: external svga output

then type
sudo service xbmc-live stop
sudo xorg -configure

now you have made a xorg.con.new in your home directory.

type

sudo nano /home/xbmc/xorg.conf.new

Replace the existing Section "Monitor" with the following

#Disable TV1 output
Section "Monitor"
Identifier "TV1"
Option "Ignore" "1"
EndSection

#Disable LVDS1 output
Section "Monitor"
Identifier "LVDS1"
Option "Ignore" "1"
EndSection

#Disable VGA1 output
Section "Monitor"
Identifier "VGA1"
Option "Ignore" "1"
EndSection

#Define DVI1 as primary output
Section "Monitor"
Identifier "DVI1"
Option "primary" "1"
EndSection

in the Section "Device" section add the following lines

Option "monitor-TV1" "TV1"
Option "monitor-DVI1" "DVI1"
Option "monitor-LVDS1" "LVDS1"
Option "monitor-VGA1" "VGA1"

Replace the existing Section "Screen" with the following

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "DVI1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
modes "1920x1080"
EndSubSection
EndSection

Then press crtl-x, the y, the enter

then type
sudo cp /home/xbmc/xorg.conf.new /etc/X11/xorg.conf
sudo service xbmc-live start

Now the computer should only use the external DVI1 output to the tv.

Good luck,

Thanks!!! I was going nuts trying to figure out drivers. I guess most laptops still output even if you disconnect the internal LCD(which I did on my old Dell Mini 9 netbook).

One tip I used X -configure instead of xorg -configure
Don't know what ubuntu release they changed it
Reply
#3
A while ago I found a simpler fix for this issue. Please note, this is not my code, I can't find the original post, but it works.

Basically, If a connection is sensed on VGA output, it switches the laptop LCD off.

create a file in /etc/X11/Xsession.d called 45custom_randr-settings
and enter the following:
Quote:EXTERNAL_OUTPUT="VGA1"
INTERNAL_OUTPUT="LVDS1"

xrandr |grep $EXTERNAL_OUTPUT | grep " connected "
if [ $? -eq 0 ]; then
xrandr --output $INTERNAL_OUTPUT --off --output $EXTERNAL_OUTPUT --auto
else
xrandr --output $INTERNAL_OUTPUT --auto --output $EXTERNAL_OUTPUT --off
fi

now you'll note the first two lines pick the internal or external ports,
so by doing
Quote:xrandr -d :0 -q
first, you can pick which ports you want to set.

You should be able to set it for VGA1 or DVI1 and external output.

Hope this helps someone.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
#4
I have no experiance with linux. I don't know if is this oky, but I'm trying to create file with command:
sudo nano /etx/x11/xsession.d/45custom_randr-settings
and when I try to save file, I get error [ error writing /etx/x11/xsession.d/45custom_randr-settings: no such file or directory ]
Reply
#5
on XBMC-Live 10.1 the above script doesn't work (at least not for me)

Below the script that works for me

Code:
EXTERNAL_OUTPUT="VGA1"
INTERNAL_OUTPUT="LVDS1"

xrandr -d :0 -q |grep $EXTERNAL_OUTPUT | grep " connected "
if [ $? -eq 0 ]; then
xrandr -d :0 -q --output $INTERNAL_OUTPUT --off --output $EXTERNAL_OUTPUT --auto
else
xrandr -d :0 -q --output $INTERNAL_OUTPUT --auto --output $EXTERNAL_OUTPUT --off
fi

P.S.
anything you change on /etc you will loose on reboot, unless you "installed" onto your USB/HDD
Reply
#6
Kanej Wrote:I have no experiance with linux. I don't know if is this oky, but I'm trying to create file with command:
sudo nano /etx/x11/xsession.d/45custom_randr-settings
and when I try to save file, I get error [ error writing /etx/x11/xsession.d/45custom_randr-settings: no such file or directory ]

Hi Kanej

Sorry, command should be
Code:
sudo nano /etc/X11/Xsession.d/45custom_randr-settings

Note the Caps for X11 and Xsession.d folder names.

Sooo, sorry, BIG Typo on my behalf. Also noted I mentioned in the /etx/X11 folder. This should have been /etc/X11...Edit original post above.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
#7
Tks Dude! It worked perfect to me!

(2011-05-18, 01:01)vbat99 Wrote:
Kanej Wrote:I have no experiance with linux. I don't know if is this oky, but I'm trying to create file with command:
sudo nano /etx/x11/xsession.d/45custom_randr-settings
and when I try to save file, I get error [ error writing /etx/x11/xsession.d/45custom_randr-settings: no such file or directory ]

Hi Kanej

Sorry, command should be
Code:
sudo nano /etc/X11/Xsession.d/45custom_randr-settings

Note the Caps for X11 and Xsession.d folder names.

Sooo, sorry, BIG Typo on my behalf. Also noted I mentioned in the /etx/X11 folder. This should have been /etc/X11...Edit original post above.

Reply
#8
Just want to say. This post is very helpful! I help me configure my XBMCbuntu on my laptop to only ouput video to HDTV.
Thanks everyone!!
Reply
#9
Hi,

I tried the solution from vbat99 and created the file: 45custom_randr-settings to use my old laptop as a media player, but nothing happend. XBMC started on the laptop screen and on my beamer (connected to the VGA port) there was no signal...

xrandr -d :0 -q

gives me the connections and they are called DVI-I-0 for the VGA output and LVDS-0 for the internal display

I typed these lines in the file:

EXTERNAL_OUTPUT="DVI-I-0"
INTERNAL_OUTPUT="LVDS-0"

Is that right ?

My system: Intel Core2Duo, geforce 8600M GT XBMCbuntu with XBMC 13.2 installed via USB stick on the main harddrive

Do I need to change something else ? Do you need more information ?

I would be very thankful for your help

Kind regards

Domi
Reply
#10
Please note that this thread you have bumped was started in 2011 and most of the instructions are from then. It is very likely that the suggested fixes will not be the same on current releases
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[LIVE] XBMC Live on laptop with TV51
This forum uses Lukasz Tkacz MyBB addons.