Sound jumps up to max volume
#1
XBMC PRE-11.0 Git:9010cd5
Fedora 14
x86_64
build.sh

I switched form Ubuntu 10.04 to Fedora 14 a few days ago, and when I installed XBMC, I noticed that every time it opens a new music or video file it raises the system volume to max. I've never seen anything like it. I didn't have this problem in Ubuntu. Is there a package or something that I'm missing? For the install I followed the compilation instructions for redhat/fedora on this site. Any help would be greatly appreciated, preferably before I blow out my speakers, please.
Reply
#2
I have the same problem with the same OS. Is this normal? XBMC turns up system volume to 100% every time I play a video? System sound at 100% is much too loud with my speakers. After I am done with xbmc and I play something outside of XBMC, volume is way too high. Is there a way to prevent system volume to go to 100%?

XBMC PRE-10.5 r35695
Fedora 14 x86_64
Reply
#3
Sorry to post in a relitively old thread, but I'm also getting the same issue.

I haven't checked every mixer track (in the "Alsa mixer" app), but XBMC at least sets "Master", "PCM", "Surround", and "Center" to max whenever it starts a video.

If there's any other information that could help solve this issue I'd be happy to provide it.


XBMC: 10.1-1.pm.3.4
OS: OpenSUSE 11.4
Arch: x86_64
Install method: Zypper
Reply
#4
XBMC: 10.1-1.pvr.2mdv2010.2
OS: Mandriva 2010.2
arch: x86_32
install: rpm + auto updates.

Same problem as previous user mention. As soon as media player exits, volume jumps to 100%, both pulseaudio (supposedly used by XBMC) and underlying ALSA channels also jump to 100% volume.

This behaviour started about a week ago. No obvious reason - just standard usual small changes with settings. Suddenly does this on all three systems I have installed XMBC on.

Any Ideas??
Reply
#5
Smile 
At least partly Confused

The "flat-volumes" pulseaudio worm strikes again - Who thought out this logic to the end!
I expect my pulseaudio (which I like) to stay on top of system hardware audio alsa drivers - But respect (mostly) the settings there set by alsamixer. I can set my speaker-system at low volume, so not to blow out the speakers. But f.ex the sound gets heavily distorted on one of my systems when master volume is above 80% (bad layout on MB ...). - Thus I set Max-master volume to 80%, and expect it to stay below that level!

I do not expect it to creep (or jump) to higher and higher levels!

In addition an older version of Mplayer was known to leave the system with volumes set to max causing troubles with pulseaudio/flat-volumes - any connection there?.

So the solution - in my case at least - was to edit the /etc/pulse/daemon.conf and set "flat-volumes = no"

Heated debates can be found if you google 'pulseaudio flat-volumes'

Hope this solves some other similar cases
Reply
#6
That worked for me too, thanks!Big Grin



Note for those new to linux who may find this thread in the future:
You will, of course, need root access to edit the file.
You'll also need to restart pulse audio for the change to take effect. (The simplest method of doing this is restarting the computer.)
Reply
#7
Smile 
flat-volumes = no worked great for me , was having the same problem in ArchLinux
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Sound jumps up to max volume00