[LIVE] Harmony One Configuration
These are the steps SaM said he took...

Quote:First, on the harmony one I changed the delay settings to a 100 ms inter key delay (if you haven’t changed it already it might be where your problem is). In my case I still had the double key press due to both modules being loaded.

In any case, if it can be useful to you or anybody else (credit to whoever found this tip first, I only completed with a few things found with a few searches) :

After installing xbmcfreak maverick v3.
1- Blacklist the lirc_mceusb module so that only the mceusb module will be used :
#sudo sh -c ‘echo blacklist lirc_mseusb >> /etc/modprobe.d/blacklist.conf’

2- Update initramfs
#sudo update-initramfs -u -k all

3- Install input-utils
#sudo apt-get update && sudo apt-get install input-utils

4- Get the device corresponding to your receiver (should be /dev/input/eventX)
#sudo lsinput

5- Get the Vendor and Product id for your device (will be used for the following udev rule)
#sudo cat /proc/bus/input/devices

6- Create a udev rule so that the receiver will always be on a fixed device (I did this because I had a problem with my receiver and a keyboard sometimes switching devices after a reboot). I create a /dev/input/remote “fixed” device but you can use whatever you want. The values 147a and e03e I used are for my IR receiver, use the ones you found in the previous step
#sudo sh -c ‘echo KERNEL==”event*”,ATTRS{idVendor}==”147a”,ATTRS{idProduct}==”e03e”,SYMLINK=”input/remote” >> /etc/udev/rules.d/10-local.rules’

7- reboot or unplug and plug again your IR receiver and verify that /dev/input/remote (or whatever you used) was created properly

8- Reconfigure lirc. On the first question (remote control configuration) select “Linux input layer (/dev/input/eventX)”. On the IR tranmitter question, that depends on your configuration. When it asks for the Custom event interface for your dev/input device, choose /dev/input/remote (the device created at step 6).
#sudo dpkg-reconfigure lirc

9- Launch irw and press buttons on your remote, you should see the key press detected.
At that point your remote should work, but it might need some tweaking to arrange the buttons at your liking or if a few buttons don’t work immediately in xbmc.
If it’s the case continue reading.

10- Still with irw launched, press the buttons on your remote and note their names. irw output should be something like “000000008001006c 00 KEY_DOWN devinput” with KEY_DOWN being the key name in that example.

11- Modify /usr/share/xbmc/system/Lircmap.xml. A more proper way to do this is to create a custom Lircmap.xml in ~/.xbmc/userdata/ for future updates.
Modify the section by following instructions on xbmc wiki with the key names you get with irw : http://wiki.xbmc.org/?title=Lirc_and_Lircmap.xml
My custom Lircmap.xml (specific to my receiver and my remote configuration, so only use it as an example of how to modify it):


You may also want to create your own remote.xml in ~/.xbmc/userdata/keymaps/ by using /usr/share/xbmc/system/keymaps/remote.xml as a reference (see xbmc wiki http://wiki.xbmc.org/index.php?title=Keymap.xml) to adjust the key mapping in xbmc according to your modifications in Lircmap.xml (Not necessary but you can tweak a few things with it).
Does anyone know a command I can run to find the LIRC modules currently loaded and being used?! This would be annoying if the only cause was two modules loaded for the same remote.
Update. After more testing I have found that the double keypress is not only contained to the directional buttons. It was just hard to tell previously that it affected others as well.

So I am back to square one. I have tried interkey delays of 100-800. NO HELP.

I am not exactly sure if I should follow the instructions provided by SaM. I would like to not need to reconfigure everything (if possible).

The remote works... it is just sending double keypresses. Or maybe it is not the Harmony that is the issue. Maybe XBMC is receiving one keypress but then performing the action twice. Huh
I found some information that may prove to be helpful. Obviously, there is the solution posted by SaM... but I would like to avoid that as long as possible. (SaM's information originally came from this thread on the Ubuntu forums)

The other information I found in the advancedsettings.xml (via this post)

The repeat delay for a LIRC remote control. A delay value between 1 and 20 before a remote button starts repeating on a long keypress (ie continuously sending button pushes while it's held down). Defaults to 3.

This used to adjust the amount of time in milliseconds between repeated keystrokes. Used to prevent key-bounce, in other words prevents xbmc (lirc?) seeing one key press as multiple key presses with certain remotes.


*UPDATE* the advanced settings do not seem to help. I messed around with the XML and rebooted between changes... I set the <remoterepeat> to 800 and <remotedelay> to 10. I tried each independently and also together. No help. Sad
Ok, I thought about this in class. I am big on breaking down problems by the process of elimination.

I know mine works well. I have the same IR receiver, a Harmony (a lessor one, but they are using the same remote codes), and otherwise equivalent hardware.

Two things pop out at me as different:

1. Even though USB is a standard, I have noticed some USB ports are erratic. Have you tried a different port? (I know kinda dumb question but I am trying to be thorough)

2. You use XBMC Freak, while I personally only use XBMC Live (Freak has too much stuff for me). I don't know what, if any, differences between the two exist when it comes to LIRC. But even if there is one settings file that is different, or one version that is different then that can sway things.

So I ask: will you rip out the GPU (which is why you are using Freak right?) and just once boot with the Intel GPU in plain Dharma XBMC Live to see if the problem happens there? Because if the same thing happens there, something really funky is happening with the remote by process of elimination. If it magically works, then you rip out the stuff from XBMC Live and shove it into Freak.

I am all for that idea and the logical progression and process of elimination makes sense.

Through my own tests and deduction (without switching to vanilla XBMC Live) I understand that the root cause it not the HP IR receiver or the Harmony Remote.

IRW works fine and will only detect one key press, but XBMC will perform two actions.

This basically eliminates the hardware from the equation. Only rarely does IRW detect 2 events for one key press.

So, as I have stated before, the main cause is the fact that XBMC Freak is using Ubuntu 10.10 Maverick running on the latest kernel. This kernel includes LIRC modules so there may be two modules running.

I will start by trying a different USB port. If things do not get better then I can go back through the process and create a bootable USB with XBMC Live (or maybe OpenELEC.tv). The only reason I chose Freak was the fact that XBMC Live does not have the proper nVidia drivers for the GT430 and I could not get my HTPC to boot. After all of the frustration and fiddling with Live I decided to switch to Freak because it included the needed video drivers. (I hope this is fixed in 10.1, so I can use vanilla XBMC)

At any rate, I will keep you posted on what is happening. I honestly am at a loss right now... I know that the new kernel is causing problems but it also seems to have great support and works nicely besides the double key press.

*UPDATE* I tried another USB port with no success.
bmcclure937 Wrote:The only reason I chose Freak was the fact that XBMC Live does not have the proper nVidia drivers for the GT430 and I could not get my HTPC to boot.

For the purpose of testing the Intel GPU will work fine, you just don't want to use it longterm for playback.

I will admit right now that Temars method of installing the GT430 on XBMC Dharma currently doesn't work because I tried last night. The Nvidia repo changed and threw me a loop. I am working on a way to get it to work for me tonight, and I will happily tell you the secret.

Until then, I am very interested in learning if XBMC Dharma does in fact fix your issues....

My onboard chipset includes an ATI GPU (mobo). I understand that would work as well for testing purposes... Wink just clarifying.

Side Note: not sure what method you are talking about with regards to "Temars" and the GT430.

And I am planning to try OpenELEC.tv first running from a USB flash drive (very fast and easy to install embedded). This way I can salvage my current install on my internal 2.5" drive... and hope that OpenELEC supports the GT430 and I do not have to get behind my HTPC and hook a VGA straight to my TV for onboard graphics. (this is the main reason I do not want to boot into XBMC Live Dharma directly but will resort to this if needed for testing).

I will post back when I am done testing!
Well... OpenELEC.tv works like a charm and was installed to USB and booted in under 10 minutes! (wow that was easy) Big Grin

The nVidia drivers worked right out of the box. OpenELEC TV runs Dharma and has Kernel 2.6.37... which should, in turn, have the latest LIRC.

I am not experiencing any issues currently, but I do not have full functionality with the remote. There is a guide on OpenELEC's site regarding a Harmony.

In the end maybe I will just stick with OpenELEC. But I will have to reconfigure all of my addons, settings, preferences, and re-add my library.

Oh yeah, and I will have to get my audio over HDMI working again Sad I just wish XBMCFreak worked. Well, I should not jump to conclusions about OpenELEC... but it seems like it will work.
bmcclure937 Wrote:I am not experiencing any issues currently,

Are you having the same repeating issues?

No repeating issues on OpenELEC but I am going to do some more digging... since the remote is not fully functional at the moment.

There is no hardware.conf present for the remote and it seems to use the mceusb embedded kernel module.

This will take some configuring to get working as intended, but this is not an issue as long as no button repeats occur.

As I said though, I will need to reconfigure all of my settings to match those that I am using on XBMCFreak (including content sources, audio, skins, add-ons, etc).

Is there a simple way to back up all settings and add-ons to transfer to another installation?

I had to manually get the audio working over HDMI on my current install. I can go through that process again if needed. (too bad XBMC does not work with HDMI audio out of the box! seems like everything with XBMC Live does not work properly with the GT430 out of the box... Sad)
Wow... well the XBMC Community servers were all jacked up and I lost my reply. Rolleyes That is highly annoying...

anyhow, I tried this method:

Quote:2. Blacklist the kernel source drivers and use the old dkms built drivers.
-Well you already have lirc-sources-modules install and probably had this working on 10.04 or older version of ubuntu.
A. Edit /etc/modprobe.d/blacklist.conf , create it if it doesn't exist.
blacklist mceusb
line to the file and save it.
B. Update initrmafs, #sudo update-initramfs -u -k all
C. reboot
D. Reconfigure lirc if its not already working.
#sudo dpkg-reconfigure lirc
On the Remote, Select "Windows Media Center Transceiver/Remote (All)
E. Thats it.
This is the method I chose after wrestling with button repeats on option

and it did not fix my problem Sad not sure if this blacklisted the module properly or not
Okay, an update on my situation! First, the above blacklisting methods did not work... but a suggestion on the XBMC Freak site does work to stop the double key presses.

spencers Wrote:I followed this suggestion and it solved the issue.


I wish this suggestion would have been posted much earlier. I gave up on all of those methods and decided to go with OpenELEC.tv (a much lighter XBMC flavor).

XBMC Freak essentially includes 2 LIRC modules (one in kernel) and they repeat key presses. Stare

So now I have ditched Freak in favor of OpenELEC.tv Big Grin OpenELEC does a great job including only necessary packages. My nVidia GT430 video worked out-of-box and I simply used my asound.conf file from my XBMC Freak install to get my HDMI audio working.

The Harmony Remote was straight-forward and am now tweaking buttons to my liking! This is how the experience should have been from the start! Shocked Props to the OpenELEC crew for getting it right and almost 100% perfect.
Other than the remote issues, did you have any other problems with XBMCFreak initially?

Logout Mark Read Team Forum Stats Members Help
[LIVE] Harmony One Configuration1
This forum uses Lukasz Tkacz MyBB addons.