[AppleTV2] Can't play VIDEO_TS folders or .ifo files
#1
I recently installed XBMC on my ATV, but have been unable to play DVDs on a remote share. All of these file play fine on XBMC running on my laptop and configuration for the sources seems to be the same across both devices.

I've been looking around, but have been unable to find anything online, so I was wondering if perhaps someone here could help. Here's the relevant excerpt from the log file (with debug output enabled):

13:46:40 T:160690176 M:109383680 NOTICE: DVDPlayer: Opening: smb://JRSERVER/Movies and DVDs/Porcupine Tree - Arriving Somewhere/VIDEO_TS.IFO
13:46:40 T:160690176 M:109383680 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
13:46:40 T:175132672 M:109379584 DEBUG: thread start, auto delete: 0
13:46:40 T:175132672 M:109379584 NOTICE: Creating InputStream
13:46:40 T:175132672 M:109375488 INFO: msg: libdvdnav: Using dvdnav version 4.1.3
13:46:40 T:175132672 M:109375488 DEBUG: libdvdread: Encrypted DVD support unavailable.
13:46:40 T:175132672 M:109375488 DEBUG: CFileSMB::Open - opened Movies and DVDs/Porcupine Tree - Arriving Somewhere, fd=-1
13:46:40 T:175132672 M:109375488 INFO: FileSmb->Open: Unable to open file : 'smb://UserTongue[email protected]/Movies%20and%20DVDs/Porcupine%20Tree%20%2d%20Arriving%20Somewhere'
unix_err:'15' error : 'Is a directory'
13:46:40 T:175132672 M:109375488 INFO: msg: libdvdread: Could not open input, smb://JRSERVER/Movies and DVDs/Porcupine Tree - Arriving Somewhere.
13:46:40 T:175132672 M:109375488 INFO: msg: libdvdread: Can't open smb://JRSERVER/Movies and DVDs/Porcupine Tree - Arriving Somewhere for reading
13:46:40 T:175132672 M:109375488 DEBUG: libdvdnav: vm: failed to open/read the DVD
13:46:40 T:175132672 M:109375488 ERROR: Error on dvdnav_open
13:46:40 T:175132672 M:109375488 ERROR: CDVDPlayer::OpenInputStream - error opening [smb://JRSERVER/Movies and DVDs/Porcupine Tree - Arriving Somewhere/VIDEO_TS.IFO]
13:46:40 T:175132672 M:109375488 NOTICE: CDVDPlayer::OnExit()
13:46:40 T:175132672 M:109375488 NOTICE: CDVDPlayer::OnExit() deleting input stream
13:46:40 T:175132672 M:109375488 DEBUG: Thread 175132672 terminating
13:46:40 T:160690176 M:109375488 DEBUG: CAnnouncementManager - Announcement: PlaybackStopped from xbmc
13:46:40 T:160690176 M:109375488 ERROR: Playlist Player: skipping unplayable item: 0, path [smb://JRSERVER/Movies and DVDs/Porcupine Tree - Arriving Somewhere/VIDEO_TS.IFO]
13:46:40 T:160690176 M:109375488 DEBUG: Playlist Player: no more playable items... aborting playback
13:46:40 T:177737728 M:109375488 DEBUG: Thread 177737728 terminating

Any idea of what else can I do to diagnose this or what could be going wrong? Any help would be greatly appreciated.

Probably should add that all other video files seem to play fine, including the individual .vob files. Trying to play the .ifo file from the file list instead of going through the library interface fails as well.

Apple TV Version: 4.2.1
XBMC: XBMC PRE-10.0 GIT:CEES417 (COMPILED : FEB 7 2011)
Full log: http://pastebin.com/8RRLU76K
Reply
#2
I have the same problem. I have XBMC on my ATV 1G and all the video_ts.ifo files play fine. On my ATV 2G they will not play. They will not play on my iPhone 4 XBMC installation either.

I can play the VOB files directly but clicking on the .ifo file will not play.

Shawn
Reply
#3
i have this same problem while trying to view dvd files from video ts folders. if i try to play them from library mode, it will error out. if you go into the folder from file mode you can select individual vob files and they will playback. it seems the library just has a problem pointing to files, rather than the ios version of xmbc having a problem playing video ts folders.
Reply
#4
Got the same problem, would love to see a fix Nod
Reply
#5
Why bother ? Use Handbrake for one-click conversion to x.264 mkv.
Arctic MC001 + Openelec
[Image: widget]
Reply
#6
Add ISO files to the list too for me. They are Mpeg2 DVD rips over an SMB share. Although, I think my problem might be the same SMB problem many others are currently having.
Reply
#7
please read the sticky threads:

http://forum.xbmc.org/showthread.php?tid=91581

"XBMC for iOS current issues at a glance:"

"video_ts playback will not work if menus are included in addition to video files"

(same for ISOs with menus)
Reply
#8
derbroti Wrote:please read the sticky threads:

http://forum.xbmc.org/showthread.php?tid=91581

"XBMC for iOS current issues at a glance:"

"video_ts playback will not work if menus are included in addition to video files"

(same for ISOs with menus)

I dont think video_ts without menus is working at this time either.

Before upgrading to the newest release I could play my video_ts but now it crashes to the main menu each time.

Also, all my iso files are movie only, all menus stripped and it crashes playing those also.

These are files made with dvdshrink, all menus and encryption stripped out.
Reply
#9
dtviewer Wrote:Also, all my iso files are movie only, all menus stripped and it crashes playing those also.

These are files made with dvdshrink, all menus and encryption stripped out.

I could have specified this too....I have the exact same issue with the same "types" of ISO (stripped of menus and subtitles using dvdshrink)
Reply
#10
With the last unofficial build VIDEO_TS folders with stripped menus are working again. Smile
Reply
#11
sorry, it seems I hadn't had the newest version installed... the current official version does not play video_ts at all, regardless of the existence of a menu.
Reply
#12
I can't view any ripped DVD's (video_ts / vob / ifo) either. Some of mine have the menus, some have been stripped, and neither work. Just about everything else seems to be working. The overscan correction is a little off at the bottom, but I might be able to just use a different skin. Also, the web interface doesn't work, so I couldn't import my libraries from my PC, which meant lots of typing with the AppleTV remote - no fun.

Having said all of that - when the kinks are worked out, this is going to be SWEET! 1080p (displayed in 720) seems to be stutter-free for me.
Reply
#13
piotr Wrote:Why bother ? Use Handbrake for one-click conversion to x.264 mkv.

Why? Because I don't want to go and convert +250 ISO's to MKV's maybe? Huh

BTW, it's not that I didn't try. The MKV's made with MakeMKV don't work (buffering every minute).

Handbrake-versions might work, but it takes an hour to convert 1 DVD.
I'm not gonna put al that work in it, because I'm certain the devs are going to solve this problem, like they did it with the other versions of XBMC!
That's just how awesome they are! Cool
Reply
#14
newsilentsilver Wrote:With the last unofficial build VIDEO_TS folders with stripped menus are working again. Smile

Thats good to know....now I just have to figure out how to upgrade to a nightly.....
Reply
#15
Do you refer to this build ....?
http://forum.xbmc.org/showthread.php?tid...ck+version
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[AppleTV2] Can't play VIDEO_TS folders or .ifo files00