Thread Rating:
  • 0 Vote(s) - 0 Average
XBMC on ATV2 adding SMB shares
Hi All,

I've managed to jailbreak my ATV2 with greenpois0n.
Now when adding SMB shares it will not detect any. And when I want to add UPNP server it won't allow for the OK button.
Are there solutions to this?

You first have to allow the shares on your pc......go to the drive of folder you want to share and right click.......go to share and tweak the settings to allow it to be shared.....then they adding it to XBMC smb shares......also....the pc has to me in the same wireless network for this to work......hope this helps....Rolleyes
Solved! had to change the workgroup name and a restart from the SSH session helped, thanks!
I've been having redouble setting some smb shares.......I can find the folder to share but XBMC asks for passwords and usernames......when I try to add the smb share....any advice?
Is this Windows 7?...

a) On the shared directory, always make sure you have appropriate file permissions (right click Properties->Security tab->'Edit' button.. add 'Everyone' user with read permissions)

b) On the shared directory, always make sure you have appropriate share permissions (right click Properties->Sharing tab->'Advanced Sharing'->'Permissions'->'Add'.. add 'Everyone' user with read permissions.

Well I had to do these steps for my setup. Hope this works for anyone out there.
I've done that and I'm still being asked for lock settings username and password......could it be that my files are on a USB drive connected to pc? I can set up smb just fine off my root c drive just docent ask me for any lock settings!
applesinafton, have you updated to the latest release? There's an smb bug when accessing shares from a Win7 PC that have only recently been fixed. If you aren't sure, posting a debug log would help us figure it out.
I'm on a vista pc......I'll try to update XBMC i said.....smb shares are fine on my root c drive.....not a problem...but when on my USB root g drive I'm being asked for lock settings information....thanks for the help!
Must have something to do with either share rights or file rights on that drive. Check them in your windows machine, it has nothing to do with being on a USB drive or not trust me.
I'll check again on my pc....I think I have any possible rights allowed......I have all my media on that drive to save space on my 80 gb pc.....I think a nas is in order soon.........thanks again........

Update: I found the solution. My shares from the root c drive was easy. Just turn on file sharing and the c drive is shared and the security setting are turned off automatically via the os. The problem arose when I wanted to share a drive added to the pc hardware. Not only do you have to allow permissions to share the drive as well as the folders in that drive, you have to change the security settings for the root drive your sharing in the security tab in the sharing window. Now I can use XBMC for all my personal media as well as all the great plugins available from the community. This was a good lesson for me....thanks for the help folks.......

XBMC on ATV2 adding SMB shares00