Thread Rating:
  • 0 Vote(s) - 0 Average
Greenp0ison JB ATV2 not working after tethered JB
Been reading and testing a ton but I am stuck. Here is the scoop.

I was successfully jailbroken on 4.2 (4.1.1) using the tethered jailbreak with no issues. Like a dumbass, I decided i wanted to go unthethered to keep the wife happy in the event of a power outage.

First, I restored the system to stock. To do this, I plugged the ATV using only the microusb and no power to my laptop and did a regular restore. All went fine and the unit boots normally and can be configured. I can repeat this with no issue.

Second, I attempted the JB using the instructions in this post:

All works fine until the unit needs to be rebooted after the jailbreak is finished. The unit will come to the apple logo and hang. I have tried the method above as well as the method in the GP instructions on screen which involve leaving the power plug in. No go. I tried reloading stock multiple times and attempting the GP JB again with no luck. It always the same with the unit stuck at the apple boot logo.

Finally, I decide I will stick with the tethered method until this gets smoother. When I restore my custom firmware and tethered boot, my network no longer works. This was the same custom firmware that worked previously. I even went so far as to create another custom firmware and try it that way but im running into the same issue with networking.

So now I'm totally ****** Sad Anyone got any suggestions??

By the way, thanks to all the guys who help out and contribute here. Us noobs appreciate it.

What if you were to start over from scratch, jb again with Greenp0ison, then uninstall NitoTV immediately after. Then reboot and see what happens. It seems from the post I read that it is NitoTV that is causing the loss of wifi after the reboot. I experienced it this morning.

To uninstall NitoTV, I did this:

ssh in:

Type apt-get update

Type apt-get remove com.nito.nitotv

Type killall AppleTV
Why don't you try your luck with the newly released pwnage tool? Seems that you have a mac anyway Big Grin
Forgive your enemies, but never forget their names.
I'm the author of those steps you tried.. well, when you refer to the reboot phase, is this after the Inject Software step completes and it says "Installation successful. Press Menu to reboot" ?

For me, this part was weird but I video taped the whole session so I can tell you exactly what I did... I just reviewed the video so this is precisely what happened to me...

After "Installation successful. Press Menu to reboot"?, well I pressed Menu to reboot. But it sat there. Pressed Menu a few times. After 8 seconds of pressing Menu button, it refreshed the screen with the standard AppleTV menu with greenpois0n menu there. I then went to 'About' under greenpois0n menu (out of curiousity) and that's when the screen went blank for 5 seconds then the AppleTV menu came up again, this time with greenpois0n menu not there, and nitoTV menu not there.

This is where I figured maybe it needed a forced reboot .. so I unplugged power cable for 10 seconds and replugged it back in.

This is where it took a long time to show anything on the TV. It took a full 50 seconds for the AppleTV menu to show after plugging back the power cable (the apple logo never even showed up for some reason). But the AppleTV menu was good, i.e. nitoTV was right there in the middle.

I am not getting to the inject portion of the jailbreak. I am at the step where the jb completes, but before I get the apple tv to boot and show the inject option.

After I complete the jailbreak (GP completes and I wait the 45 secs) i unplug the usb and plug power and the hdmi, the apple logo appears and then hangs.

Thats where im stuck


Maybe you have the same problem as the other guy I helped in the other thread. Please see below;

Originally Posted by macmel
Ok, I understand now. And I know what your problem is, you are using the wrong version of the Apple TV2 Firmware. You should use the below firmware. Hope this help


BTW; Just do the greenpois0n JB, there's no need to run Seasonpass

Originally Posted by pokwer
On dear god, YOU'RE RIGHT! SeasonPass is what downloaded the other version so I just kept that as the IPSW to use.

Thank you so much for persisting and asking all your questions. I'm installing xbmc again as we speak.

Thank you again!
Forgive your enemies, but never forget their names.
Have you tried waiting a good amount time above and beyond the 45 seconds?
Did you restore to 4.2.1 before jailbreaking (i.e. AppleTV2,1_4.2.1_8C154_Restore.ipsw)?

I have jailbroken two AppleTVs recently without any issues. The method I used is something like:

-- Restore back to stock standard 4.2.1 (should always revert back to a stock standard build before any JB).

1. Plug in power cord, wait 10 seconds or so.
2. Plug in the mirco-USB cable, wait for a constant pulsing LED on the front of the ATV.
3. Press and hold Menu/Play for 7 seconds, LED light should start pulsing faster after like 5 seconds of holding Menu/Play.
4. Release Menu/Play, ATV is now in DFU mode.
5. Launch the greenp0ison JB, click "Jailbreak"
6. Wait for it to complete.
7. Wait an additional minute/2-mins to be sure it has completed. Go grab a drink or listen to a song or something, giving it a little extra time isn't going to hurt.
8. Unplug everything and connect the ATV up to your TV with HDMI, power and network.
9. Wait for it to launch and then perform the additional software injection.
10. Press 'Menu' after the additional software has been installed, this will reboot the ATV.
11. Wait for it to boot, you should now be able to SSH into the machine.
12. From terminal perform the following (replace with IP of your ATV, password for root on ATV is 'alpine'):

ssh [email protected]
echo "deb ./" > /etc/apt/sources.list.d/xbmc.list
apt-get update
apt-get install org.xbmc.xbmc-atv2

You will get an error that it encountered an error, this is just the 'killall Lowtide' command failing, but XBMC will have been installed.
nito TV has been updated and you can install XBMC from nTV menu instead.
MIFcom Mini-ITX ASUS ION2 | 4GB RAM | 120 GB SSD | LibreElec 8.01 / Kodi 17.1
Philips 42PFL8684
I also read somewhere else to make sure the laptop your using to JB with must be connected to the internet throughout.
right, internet connection is needed for the jailbreak. You're connecting to ethernet wire correct? Maybe you can unplug/plugin your router before the jailbreak. To ensure DHCP leases are all reset and the AppleTV2 successfully acquires an internet connection through the router.
swirlman Wrote:After I complete the jailbreak (GP completes and I wait the 45 secs) i unplug the usb and plug power and the hdmi

If this is really what you are doing, then this is your problem. After running the jailbreak you are supposed to connect power first, then remove USB and plug in HDMI. Ie, the ATV should not lose power at all during this process as it's not yet untethered.
thanks for all the replies,

Yes, the laptop I am using is connected to the net. The atv is also connected via hardwire. I did do a restore with the latest ispw. I even used a fresh laptop that didn't have iTunes installed previously and let it download a new one from apple.

I have let the unit sit pas the 45 seconds after the JB but I think the longest was like a minute thirty. I'll try letting it go longer.

Gonna give this another go round today, but thanks for all the responses.
Did you see my post about the order of powering off just before your post?
DING DING!!! We have a winner!

AaronD's suggestion about not removing the usb until power was inserted was the trick.

Just a couple of points to add:

After I restored to factory, I went in and setup the wifi. When the time came to JB I was already and wifi and it downloaded the necessary files that way.

Huge thanks to all (especially Tosh and AaronD). My wife will now be happy!

I hope this helps someone else out there avoid some headaches.

swirlman Laugh

Greenp0ison JB ATV2 not working after tethered JB00