[Linux] Probem with Criterion Collection BD rips Playback
#1
Sad 
I have a large collection of Blu-Ray disks that I decided to rip the main feature of into MKV using makemkv and use XBMC to play them back. I found that I have a big issue with many (but not all) the Criterion Collection rips. Many of them seem to play back in (very) slow motion, like 2 frames a second or so (actually when I turned on debugging it displayed 3.9FPS !) while other Criterion Collection BD rips playback fine (24.0 FPS). Only Criterion BD rips have this problem. Also, if I use VLC (unfortunately on a different computer so it may not be a valid test) the same problematic rips playback just fine.

I am running XBMC 10.0 r35648 (Compiled : Dec 17 2010)
Ubuntu Lucid (10.04) - 2.6.32-29-generic #58-Ubuntu SMP i686
The XBMC computer is a Giada N20 (1.8GHz Intel Atom D525 dual-core processor, 2GB RAM, NVIDIA ION 2 graphics card)

I ran mediainfo on two such MKVs, one on a rip that works fine and another on one that does not but I didn't see anything that caught my eye.

Broadcast news (works fine) mediainfo: http://pastebin.com/8TMeCDJq
Amarcord (has the slow-mo problem) mediainfo: http://pastebin.com/d6hMS8We

I can see in the log many errors like the following:

Code:
ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
ERROR: AddPackets - failed to add leftover bytes to render
DEBUG: CDVDPlayerAudio:: Discontinuity - was:1143487.115000, should be:135000.000000, error:-1008487.115000

Log file for movie with playback problems: http://pastebin.com/tvPHHBPk
Log file for movie which playback fine: http://pastebin.com/CmjURBpS

Any idea what may be the problem and how to fix it?
Reply
#2
Sad 
Well, after trying all kind of permutations I ended up figuring out that the problem is that XBMC has a problem playing back the PCM stream which slows down the playback to less then 4 FPS. I ended up converting, in one case as a test, the PCM stream to AC3 and now the playback is fine.

What I am confused about is the fact that VLC has no problem playing back the PCM version. Why does XBMC have this problem?
Reply
#3
In case anyone else runs into the same problem, it has to do with mono PCM which Dharma has a problem with.

See my bug report: http://trac.xbmc.org/ticket/11284
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[Linux] Probem with Criterion Collection BD rips Playback00