XBMC freezing on mkv playback
#1
Hi All

I'm having an issue where when i load an mkv moive xbmc hangs on the working symbol. if i close xbmc and reopen then it will work fine, but it won't work from a computer restart or power off power on (standby and hibernate are ok tho).

Was originally working fine from fresh install (on 10.0) but then it would hang on starting the mkv. Have tried loading the file directly and in library but same issue.

Details:
Using Win 7 32 bit
D510 with ion2 (xs35gt)
2gb ram
Nvidia driver 257.3
XBMC 10.1 (had same issue on 10.0)
debug log http://pastebin.com/UptB0ZV1


Any help would be greatly appreciated
Reply
#2
You need to enable debug logging from System settings, System, Debugging.

Presumably the problem is related to the log entry:

ERROR: CThread:ConfusedtaticThread : Access violation at 0x6b3e17c3: Reading location 0x00000124

Hopefully with debug logging enabled it will be clearer what's causing this error.

JR
Reply
#3
New log link
with debug enabled
Reply
#4
It's definitely a crash. Does it do it on all videos or just some? If the latter, is there any obvious pattern to what will play and what won't?

Later: it might be worth downloading my modified version of v10.1 from http://swarchive.ratsauce.co.uk/xbmc/XBM...110315.zip as this contains extra debugging info, and this will tell us which thread is crashing. I'd bet it's CDVDPlayer, but for the small effort involved it seems worth checking this.

JR
Reply
#5
Can you try with DXVA turned off.
Reply
#6
I have the same issue and the exact same hardware as the OP and can confirm that turning off DXVA2 solves the issue with not being able to play MKV-files - BUT with the inferior hardware, playing MKV without hardware axelleration is not possible without stuttering.

Playing DVD images works fine.
Reply
#7
It crashes on all mkv files, playing avi files works fine.

tried turning dvxa2 off and the mkv files would play (just not very watchable)


new pastebin using modified v10.1 link
Reply
#8
Ok it looks as if it is indeed the CDVDPlayerVideo thread that's crashing, but that doesn't take us much further.

Grasping at straws really, but if you copy the film to the local hard disk does it crash as well?

My guess would be a video driver problem.

JR
Reply
#9
updated the nvidia drivers to 266.58 using the modified inf method, all working now
Reply
#10
sdiddy88 Wrote:updated the nvidia drivers to 266.58 using the modified inf method, all working now

Thanks, that's worth knowing.

JR
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
XBMC freezing on mkv playback51