[AppleTV2] 4.3 Support?
#16
DN38416 Wrote:I'm having issues installing xbmc again after jailbreaking the latest firmware.

Anyone know how to fix this?
Apple-TV:/private/var/tmp root# dpkg -i org.xbmc-20110401-97b5e9f_atv2-arm-private.deb
Selecting previously deselected package org.xbmc.xbmc-atv2.
(Reading database ... 1322 files and directories currently installed.)
Unpacking org.xbmc.xbmc-atv2 (from org.xbmc-20110401-97b5e9f_atv2-arm-private.deb) ...
dpkg: dependency problems prevent configuration of org.xbmc.xbmc-atv2:
org.xbmc.xbmc-atv2 depends on org.xbmc.xbmc-seatbeltunlock; however:
Package org.xbmc.xbmc-seatbeltunlock is not installed.
dpkg: error processing org.xbmc.xbmc-atv2 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
org.xbmc.xbmc-atv2

I'm having the same issue here using PwnageTool 4.3 as the jailbreak method.

I followed the instructions in the Unofficial builds for testing! NOT FOR THE FAINT HEARTED View Single Post thread as I did before with the previous Seas0nPass jailbreak, which did work at that time.

On further investigation, too...

Code:
Apple-TV:/var/mobile root# apt-get install org.xbmc.xbmc-seatbeltunlock
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  org.xbmc.xbmc-seatbeltunlock: Depends: bsdiff but it is not installable
                                Depends: gawk but it is not installable
E: Broken packages

Code:
Apple-TV:~ root# apt-get install bsdiff gawk
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Package bsdiff is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package bsdiff has no installation candidate

It seems like PwnageTool might've forgotten to install a couple of required tools?
Reply
#17
I thought all that was needed was openssh... and the rest could be installed manually?

Or is xbmc not even compatible with the latest firmware? (8F202)
Reply
#18
DN38416 Wrote:I thought all that was needed was openssh... and the rest could be installed manually?

Or is xbmc not even compatible with the latest firmware? (8F202)

It's definitely compatible as I've used it with the Seas0nPass tethered jailbreak prior to today. It's likely as issue with just missing packages in PwnageTool.
Reply
#19
But did Seas0nPass use this firmware AppleTV2,1_4.3_8F191m_Restore.ipsw
or this one AppleTV2,1_4.3_8F202_Restore.ipsw?
Reply
#20
I am having the same issues (seatbeltunlock(?)) as some other folks here. Jailbroke it using pwnage, everything good. Tried to install XBMC from Nito didnt work, same with ssh-ing an install as well as a nightly build, none worked.
Reply
#21
Looks like with the new jailbreak that came out today you can't install xbmc? Wait for more reaction before i go to 4.3.1
Reply
#22
sauriks package is missing.

add it with:

Quote:echo "deb http://apt.saurik.com/ tangelo-3.7 main">/etc/apt/sources.list.d/saurik.list

then do a

Quote:apt-get update

and the install the missing dependencies with

Quote:apt-get -f install

After that you are ready to go...

BUT: you have to install the latest nightly to be able to use hw-acceleration for h264-files.

EmKay
Reply
#23
how do u add this to the installer?
Reply
#24
Thanks emkay, that did the trick! Figured it was something simple like that. Smile
Reply
#25
That did it, XBMC starts now
Reply
#26
Please Help im new on how to do this
Reply
#27
Thanks emkay Big Grin
Reply
#28
nerver mind got it working, thanks guys
Reply
#29
nice that it works now for you all.

But now I have the problem, that everytime I want to play a video a popup tells me that the sound device could not be initialized (and the video stutters). is anyone here with the same problem?
Reply
#30
emkay Wrote:nice that it works now for you all.

But now I have the problem, that everytime I want to play a video a popup tells me that the sound device could not be initialized (and the video stutters). is anyone here with the same problem?

Yes, thats me too. Also I could not get onto an SMB share, but that might be something else entirely of course.
Reply
 
Thread Rating:
  • 3 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
[AppleTV2] 4.3 Support?43