Thread Rating:
  • 2 Vote(s) - 3 Average
XBMC always on top
#1
Hi all,
Like many of you, I have been using XBMC fully satisfied with it. I have used it for years on my AppleTV. Now I sold my ATV and have XBMC installed on a (secondhand) MacMini. (because I want to use a USB DAC).

This also gives me the opportunity to fully take advantage of my premium Spotify account.

I do not want to use a mouse or keyboard, the Mini is stashed away. I want to use the XBMC and Spotify iPhone remotes.

Here I run into a problem. Whenever I use the Spotify remote (on iPhone), the Spotify app in OSX pops up and covers XBMC. Using XBMC remote, does not make XBMC top window.

Is there any way to force XBMC on top (the window option Float on top does not have desired effect), or to have Spotify forced in the background?

A simple Option + Tab would suffice, but I do not want a keyboard in the living room.....
Reply
#2
add addvancedsetting.xml and in it put videoscreen.fakefullscreen=false.

then XBMC for OSX will use a real fullscreen OpenGL and nothing will get on top of it... ever.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#3
Sweet. Will try tomorrow.
Reply
#4
What i did is create a file called "advancedsettings.xml" I put it in

XBMC (show package contents) > Resources > XBMC > userdata.

This is the contents of the file:

Code:
<advancedsettings>
    <videoscreen>
        <fakefullscreen>false</fakefullscreen>
    </videoscreen>
</advancedsettings>

I restarted XBMC, but still Spotify comes on top whenever I use the Spotify remote.

What am i doing wrong?
Reply
#5
I have also tries just adding

"videoscreen.fakefullscreen=false"

To an empty advancedsettings.xml

Nothing either
Reply
#6
check xbmc.log, it will report info about any advancedsettings.xml that is found and parsed.

also it does not go into xbmc.app, goes into ~/Library/Application\ Support/XBMC/userdata/
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#7
Davilla, thanks a bunch! Works like a charm.

I am now 100% happy with my setup.

regards!
Reply
#8
Thanks so much davilla, I searched long and hard for this. I don't understand why this wouldn't be a default option. Who could possibly want windows popping up in front of the media center and stealing focus so you can't use the remote any more? Anyhow, I'm so glad I finally found a solution.

For any weary traveller that finds this thread later, the solution is the following

step 1) go to the directory
~/Library/Application\ Support/XBMC/userdata/

where ~ is your home directory

step 2) create a file called "advancedsettings.xml"

step 3) put the following text inside:

<advancedsettings>
<videoscreen>
<fakefullscreen>false</fakefullscreen>
</videoscreen>
</advancedsettings>

step 4) save the file and restart xbmc

step 5) Huh

step 6) Profit!!!
Reply
#9
(2011-03-30, 10:44)digyourownhole Wrote: Davilla, thanks a bunch! Works like a charm.

I am now 100% happy with my setup.

regards!

A question for you. Do you use Growl ? If so, do growl notifications continue to be displayed after adding the advanced setting.
Macmini Server 2011 i7 Quad Core, OS 10.8.2, Amp Onkyo TX-SR308 USB WD drives 3x2TB TV Samsung Plasma 720p EyeTV Integration
There are only 10 kinds of people in this world, those who understand binary, and those who don't.



Reply
#10
(2012-11-25, 04:35)activate Wrote:
(2011-03-30, 10:44)digyourownhole Wrote: Davilla, thanks a bunch! Works like a charm.

I am now 100% happy with my setup.

regards!

A question for you. Do you use Growl ? If so, do growl notifications continue to be displayed after adding the advanced setting.

No. Nothing, I repeat, nothing will be allowed above XBMC when running with fakefullscreen == false.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#11
Okidoki, thanks.
Macmini Server 2011 i7 Quad Core, OS 10.8.2, Amp Onkyo TX-SR308 USB WD drives 3x2TB TV Samsung Plasma 720p EyeTV Integration
There are only 10 kinds of people in this world, those who understand binary, and those who don't.



Reply
#12
Except for that bug that keeps flying around my room at night... get off my screen, bug!
Reply
#13
(2012-11-25, 02:46)scstraus Wrote: Thanks so much davilla, I searched long and hard for this. I don't understand why this wouldn't be a default option. Who could possibly want windows popping up in front of the media center and stealing focus so you can't use the remote any more? Anyhow, I'm so glad I finally found a solution.

For any weary traveller that finds this thread later, the solution is the following

step 1) go to the directory
~/Library/Application\ Support/XBMC/userdata/

where ~ is your home directory

step 2) create a file called "advancedsettings.xml"

step 3) put the following text inside:

<advancedsettings>
<videoscreen>
<fakefullscreen>false</fakefullscreen>
</videoscreen>
</advancedsettings>

step 4) save the file and restart xbmc

step 5) Huh

step 6) Profit!!!

I also tried this but didn't solve my problem. If I use this configuration in advancedsettings I have the TV completely black and didn't found error on log files. The only things I can do is to press the CMD+Q for exit. I'm using a MAC MINI MID 2011.
XBMC 1 : XBOX + HD 2,5" 160Gb + Case SILVERSTONE LASCALA LC04 + Logitech Harmony ONE remote
XBMC 2 : ATV2
NAS server : CPU Intel ATOM 1,6Ghz + MB ECS 945GCT-D + 1Gb RAM + Storage 160Gb 2,5" for O.S. and 1Tb 3,5" for data + Windows XP
Reply
#14
(2013-03-07, 01:06)pedal2metal Wrote:
(2012-11-25, 02:46)scstraus Wrote: Thanks so much davilla, I searched long and hard for this. I don't understand why this wouldn't be a default option. Who could possibly want windows popping up in front of the media center and stealing focus so you can't use the remote any more? Anyhow, I'm so glad I finally found a solution.

For any weary traveller that finds this thread later, the solution is the following

step 1) go to the directory
~/Library/Application\ Support/XBMC/userdata/

where ~ is your home directory

step 2) create a file called "advancedsettings.xml"

step 3) put the following text inside:

<advancedsettings>
<videoscreen>
<fakefullscreen>false</fakefullscreen>
</videoscreen>
</advancedsettings>

step 4) save the file and restart xbmc

step 5) Huh

step 6) Profit!!!

I also tried this but didn't solve my problem. If I use this configuration in advancedsettings I have the TV completely black and didn't found error on log files. The only things I can do is to press the CMD+Q for exit. I'm using a MAC MINI MID 2011.

yep same for me. mid 2011 mac mini when i add that setting to advanced settings i get a black screen in xbmc. if i press / to toggle window mode, my window gets smaller and i can navigate around. but if i press / again to maximize black screen.
Reply
#15
and what about Command T ?
Macmini Server 2011 i7 Quad Core, OS 10.8.2, Amp Onkyo TX-SR308 USB WD drives 3x2TB TV Samsung Plasma 720p EyeTV Integration
There are only 10 kinds of people in this world, those who understand binary, and those who don't.



Reply



XBMC always on top32