•  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 14
  • Next 
 
Thread Rating:
  • 2 Vote(s) - 5 Average
Problem with Apple TV 2 - 4.3.1 with Jailbreak
#16
Hi Devs,

More infos on the sound problem can be found here: http://forum.xbmc.org/showpost.php?p=767...stcount=64

EmKay
Reply
#17
Platform (AppleTV2)
Version of iOS (4.3.1)
Build version number and date compiled (97b5e9f Compiled April 1 2011)
Install Method (apt-get & dpkg) Used Pwnage tool today

http://pastebin.com/DzqzLYAW
TV: VIZIO E-Series 43”
HTPC: Raspberry Pi 3
STORAGE: Windows 8 Server with DrivePool (Currently with 24TB)
Reply
#18
hello boys! pff, i used pwnage tool, and jailbreak my apple tv 2g, the first problem solved with help emkay, but the second poblem no solved

no sound in the first lauch, i changed settings to hdmi sound and now xbmc boot, i select the channel, enter in the megavideo and appletv reboot lowtide...

can anyone help me?
Reply
#19
Sad 
Hi all,

I could get my NAS connected via zeroconf, bur smb is still not working. I also have the issue with the sound. I tried HDMI in any version, no sound.

P.S: I have my syslog file, but I am not sure which part you need. Mabye this extract helps. Let me know if you need more... or anotehr part.

Code:
Apr  4 17:02:42 AppleTV AppleTV[90]: BRDisplayManager: *** DISPLAY UNPLUGGED ***
Apr  4 17:02:42 AppleTV AppleTV[90]: BRDisplayManager: display mode did change; new mode: <CADisplayMode 0 x 0; pixelAspect 1>
Apr  4 17:02:42 AppleTV kernel[0]: AppleRGBOUT: DP cable removed
Apr  4 17:02:42 AppleTV kernel[0]: virtual void IOMobileFramebuffer::hotPlug_notify(uint64_t) (0)
Apr  4 17:02:42 AppleTV kernel[0]: bool AppleRGBOUT::power_down_hardware()
Apr  4 17:02:42 AppleTV kernel[0]: AppleRGBOUT::message is kIOMessageServiceIsRequestingClose
Apr  4 17:02:42 AppleTV kernel[0]: bool AppleRGBOUT::power_down_hardware(), stop the link
Apr  4 17:02:42 AppleTV kernel[0]: bool AppleRGBOUT::power_down_hardware(), clock down RGBOUT
Apr  4 17:02:42 AppleTV kernel[0]: AppleRGBOUT, Completed Link
Apr  4 17:02:42 AppleTV kernel[0]: bool AppleRGBOUT::power_down_hardware(), close the DP
Apr  4 17:02:42 AppleTV kernel[0]: bool AppleRGBOUT::power_down_hardware(), detach and release DP driver
Apr  4 17:02:42 AppleTV kernel[0]: IOReturn AppleRGBOUT::handle_audionly_mode(bool) 0
Apr  4 17:02:42 AppleTV kernel[0]: void AppleRGBOUT::verify_swap_gated(IOMFBSwapIORequest*, bool*) failed mIsDPOut: 1 mDPDriver: 0 fTVOUTDelegate: 0
Apr  4 17:02:42 AppleTV kernel[0]: AppleRGBOUT verify_swap failed
Apr  4 17:02:42 AppleTV kernel[0]: IOReturn AppleRGBOUT::set_display_device_gated(uint32_t), 1
Apr  4 17:02:42 AppleTV kernel[0]: void AppleRGBOUT::verify_swap_gated(IOMFBSwapIORequest*, bool*) failed mIsDPOut: 1 mDPDriver: 0 fTVOUTDelegate: 0
Apr  4 17:02:42 AppleTV kernel[0]: AppleRGBOUT verify_swap failed
Apr  4 17:02:42 AppleTV kernel[0]: virtual void AppleRGBOUT::do_power_state_change(): fSoft: 0 fHard: 1 swapBusy: 0  fController: 0 -> 0
Apr  4 17:02:43 AppleTV mediaserverd[22]: >vad< ASSERTION FAILURE: 08:02:43.124 {ThreadID: 0x1c02000} VirtualAudio_Device.cpp{2415}: RefreshStreams(): We have no input or output streams to refresh. Major internal error
Apr  4 17:02:43 AppleTV mediaserverd[22]: 08:02:43.127 <SystemSoundServer> AQMEIO_Base::DoStartIO: error -66680
Apr  4 17:02:43 AppleTV mediaserverd[22]: 08:02:43.127 <SystemSoundServer> AQMEDevice::StartIO: error -66680
Apr  4 17:02:43 AppleTV mediaserverd[22]: 08:02:43.128 <SystemSoundServer> CA_UISoundClient::StartPlaying: AddRunningClient failed (status = -66680).
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: available modes did change: new modes: (
        "<CADisplayMode 720 x 480; pixelAspect 1>",
        "<CADisplayMode 640 x 480; pixelAspect 1>",
        "<CADisplayMode 1280 x 720; pixelAspect 1>"
    )
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: *** DISPLAY PLUGGED IN ***
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: Attempting to set display to default mode
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: sorted modes to try: (
        "<CADisplayMode 1280 x 720; pixelAspect 1>",
        "<CADisplayMode 720 x 480; pixelAspect 1>",
        "<CADisplayMode 640 x 480; pixelAspect 1>"
    )
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: About to set display mode to: <CADisplayMode 1280 x 720; pixelAspect 1>
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: display mode did change; new mode: <CADisplayMode 1280 x 720; pixelAspect 1>
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: Display mode change successful
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: setting color mode from preferences to 1
Apr  4 17:02:43 AppleTV AppleTV[90]: BRDisplayManager: setting color mode to 1.
Apr  4 17:02:43 AppleTV kernel[0]: [001213.641594]: IODPDisplayInterface::start:(0x8acd7e00) result=1
Apr  4 17:02:43 AppleTV kernel[0]: [000000.000055]: AppleANX9836::addInterfaceGated:(0x879e4000) result=1
Apr  4 17:02:43 AppleTV kernel[0]: [000000.000144]: IODPAudioInterface::start:(0x8ae94700) result=1
Apr  4 17:02:43 AppleTV kernel[0]: [000000.000043]: AppleANX9836::addInterfaceGated:(0x879e4000) result=1
Apr  4 17:02:43 AppleTV kernel[0]: bool AppleRGBOUT::power_down_hardware() redundant call
Apr  4 17:02:43 AppleTV kernel[0]: AppleRGBOUT: DP cable attached
Apr  4 17:02:43 AppleTV kernel[0]: virtual void IOMobileFramebuffer::hotPlug_notify(uint64_t) (0x1)
Apr  4 17:02:43 AppleTV kernel[0]: virtual void AppleRGBOUT::do_power_state_change(): fSoft: 1 fHard: 1 swapBusy: 0  fController: 0 -> 1
Apr  4 17:02:43 AppleTV kernel[0]: bool AppleRGBOUT::power_up_hardware()
Apr  4 17:02:43 AppleTV kernel[0]: bool AppleRGBOUT::power_up_hardware(), could not enable RGBOUT. Valid DP timing/color is not selected yet
Apr  4 17:02:43 AppleTV kernel[0]: IOReturn AppleRGBOUT::set_display_device_gated(uint32_t), 2
Apr  4 17:02:43 AppleTV kernel[0]: IOReturn AppleRGBOUT::set_digital_out_mode_gated(uint32_t, uint32_t) 74 8
Apr  4 17:02:43 AppleTV kernel[0]: bool AppleRGBOUT::power_down_hardware() redundant call
Apr  4 17:02:43 AppleTV kernel[0]: IOReturn AppleRGBOUT::set_displayport_mode(IODPDisplayColorElement*, IODPDisplayTimingElement*)
Apr  4 17:02:43 AppleTV kernel[0]: bool AppleRGBOUT::power_up_hardware()
Apr  4 17:02:43 AppleTV kernel[0]: set_crc_notification_state 0
Apr  4 17:02:43 AppleTV kernel[0]: bool AppleRGBOUT::power_up_hardware(), start DP Mode
Apr  4 17:02:43 AppleTV kernel[0]: [000000.045156]: IODPDisplayInterface::open:(0x8acd7e00) result=1
Apr  4 17:02:43 AppleTV kernel[0]: [000000.104543]: IODPAudioDriver::message:(0x83c06500) Video Link started
Apr  4 17:02:43 AppleTV kernel[0]: bool AppleRGBOUT::power_up_hardware(), link started
Apr  4 17:02:43 AppleTV mediaserverd[22]: >vad< EXCEPTION: 08:02:43.644 {ThreadID: 0x2ffdf000} VirtualAudio_Device.cpp{3346}: GetConnectedPortCount(): kVirtualAudioObjectCategoryNotSupportedError: "category not supported."
Apr  4 17:02:43 AppleTV mediaserverd[22]: >vad< EXCEPTION: 08:02:43.649 {ThreadID: 0x2ffdf000} VirtualAudio_Device.cpp{3346}: GetConnectedPortCount(): kVirtualAudioObjectCategoryNotSupportedError: "category not supported."
Apr  4 17:02:43 AppleTV mediaserverd[22]: >vad< EXCEPTION: 08:02:43.654 {ThreadID: 0x2ffdf000} VirtualAudio_Device.cpp{3278}: GetActivePortCount(): kVirtualAudioObjectCategoryNotSupportedError: "category not supported."
Apr  4 17:12:53 AppleTV launchproxy[193]: /usr/libexec/sshd-keygen-wrapper: Connection from: 192.168.2.143 on port: 56921
Apr  4 17:13:03 AppleTV sshd[194]: Accepted password for root from 192.168.2.143 port 56921 ssh2
Apr  4 17:13:03 AppleTV sshd[195]: USER_PROCESS: 195 ttys000
Apr  4 17:17:34 AppleTV mediaserverd[22]: >vad< ERROR:    08:17:34.556 {ThreadID: 0x18b8000} Device_HAL_Common.cpp{145}: SetPropertyData(): FAIL with status 560947818 ("!obj"): mDeviceID 276 (uid "DisplayPort"); selector "MtnL"; scope 1735159650; element 0
Apr  4 17:17:34 AppleTV mediaserverd[22]: >vad< EXCEPTION: 08:17:34.563 {ThreadID: 0x18b8000} Device_HAL_Common.cpp{146}: SetPropertyData(): status: "Unable to set property data."
Apr  4 17:17:34 AppleTV mediaserverd[22]: 08:17:34.571 <0x18b8000> audio device's sample rate is 0; forcing to 44100
Apr  4 17:17:34 AppleTV mediaserverd[22]: >vad< EXCEPTION: 08:17:34.592 {ThreadID: 0x2ffdf000} VirtualAudio_Device.cpp{3346}: GetConnectedPortCount(): kVirtualAudioObjectCategoryNotSupportedError: "category not supported."
Apr  4 17:17:34 AppleTV mediaserverd[22]: >vad< EXCEPTION: 08:17:34.596 {ThreadID: 0x2ffdf000} VirtualAudio_Device.cpp{3346}: GetConnectedPortCount(): kVirtualAudioObjectCategoryNotSupportedError: "category not supported."
Apr  4 17:17:34 AppleTV mediaserverd[22]: >vad< EXCEPTION: 08:17:34.600 {ThreadID: 0x2ffdf000} VirtualAudio_Device.cpp{3278}: GetActivePortCount(): kVirtualAudioObjectCategoryNotSupportedError: "category not supported."
Apr  4 17:17:34 AppleTV kernel[0]: AppleRGBOUT: DP cable removed
Apr  4 17:17:34 AppleTV kernel[0]: virtual void IOMobileFramebuffer::hotPlug_notify(uint64_t) (0)
Apr  4 17:17:34 AppleTV kernel[0]: bool AppleRGBOUT::power_down_hardware()
Apr  4 17:17:34 AppleTV kernel[0]: AppleRGBOUT::message is kIOMessageServiceIsRequestingClose
Apr  4 17:17:34 AppleTV AppleTV[90]: BRDisplayManager: available modes did change: new modes: (
    )
Reply
#20
I was able to get SMB share by adding it manually. Just the audio issue still to overcome.
Reply
#21
hvac73 Wrote:I was able to get SMB share by adding it manually. Just the audio issue still to overcome.

Do you have a command line for adding it manually?
Thx
Reply
#22
Just did it from XBMC.
Reply
#23
I get the same "Error 2: share not available." when I try to browse for SMB shares. When adding manually I get a "Request timed out".
Reply
#24
I also managed to add SMB server manually just adding SMB://<myServerIp>:32000 to the list of sources.
Reply
#25
I'm also having the trouble with viewing an smb network but I can add each share to the sources list manually as others have been able to. Unfortunately I also get the "Failed to initialize audio device" when playing any video. My audio is over HDMI to my TV and out the crappy 2.0 speakers of the TV. I tried both the Analog and HDMI sound settings in XBMC without any difference and rebooted between changes to make sure that wasn't it. I used Pwnagetool to jailbreak my ATV. Had to manually add sauriks repo to my sources to add bsdiff and gawk and manually installed seatbeltunlock before installing the latest nightly deb.

Snippit of where I believe the error is taking place:
Code:
03:03:31 T:138272768 M:106778624   DEBUG: CIOSCoreAudioDevice::SetupInfo: Remote/IO Output Stream Bus 1 Format [lpcm] Mixable 2 Channel 16-bit Signed Integer (48000Hz)
03:03:31 T:138272768 M:106774528   DEBUG: CIOSCoreAudioDevice::SetupInfo: Remote/IO Input Stream Bus 1 Format [lpcm] Mixable 2 Channel 16-bit Signed Integer (48000Hz)
03:03:31 T:138272768 M:106754048   ERROR: CIOSCoreAudioUnit::Open: Unable to Open AudioUnit. Error = 0x10000003 (   )
03:03:31 T:138272768 M:106278912    INFO: CIOSAudioRenderer::Deinitialize: Renderer has been shut down.
03:03:31 T:138272768 M:106278912    INFO: Previous line repeats 1 times.
03:03:31 T:138272768 M:106278912   ERROR: Creating a Null Audio Renderer, Check your audio settings as this should not happen
03:03:31 T:138272768 M:106278912   DEBUG: RemoveActiveDevice - Removing device 2
03:03:31 T:138272768 M:106278912   DEBUG: SetActiveDevice - SetActiveDevice from 0 to 2
03:03:31 T:138272768 M:106278912   DEBUG: RemoveActiveDevice - Removing device 0
03:03:31 T:138272768 M:106278912   DEBUG: CNullDirectSound::Initialize - Channels: 2 - SampleRate: 48000 - SampleBit: 16 - Resample false - IsMusic false - IsPassthrough false - audioDevice: Default Output Device
XBMC log in full: http://pastebin.ubuntu.com/589374/

Thanks for all the hard work on XBMC, been using it for ages and it's my favorite platform for my living room.
Reply
#26
Just a short question: is there anybody that got audio up and running after a pwnage tool jailbreak on 4.3.1?

Maybe I should also open up the question a bit: Is there anybody that has 4.3.1 with XBMC and audio in XBMC?

If yes, how did you do it?
Reply
#27
No it seems to be a problem on atv2 with the JB ... i have no problems with audio on an ipad 4.3.1 pnwagetool. Maybe someone could try to jailbreak with sn0wbreeze and let us know if that works?!?
Reply
#28
I only meant the apple TV Smile. As far as I know there is currently no other unthered jailbreak available...
Reply
#29
$ ssh [email protected]<your ATV2 IP address>

[email protected]<your ATV2 IP address>'s password: ''enter your password here, it should be "alpine" if you haven't changed it''

$ echo "deb http://apt.saurik.com/ tangelo-3.7 main">/etc/apt/sources.list.d/saurik.list

$ apt-get update
$ apt-get -f install org.xbmc.xbmc-atv2
Reply
#30
riconster Wrote:$ ssh [email protected]<your ATV2 IP address>

[email protected]<your ATV2 IP address>'s password: ''enter your password here, it should be "alpine" if you haven't changed it''

$ echo "deb http://apt.saurik.com/ tangelo-3.7 main">/etc/apt/sources.list.d/saurik.list

$ apt-get update
$ apt-get -f install org.xbmc.xbmc-atv2

What does this do?
TV: VIZIO E-Series 43”
HTPC: Raspberry Pi 3
STORAGE: Windows 8 Server with DrivePool (Currently with 24TB)
Reply
  •  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 14
  • Next 



Logout Mark Read Team Forum Stats Members Help
Problem with Apple TV 2 - 4.3.1 with Jailbreak52