Problem fading from 0 to 100 when using a Hidden anim. triggered by Container.OnNext
#1
I'm working on a coverflow view that has an element that fades from 0 to 100% opacity when I move to the next item. The problem is that it flashes at 100% opacity for one frame first then goes to zero and starts the animation. Is there a way to stop the texture from flashing for that one frame? Everything else works perfectly.

This is the code I've ended up with:
Code:
<control type="group">
<posx>490</posx>
<visible>Container.OnNext</visible>
<animation type="Hidden" reversible="false">
<effect type="fade" start="0" end="100" time="250" />
<effect type="rotatey" center="470" start="0" end="-60" time="250" tween="quadratic" easing="out" />
</animation>
<control type="image">    
  <posx>0</posx>
  <posy>0</posy>
  <width>300</width>
  <height>440</height>
  <texture flipx="true" diffuse="movieposter_mask.png" scalediffuse="false">poster_glass.png</texture>
  <aspectratio>stretch</aspectratio>
  <colordiffuse>ffffffff</colordiffuse>
</control>
</control>
Reply
#2
yes, you need to add
Code:
<visible>!Container.OnNext</visible>
to the image control
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
Wow. I don't understand it but it works. Thanks Ronie.
Reply
#4
the Container.OnNext condition is true for one frame, so your image is visible during that period.

the next frame, Container.OnNext changes to false again and that's when your 'hidden' animation is triggered.

hope that makes sense ;-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#5
It all makes sense now. Thanks for the explanation.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Problem fading from 0 to 100 when using a Hidden anim. triggered by Container.OnNext00