"Clean Library" corrupting myvideos34.db
#1
I was hoping someone might be able to help. I'm running the latest version of Dharma and the Cirrus Extended skin in Windows 7 32-bit. I've been encountering a problem where when I run the "clean library" request, it is corrupting myvideos34.db. All of a sudden my TV Shows and Movies disappears from my home screen.

This has resulted in me having to do a full re-scan of my library (a PITA to say the least...since I customize the fan art, etc). Once my re-scan was complete, I backed up all of the.db files (in case they got corrupted again).

Well, today I deleted a few movies from my NAS, then booted XBMC and ran "clean library" again...guess what...it corrupted myvideos34.db again!! (good thing I had a backup). Anyone else encountering this issue? Is there some sort of fix or something I should be aware of?
Reply
#2
If it's reproducible, can you turn on debug logging then clean the library again? If it results in a corrupted db, the the debug log should be able to tell us why.
Living Room: ASUS Chromebox / OpeneElec 5 / Kodi 14.2
Bedroom: Amazon FireTV Stick / Kodi 14.2
Home Office: Amazon FireTV Stick / Kodi 14.2
Windows Server: Intel Core i3-2100T / 8GB Ram / 48TB / MySQL / StableBit DrivePool on Server 2012 R2 Standard
Reply
#3
Philmatic Wrote:If it's reproducible, can you turn on debug logging then clean the library again? If it results in a corrupted db, the the debug log should be able to tell us why.

Please excuse the total N00b question....how do I turn on debug mode and where is that log file found (so I can copy and paste it here).
Reply
#4
Dr.Know Wrote:Please excuse the total N00b question....how do I turn on debug mode and where is that log file found (so I can copy and paste it here).

a bit down in this post explains it:

http://forum.xbmc.org/showthread.php?tid=42708
Reply
#5
From the sticky thread:

Jester Wrote:Where is my (debug) log?
IMPORTANT! The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System.
The location depends on your windows version:

1. Windows Xp: Documents and Settings\[user]\Application Data\XBMC\xbmc.log
2. Vista/Win7: Users\[user]\AppData\Roaming\XBMC\xbmc.log

If you start XBMC in "portable" mode (with the -p commandline argument) then the log will be in the XBMC folder itself.
Living Room: ASUS Chromebox / OpeneElec 5 / Kodi 14.2
Bedroom: Amazon FireTV Stick / Kodi 14.2
Home Office: Amazon FireTV Stick / Kodi 14.2
Windows Server: Intel Core i3-2100T / 8GB Ram / 48TB / MySQL / StableBit DrivePool on Server 2012 R2 Standard
Reply
#6
Okay, here's my xbmc.log file after turning on debugging. I was able to replicate the problem. I turned on debugging and then did a "clean library". Once it was done, my Movies and TV Shows disappeared.

http://pastebin.com/xEXpzffX
Reply
#7
Can anyone help??
Reply
#8
Bump

I still need some help on this. I ended up exporting my entire library to a file and uninstalling xbmc 10.1 and then reinstalling it. Then I imported my library from file. Once it was completed, I then did a "clean library"....same thing happened...Movies and TV Shows disappeared. This is getting really annoying!
Reply
#9
Stupid question, are you using the PVR branchHuh?
Quote:20:22:09 T:1760 M:2987073536 ERROR: Error evaluating boolean expression !PVR.IsRecording + PVR.HasTimer
Cause that may be your problem
Image
Reply
#10
isamu.dragon Wrote:Stupid question, are you using the PVR branchHuh?

Cause that may be your problem

No, I am not using the PVR branch....how do I go about turning it off?
Reply
#11
Any takers?? I can't seem to find any info on these forums or in the wiki on how to turn off the PVR function within XBMC (unless I'm blind...which could very well be true)...
Reply
#12
I've updated my debug log since re-installing XBMC and am running Cirrus instead of Cirrus Extended. Let me know if there's anything in there suspicious causing this problem I'm having.

http://pastebin.com/mtNhfKMj
Reply



Logout Mark Read Team Forum Stats Members Help
"Clean Library" corrupting myvideos34.db0
This forum uses Lukasz Tkacz MyBB addons.