Thread Rating:
  • 0 Vote(s) - 0 Average
VDR VNSI - No EPG
#16
nothing special showing up in that debug log. I'll add some more debug logging in the epg update code.

but I'm still suspecting vdr/vnsi because I haven't seen that behaviour since the conversion to utc times in the interface was made.
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
Reply
#17
It looks like the epg is all there in the right place, but the 8 hours between now and then get thrown away. I'm wondering if that would fit with my GMT offset (and being on summer time).. So, vdr-vnsi sends the details, but then the new utc zoning requests it again, but offset to my actual time.. (Maybe calls it using utc, but it's interpretted as local time?)..

However, why would it pull in correctly initially?
Reply
#18
yeah good point. I'll check the old entry cleanup code later today. could still be an issue in there.
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
Reply
#19
Any news on this? Does anyone else have this issue?
Reply
#20
No issue with the EPG at the moment.

uname -a
Code:
Linux foo.local 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux

cat /etc/apt/sources.list |grep -e vdr -e xbmc
Code:
# xbmc
deb http://ppa.launchpad.net/lars-opdenkamp/xbmc-pvr/ubuntu lucid main
# vdr-testing
deb http://ppa.launchpad.net/yavdr/testing-vdr/ubuntu lucid main
deb-src http://ppa.launchpad.net/yavdr/testing-vdr/ubuntu lucid main

dpkg -l |grep -e yavdr -e xbmc
Code:
...
vdr - 1.7.17-4yavdr1~lucid
vdr-dev - 1.7.17-4yavdr1~lucid                                        
vdr-plugin-live - 0.2.0.99+cvs20110323.1545-0yavdr1~lucid                      
vdr-plugin-vnsiserver - 0.0.2+svn20110325.2320-0yavdr0~lucid                          
vdr-plugin-xineliboutput - 1.0.6+cvs20110411.1440-0yavdr0~lucid                          
xbmc - 2:11.0-pvr+odk30~git20110426.f44db35-0ubuntu1~ppa+odk30~lucid
xbmc-bin - 2:11.0-pvr+odk30~git20110426.f44db35-0ubuntu1~ppa+odk30~lucid
xineliboutput-sxfe - 1.0.6+cvs20110411.1440-0yavdr0~lucid

date
Code:
So 8. Mai 12:59:17 CEST 2011

I hope it helps
Cheers
/aedon
Reply
#21
aedon Wrote:No issue with the EPG at the moment.
date
Code:
So 8. Mai 12:59:17 CEST 2011

It won't affect you, you're one hour ahead of UTC. It's only an error when behind UTC..

Sun May 8 09:08:08 CDT 2011
Reply
#22
i think the problem is that in PVR::CPVREpg::Cleanup local time is compared with utc.
Reply
#23
thought I checked that. will have a look at it

edit:
yeah, it's comparing utc and local time in CEpg::RemoveTagsBetween(time_t start, time_t end, bool bRemoveFromDb = false)
will fix it
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
Reply
#24
shouldn't that be tag->EndAsUTC in that code, since firstDate is in UTC?

Code:
void PVR::CPVREpg::Cleanup(const CDateTime &Time)
{
CSingleLock lock(m_critSection);

CDateTime firstDate = Time.GetAsUTCDateTime() - CDateTimeSpan(0, g_advancedSettings.m_iEpgLingerTime / 60, g_advancedSettings.m_iEpgLingerTime % 60, 0);

unsigned int iSize = size();
for (unsigned int iTagPtr = 0; iTagPtr < iSize; iTagPtr++)
{
CPVREpgInfoTag tag = (CPVREpgInfoTag *) at(iTagPtr);
if ( tag && / valid tag /
!tag->HasTimer() && / no timer set */
tag->EndAsLocalTime() < firstDate)
{
DeleteInfoTag(tag);
iTagPtr--;
iSize--;
}
}
}`
Reply
#25
I installed today the new xbmc (2:11.0-pvr+odk34~git20110508.23bd2c9-0ubuntu1~ppa+odk34~lucid). EPG is still empty like with last 2-3 builds. I have same packages as aedon posted on the previous page.

I can use epg in vdr-sxfe and everything there is ok. In xbmc I can watch tv, but epg says no information and db files are pretty empty too. Channels are only listed in xbmc.

debug log: http://pastebin.com/ZUyYcx3a

TImezone EEST
Reply
#26
FernetMenta Wrote:shouldn't that be tag->EndAsUTC in that code, since firstDate is in UTC?

Code:
void PVR::CPVREpg::Cleanup(const CDateTime &Time)
{
CSingleLock lock(m_critSection);

CDateTime firstDate = Time.GetAsUTCDateTime() - CDateTimeSpan(0, g_advancedSettings.m_iEpgLingerTime / 60, g_advancedSettings.m_iEpgLingerTime % 60, 0);

unsigned int iSize = size();
for (unsigned int iTagPtr = 0; iTagPtr < iSize; iTagPtr++)
{
CPVREpgInfoTag tag = (CPVREpgInfoTag *) at(iTagPtr);
if ( tag && / valid tag /
!tag->HasTimer() && / no timer set */
tag->EndAsLocalTime() < firstDate)
{
DeleteInfoTag(tag);
iTagPtr--;
iSize--;
}
}
}`

This patch improves the problem a lot. It's now 8.10am and with this patch the on channel epg starts again at 11am instead of 4pm..

I got tvheadend working today and the same problem exists with that as with VDR, so this is an XBMC side problem with a +UTC timezone..
Reply
#27
bleh, forgot that the cleanup method is overwritten in CPVREpg and only fixed it in CEpg Smile
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
Reply
#28
could you try https://github.com/opdenkamp/xbmc/commit...3a69c23c93
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
Reply
#29
I have.. Looks like it's working.. Am playing around with the my channels.conf at the moment, but at first glace all was good.

The only issue may be that the current program wasn't in the channels list, but the timeline was correct and stayed that way..
Reply
#30
Now I have an epg I can tell you more information. Everything works from the timeline window. However, once the epg has loaded the channels appear empty. If I click in one, the channel starts but the info button doesn't show any information. If I select menu I don't have an epg button I can click on to check either the surrounding channels or the schedule for that channel.

If I select a channel via timeline, the info window has the channel information.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
VDR VNSI - No EPG00