XBMC Live Dharma 10.1 Emulation
#1
So for the past 4 hours I've been working on getting emulators running on my XBMC. After about two hours, I was finally able to get SNES working, but with no sound. I didn't really even want SNES so when the few changes to the XBMC audio options didn't fix it, I said screw it and moved on to Genesis. If I had to chose any emulator to get running it would be this. Since I'm running live I can't install them easily, I have to do the sudo apt-get crap. I got zsnes to install fine after I did the sudo apt-get update and then sudo apt-get install zsnes. When I tried to do sudo apt-get install gens and it gave me some error saying E: Couldn't find file in directory or something like that. Can anyone help? I did a search on ubuntu.com for packages and found dgen is an emulator. Unfortunately that just flashes a black screen real quick and doesn't do anything.

I even tried to use sudo wget to get the .deb file from the gens/gs website. I then tried to dpkg -i the file and it didn't work. I looked at the size and they were only 1.29kb, so they were not the full size. Not sure why that didn't download right.
Reply
#2
Ok, good news. I got the wget command to work. I got gens installed. But now I don't have any sound. I reset all my audio options back to hdmi output. Does anyone know how to fix the audio output of gens??
Reply
#3
No one? Help?
Reply
#4
I found a post that says I need to edit my .asoundrc file and it should only contain defaults.pcm.device 3

I'm using HDMI out for sound and XBMC Live Dharma 10.1. Where is this file located? Will that fix my problem if I also change my XBMC options to:

Audio Output Device: DEFAULT
Passthrough Output Device: CUSTOM
Custom Passthrough Device: plughw:0,3


Thanks
Reply
#5
Quote:No one? Help?
Search, there is several guiedes for this.

Quote:Will that fix my problem if I also change my XBMC options
No, the game does not use the sound settings from xbmc that is why you need to create the file.

Quote:Where is this file located?
Search
Reply
#6
Create a file in home directory:
In termnial ( ctrl + alt F2 ) other Fkeys work
login then

Code:
sudo nano .asoundrc
add

Code:
defaults.pcm.device 3

Code:
ctrl + o
yes to save
Code:
ctrl +x
to exit

sudo reboot

go to settings in xbmc then system and audio
Change
Custom Passthrough Device: plughw:0,3

reboot and try (this will add audio for firefox also)
Reply
#7
Thanks Lefty420! vikjon0.... I spent 4 hours searching for all of this crap. The last thing I wanted to do was post in the forum because I don't want to waste people's time. I really searched and didn't find anything that specifically said what left420 said.

Thanks for the info. I'll give it a go! Thanks again.
Reply
#8
Ok. I followed all of the commands you told me. Rebooted, logged back in and gens and zsnes still don't have sound. So I logged back in as my main XBMC to check it saved the .asoundrc.I'm assuming I made it correctly since it showed up. It still has the defaults.pcm.device 3. I rebooted and tried to just watch a movie and it said it failed to initialize the audio device. I tried using hdmi and defaults as the audio output but kept the passthrough custom with the plughw:0,3. Still not working. I eventually just deleted all the info in the .asoundrc and reset my passthrough and output to hdmi to get the sound working for the video again. Any ideas why all this would happen? Thanks!
Reply
#9
have you created or is there a .asoundrc in /ect/ ?
you can sftp into the box to look if your not good with terminal commands.
If there is your gonna need to remove that and follow my guide again. I had the same issues as you because I had previously created a .asoundrc in /ect/ to enable menu sounds, I later found you dont need it just the one in /home/ folder.

If you do have a .asoundrc in /ect/ and cant remove it in ftp (due to permissions) log into terminal and type

Code:
sudo rm /ect/.asoundrc

You could probaly just do that then follow my guide in the last post. Keep at it I just got it working 2 days ago Smile
Reply
#10
Ok, I looked into the .asoundrc file in the /ect/ directory. When I typed out the command to remove it, it says there was no such file. So that's not the issue. I did create a .asoundrc file under the root username so I went in and deleted that.

I then did your steps again and nothing happened. Then I thought about trying the command sudo nano /home/.asoundrc since you said to make it in the home directory. That didn't work either.

What are the settings supposed to be in the audio again? Audio Output Device is hdmi and then the paththrough is custom and it is set to plughw:0,3? Correct? I starting to lose hope Sad Thanks again for your help.
Reply
#11
when i didnt have sound in my emulators i also didnt have sound in my menus (im using optical however).

im also using 10.1 dharma and menu sounds and emu sounds are working.

originally i just had to install libsdl1.2debian-alsa.

also, make sure the proper things are unmuted in alsamixer (menu sounds and emulator sounds were muted by default by me)

sorry i cant help much more then that.
iOS XBMC users PLEASE use the advanced search function before starting a new thread. Make sure to click on 'XBMC for iOS Specific Support' so your results are narrowed down correctly.

Please make sure to visit the Sticky section for common issues/questions/etc. Also, XBMC for iOS information
Reply
#12
try this
in terminal

Code:
cd /home/
Code:
sudo nano .asoundrc

Add:

Quote:pcm.!default {
type plug
slave {
pcm "hdmi"
}
}
[HTML]Ctrl + o (y then enter)
Ctrl + x[/HTML]

Reboot and set the audio setting to how they were working before for movies and try good luck
P.s. What setup you running ?
Reply
#13
Still no go Sad The sound worked for movies this time though, when I had the .asoundrc file and the Audio output set to hdmi and the passthrough set to hdmi or plughw:0,3.

I have never had the menu sounds work with Dharma 10.1 and I made sure they weren't turned off. I hooked up a keyboard and mouse but I was unable to get to the drop down menus on the emulators.

My setup is an Acer Aspire R1600, running XBMC Dharma 10.1 Live.
Reply
#14
Did you install the xbmc live from here or the xbmc freak version. The reason I ask is the xbmc freak comes with the latest nvidia drivers which could fix you'r problems. My only advice left is look into updating the nvida drivers or re-installing xbmc-freak version .
Reply
#15
I downloaded the version from xbmc.com. Is updating the drivers pretty easy? or does that involve a lot of work?

I guess I could reinstall it again. Where would I find that release? Thanks
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC Live Dharma 10.1 Emulation00