Kodi Community Forum
[RELEASE] Artist Slideshow addon (for skin integration) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (/forumdisplay.php?fid=151)
+---- Thread: [RELEASE] Artist Slideshow addon (for skin integration) (/showthread.php?tid=102703)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19


- perro6969 - 2011-06-08 11:10

Hi Ronie,

you'll get a Debug Log. Right now I can't find the time, but I'll do it.


- solidsatras - 2011-06-08 17:38

@ronie
you might want to fix the typo in the thread name:
[Release] Arstist Slideshow addon (for skin integration)


- ronie - 2011-06-08 18:08

solidsatras Wrote:@ronie
you might want to fix the typo in the thread name:
[Release] Arstist Slideshow addon (for skin integration)

thanx & taken care of :-)


- perro6969 - 2011-06-08 21:33

ronie Wrote:it doesn't happen on my end, but i may need to adjust some timings in the script.

but...i'm gonna need a Debug Log to know for sure. :-)

Hello,

here is the Debug Log:
http://pastebin.com/FbN93CUf

I played an Artist (Bad Religion) for the first time using the addon and when I go to the visualisation mode, it displays only 1 image. This happens always when I play the artist for the first time.
What also happens is that when I go out and come back to the visualisation mode (workaround) it displays only a few images the whole time, but I know there should be more, so I go out again from the visualisation mode for a longer period of time and come back, it displays more images.
I hope it's clear. Please, tell me if you need any other Debug Log.


- ronie - 2011-06-08 22:35

perro6969 Wrote:Hello,

here is the Debug Log:
http://pastebin.com/FbN93CUf

I played an Artist (Bad Religion) for the first time using the addon and when I go to the visualisation mode, it displays only 1 image. This happens always when I play the artist for the first time.
What also happens is that when I go out and come back to the visualisation mode (workaround) it displays only a few images the whole time, but I know there should be more, so I go out again from the visualisation mode for a longer period of time and come back, it displays more images.
I hope it's clear. Please, tell me if you need any other Debug Log.

well, let me explain how the addon works, that might clear up a few things...

as soon as the first image is downloaded it will show up on your screen.
xbmc will keep using this (and only this) image while other images are downloaded in the background. (xbmc does not automatically pick up those new ones).
as soon as all images are downloaded, the script will force xbmc to refresh the slideshow, so all images will be used.

this means, in the case a track ends before all images are downloaded, you'll only get to see the first image.

getting out of the visualization screen and back in, will also refresh the slideshow, so you'll get to see the images that have been downloaded so far.

i think that's what you're experiencing.

now i'll have a look at your log to see if i'm right ;-)


edit:
nope...not what's happening at your end.
so back to plan A, adjust some timings in the script.


Back to Beta - fredphoesh - 2011-06-08 23:53

Hi there Ronie,
I don't know if you remember me from the beta cycle?
I was one of the people who had been pleading for something like this for a long, long time, so your work on the LastFM script is massively appreciated.


I have not xbmc'ed for a while, and the script was not working, so I uninstalled from settings, then re-installed. It says it is installed but there are no images displayed at all. I seem to remember it working without much else to do... I am pressing TAB to go full screen, and whether I choose another visualisation or "none" there is no slide show.

Any ideas, could remnants of the beta files in my folders be messing with the release version?

Thanks again,

Mark.


- ronie - 2011-06-08 23:57

fredphoesh Wrote:f the beta files in my folders be messing with the release version?

not likely, but you never know.

you could check your Debug Log if the script does start at all.

what skin are you using ?


- fredphoesh - 2011-06-09 00:12

ronie Wrote:not likely, but you never know.

you could check your Debug Log if the script does start at all.

what skin are you using ?

Hi Ronie, thanks for the response...

I'm using Transparency.
I will do a Debug Log next time I run xbmc...

AFAIRemember, I did not have to "start" the script, it was automatically started as a visualisation, right?

Tx
Mark


- ronie - 2011-06-09 00:14

fredphoesh Wrote:Hi Ronie, thanks for the response...

I'm using Transparency.
I will do a Debug Log next time I run xbmc...

AFAIRemember, I did not have to "start" the script, it was automatically started as a visualisation, right?

Tx
Mark

that's correct, the skin will start the script when you enter the visualization screen.

would that be T! 3.11.7 ?
if so, the latest update of the skin probably wiped the modded MusicVisualisation.xml file.


- fredphoesh - 2011-06-09 00:18

ronie Wrote:would that be T! 3.11.7 ?
if so, the latest update of the skin probably wiped the modded MusicVisualisation.xml file.

aah! yes, my htpc is not on, but there definitely was a transparency update in the last short while... but I re-installed it from the Add-ons in settings, so wouldnt that xml file have been re-installed? Or must it still be added manually?

tx
Mark.


- ronie - 2011-06-09 00:24

fredphoesh Wrote:aah! yes, my htpc is not on, but there definitely was a transparency update in the last short while... but I re-installed it from the Add-ons in settings, so wouldnt that xml file have been re-installed? Or must it still be added manually?

tx
Mark.

still manually.

only the svn version of T! will have it by default.


- fredphoesh - 2011-06-09 00:32

ronie Wrote:still manually.

only the svn version of T! will have it by default.

aha, so user error then Wink

i will find those files and copy them over.

thanks again and cheers,
Mark.


addon repository - fredphoesh - 2011-06-09 16:44

ronie Wrote:download:
the addon is available in the official addon repo, for both dharma and eden-pre

Hi Ronie,
I have looked on the xbmc.org site, and in the forums for something that is called addon repository, but cannot find it.
Do you mean the add-on function within xbmc? If so, I have installed there, but as you told me last night, I would have to copy the xml files to the appropriate directories manually anyway.

Sorry for being a bit of a dolt!
I do have the files i had downloaded previously, but dont know if they are they are the latest versions:

script.artistslideshow-3.zip
slideshow-transparency.zip

thanks again,
Mark.


- ronie - 2011-06-09 19:19

fredphoesh Wrote:Hi Ronie,
I have looked on the xbmc.org site, and in the forums for something that is called addon repository, but cannot find it.
Do you mean the add-on function within xbmc? If so, I have installed there, but as you told me last night, I would have to copy the xml files to the appropriate directories manually anyway.

Sorry for being a bit of a dolt!
I do have the files i had downloaded previously, but dont know if they are they are the latest versions:

script.artistslideshow-3.zip
slideshow-transparency.zip

thanks again,
Mark.

yes, just use the addon browser in xbmc to install the script.

for the rest, all you need is slideshow-transparency.zip


- fredphoesh - 2011-06-09 19:56

ronie Wrote:yes, just use the addon browser in xbmc to install the script.

for the rest, all you need is slideshow-transparency.zip


Tx, I installed the script via xbmc last night and it did not work, so today copied the MusicVisualisation.xml into the 720p folder at C:\Users\mark\AppData\Roaming\XBMC\addons\skin.transparency\

and all is fine...

I will continue to do some testing WRT the slide show getting stuck on one artist at some point... If it happens again I will ardently try to figure out why it's doing that. It MAY have something to do with one of the large collections which is tagged Album Artist - Various Artists and the Artist tag is unique for each track.

speak soon, tx again for the fantastic addition!
Mark.