Kodi Community Forum
[Linux] Problems with updated nvidia driver 295.40 - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: [Linux] Problems with updated nvidia driver 295.40 (/showthread.php?tid=128705)



Problems with updated nvidia driver 295.40 - BaerMan - 2012-04-12 22:27

Hi there

today I updated to current nvidia binary driver 295.40 (from 295.33) and using that driver xbmc starts but doesn't display anything. I can navigate the menu (I can hear the clicks when navigating) but screen stays dark. I tried several tricks such as deleting the guisettings.xml in case there were some broken config settings but without success and I can find no error messages at all, neither in XBMC's logfile nor in system logs. Interestingly I can start an X-Session without any problems, so I guess it's related somehow to XBMC itself. Now I reverted back to driver 295.33 and all is fine again.

System:
Ubuntu Lucid 10.04.4 with kernel 2.6.38-14
GPU: GeForce 6150 LE
Display: Flatscreen connected via HDMI
XBMC 11.0 Git:Unknown from ppa.launchpad.net/alexandr-surkov/xbmc/ubuntu (installation date should have been 2012-03-24)

XBMC starts as standalone app from console without X and there were several reboots after installation of driver.

If you need more info or a logfile please tell me.

EDIT: just saw that kernel driver 295.40 doesn't depend on "agpgart" anymore while 295.33 does. Probably that's an important one?


RE: Problems with updated nvidia driver 295.40 - XbmArchLin - 2012-04-13 19:51

I have a nvidia 6200 pci that does not work with 295.40 , had to downgrade to 295.33 and it works great . There are others over here with the same Problems with 295.40 . https://bbs.archlinux.org/viewtopic.php?id=139535


RE: Problems with updated nvidia driver 295.40 - XbmArchLin - 2012-05-03 21:46

This problem has been Solved by upgrading to 295.49 .


RE: Problems with updated nvidia driver 295.40 - BaerMan - 2012-05-17 17:42

Am now running on driver 302.07 and it works fine. Smile


RE: Problems with updated nvidia driver 295.40 - jawilljr - 2012-05-18 01:07

I used x-swat:

Code:
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current libvdpau1

x-swat has the latest 295.53 drivers.

Jerry


RE: Problems with updated nvidia driver 295.40 - tronic - 2012-05-18 10:16

(2012-05-18 01:07)jawilljr Wrote:  I used x-swat:

Code:
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current libvdpau1

x-swat has the latest 295.53 drivers.

Jerry

Hi Jawilljr.

Good tip, as those drivers have been working great with GTX 460.Cool