Artwork Downloader

  Thread Rating:
  • 14 Vote(s) - 4.29 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Eisa Offline
Junior Member
Posts: 19
Joined: Jul 2016
Reputation: 0
Post: #2611
Firstly, thanks for this add-on!

Feature Request:
Option to download ExtraFanarts from multiple sources. (Specifically "fanart.tv" in conjuction with "thetvdb.com").

Explanation:
I've noticed that not all of the ExtraFanarts are being downloaded,
What I believe is that it's not scraping from fanart.tv.

I believe it's only using thetvdb as a source to scrape Extrafanarts.

How I made sure:
I tried all the settings and I disabled the limit of Extra Fanarts, also deleted my entire library to test further.
Also I checked the API, and the add-on provider fanarttv.py then I saw that 'showbackground' is missing. I believe 'showbackground' is fanart in "fanart.tv".

Possibly this was done to avoid duplicates.However, it leads to missing fanarts. I'd truly appreciate the option to enable downloading Extrafanarts from more sources as it's truly easy to get rid of duplicates by using a third-party program.

Conclusion:
Not finding a solution made me search for similar programs for one full day, (tested almost all and still am testing. Hopefully I'll find a solution if I couldn't through Artwork Downloader).
Still, I truly wish that there'll be an option to enable downloading ExtraFanarts from multiple sources.

Thanks again for this awesome add-on!

Edit (21-7-2016) Solved using Ember:
Thankfully, I've been able to download ExtraFanarts from multiple sources using Ember; thanks to DanCooper for assisting me. However, there are small issues here and there, but still it does it's job greater than expected!
(This post was last modified: 2016-07-21 06:10 by Eisa.)
find quote
htpc1602 Offline
Junior Member
Posts: 1
Joined: Mar 2015
Reputation: 0
Post: #2612
Hi all,

How do I delete all of the options when I go to check the artwork? I accidentally downloaded clearart clearlogo, etc, but I only want fanart and posters. I delete the thumbnails in AppData\Roaming, but I want the actual "clearart" option to be gone when I go to select artwork for my library.

Any thoughts?
find quote
jiquem Offline
Junior Member
Posts: 11
Joined: Sep 2015
Reputation: 0
Post: #2613
(2016-05-19 10:31)swiss_lis Wrote:  As movie78 above, when I request download discart for my movies collection of 300+ strong, it finds no art. I have to download each one manually. All other artwork downloads fine.

hello,

Do you find a solution to this issue ? I am encoutering the same on a fresh LibreElec installation.

Regards
find quote
jiquem Offline
Junior Member
Posts: 11
Joined: Sep 2015
Reputation: 0
Post: #2614
I quickly code this ugly script to download discart for all movies

Code:
#!/bin/bash

MAX=$(sqlite3 /storage/.kodi/userdata/Database/MyVideos99.db  'select max(idmovie) from movie;')
#MAX=10
echo $MAX

kodi-send -a "Action(Mute)"
for i in $(seq 1 $MAX)
do
  echo $i
  kodi-send -a "RunScript(script.artwork.downloader, mode=custom, mediatype=movie, dbid=$i, discart)"
  sleep 5
  kodi-send -a "Action(Select)"
  sleep 5
done
find quote
Solo0815 Online
Fan
Posts: 727
Joined: Sep 2004
Reputation: 6
Location: Germany
Post: #2615
ArtworkDownloader can't find Artwork for Amazon-Movies added to the DB via strm-file:
Edit #2: Log on pastebin
http://pastebin.com/EZhTRnDA

Edit:
It seems that the Year is not filtered and thats why nothing is found. Can you please add a option to filter out the year in brackets?
Thx

PC: Kubuntu 16.04 and Win7/10 --- Wetek Play: LibreELEC 7.x (master) --- --- RPi3: Milhouse latest --- NAS: OMV 2.x
(This post was last modified: 2016-08-10 20:59 by Solo0815.)
find quote
vbat99 Offline
Posting Freak
Posts: 1,950
Joined: Aug 2009
Reputation: 51
Location: New Zealand
Post: #2616
Dude, upload log to paste bin and post link.
don't post up full logs in your post.

Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
find quote
Solo0815 Online
Fan
Posts: 727
Joined: Sep 2004
Reputation: 6
Location: Germany
Post: #2617
Done

PC: Kubuntu 16.04 and Win7/10 --- Wetek Play: LibreELEC 7.x (master) --- --- RPi3: Milhouse latest --- NAS: OMV 2.x
find quote
jspyke52 Offline
Junior Member
Posts: 21
Joined: Aug 2015
Reputation: 0
Post: #2618
Once I create a new Super folder and I have all that I want in it, inside of that folder there is a default folder that says create folder and a blank space before my apps or whatever I put into the folder.. Is there a way to delete that blank space and create new folder out of it?
find quote
Solo0815 Online
Fan
Posts: 727
Joined: Sep 2004
Reputation: 6
Location: Germany
Post: #2619
(2016-06-10 17:42)mikebzh44 Wrote:  Hi Martijn.

French user encounter an issue because his movies does not have ID but AD can't fetch it from TheMovieDB :

Code:
16:40:47 T:3484   DEBUG: Artwork Downloader MP: Processing media:  Alien, le huitieme passager
16:40:47 T:3484   DEBUG: Artwork Downloader MP: No IMDB ID found, trying to search themoviedb.org for matching title.
16:40:47 T:3484   DEBUG: Artwork Downloader MP: TMDB API search criteria: Title[Alien, le huitieme passager] | Year[1979]
16:40:47 T:3484   DEBUG: Artwork Downloader MP: TMDB API search:   http://api.themoviedb.org/3/search/movie?query=Alien,+le+huitieme+passager+1979&api_key=4be68d7eab1fbd1b6fd8a3b80a65a95e
16:40:47 T:3484   DEBUG: Artwork Downloader MP: API: http://api.themoviedb.org/3/search/movie?query=Alien,+le+huitieme+passager+1979&api_key=4be68d7eab1fbd1b6fd8a3b80a65a95e
16:40:47 T:3484   DEBUG: Artwork Downloader MP: TMDB API search found no ID
16:40:47 T:3484   DEBUG: Artwork Downloader MP: Provider ID:

It's because AD does not use the proper API :

http://docs.themoviedb.apiary.io/#refere...earchmovie

With :

Code:
http://api.themoviedb.org/3/search/movie?query=Alien,+le+huitieme+passager&api_key=4be68d7eab1fbd1b6fd8a3b80a65a95e&year=1979

AD can retrieve the good ID and search for artwork.

I will submit a PR for this issue on GITHUB.
seems this problem is still there. See my log above. When I remove the year from the search, the movie is found.

PC: Kubuntu 16.04 and Win7/10 --- Wetek Play: LibreELEC 7.x (master) --- --- RPi3: Milhouse latest --- NAS: OMV 2.x
find quote
mikebzh44 Offline
Posting Freak
Posts: 2,084
Joined: Nov 2011
Reputation: 57
Location: Nantes - France
Post: #2620
I'm quite sure that I've made a PR on GITHUB but I can find it, I will make a new one today.

But you can easily fix this is by editing file script.artwork.downloader/lib/provider/tmdb.py, go to line 147 and replace :

Code:
search_url = 'http://api.themoviedb.org/3/search/movie?query=%s+%s&api_key=%s' %( medianame, year, API_KEY )

by

Code:
search_url = 'http://api.themoviedb.org/3/search/movie?query=%s&api_key=%s&year=%s' %( medianame, API_KEY, year )

CAUTION : Python take care of indentation

Sorry for my english, but, you know, I'm French so ...

Main HTPC : Core i3 2120T running OpenELEC with Aeon Nox 5 and my mod
Secondary HTPC : Freebox Mini 4K running Android TV with Aeon Nox 5 and my mod
find quote
Solo0815 Online
Fan
Posts: 727
Joined: Sep 2004
Reputation: 6
Location: Germany
Post: #2621
After changing the line, it works like charm.
This is definitivly worth a PR!
Thx for the tip

PC: Kubuntu 16.04 and Win7/10 --- Wetek Play: LibreELEC 7.x (master) --- --- RPi3: Milhouse latest --- NAS: OMV 2.x
find quote
Brasmuss Offline
Junior Member
Posts: 4
Joined: Feb 2013
Reputation: 0
Post: #2622
Hi

Recent I have a problem with the artwork. It does not match the content. Wrong pictures etc. Anyone else know about this and have a solution?
I have tried another skin, and same problem. It has been going on for a week now.

Thanks in advance Smile
find quote
Edworld Offline
Posting Freak
Posts: 895
Joined: Sep 2014
Reputation: 7
Location: Michigan
Post: #2623
Limit artwork question:

What does minimum rating do? I set it to 10 thinking it would only download extrafanart from TMDb with at least 10 as a rating, but downloaded all kinds of extrafanarts with zero votes/ratings.

Thanks
find quote
Post Reply