Linux - Inspiron 1501 - XBMCbuntu

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
skorpi0wn Offline
Junior Member
Posts: 8
Joined: Mar 2009
Reputation: 0
Post: #1
I'm running the latest version of XBMCbuntu on a Dell Inspiron 1501 Laptop. I installed the software directly to the hard drive. When I load it, the software crawls to the point where it takes about five seconds between keyboard press and movement on the screen.

I installed XBMC on Windows XP and Windows 7 using the same laptop, and speed wasn't an issue at all. Everything ran smooth and crisp.

Does anyone know why this would work so well in Windows, but not in Linux?

Best
find quote
teeedubb Offline
Donor
Posts: 2,741
Joined: Mar 2010
Reputation: 63
Location: Down Under
Post: #2
Sounds like a video driver issue... What video card are you using an have you installed the drivers for it?
find quote
skorpi0wn Offline
Junior Member
Posts: 8
Joined: Mar 2009
Reputation: 0
Post: #3
It's an ATI Radeon Xpress 1150. After I use lspci -v I see the drivers loaded are:

VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]

(The Xpress 200M was installed in Intel machines while it was renamed Xpress 1150 in AMD based machines).

One thing I notice is that when I drop to a shell and run 'top' I see that xbmc.bin is running at 105% CPU!
(This post was last modified: 2012-04-24 08:30 by skorpi0wn.)
find quote
skorpi0wn Offline
Junior Member
Posts: 8
Joined: Mar 2009
Reputation: 0
Post: #4
Update: I installed the latest Ubuntu 12.04 LTS beta 2. Then I installed XBMC afterwards using this repository: ppa:nathan-renniewaldock/xbmc-stable. XBMC runs MUCH faster now. It's only slow due to the resources that the Ubuntu Desktop eats now. Plus, my controller doesn't have all the buttons mapped correctly. But at least it's a start. I wonder why the XBMCbuntu install is cause xbmc.bin to max at 105%?
find quote
skorpi0wn Offline
Junior Member
Posts: 8
Joined: Mar 2009
Reputation: 0
Post: #5
Last night, I reinstalled XBMCbuntu and sure enough everything remained very sluggish to the point where everything was unusable. Today, I upgraded the distribution to 12.04. XBMC runs faster now - to the point where a keypress reacts in about 1/2 a second. The problem now is that the CPU for xbmc.bin is running at 190% (in top) which is keeping the fans at high speed. The movies load now, but they are too choppy to watch.

Any suggestions on how to change the video drivers?
find quote