Linux - Can not see some files via SMB

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bark01 Offline
Junior Member
Posts: 9
Joined: Mar 2008
Reputation: 0
Post: #1
Hi,

When i use SMB to access my shares there are some files that do not show up. For instance my SMB share would go into a folder called TV, from there i go to walking dead, if i go to season 1 all the files are viewable, if i go to season 2 I can open the folder but can't see any files. I can see the files if a navigate via another PC I just can't see them when I use try through my HMPC.

I'm running an Acer Aspire REVO with LIVE XBMC v10.

The files I'm trying to view are .MKV, and I'm not trying to view them in libary view I'm trying to access via the directory. The only common thread I can think of is the non navigatable files all seem to be newer files and it id generally everything in the folder that is missing. ALthough I have one folder with some episodes of a Tv series that were downloaded lsat year that are viewable but ones downloaded this year are not.

Is there a certain form of .MKV that doesn't work in linux?

Any ideas?
(This post was last modified: 2012-04-30 00:07 by bark01.)
find quote
drivesoslow Offline
Fan
Posts: 477
Joined: Aug 2008
Reputation: 5
Post: #2
Check the permissions on the files.

Also are you sharing them from Windows or Linux?
find quote
bark01 Offline
Junior Member
Posts: 9
Joined: Mar 2008
Reputation: 0
Post: #3
(2012-04-30 22:37)drivesoslow Wrote:  Check the permissions on the files.

Also are you sharing them from Windows or Linux?

I'm sharing them from windows 7 to xbmc live.

I think you may have spotted the issue, the files i can see are shared to Everyone, System, My login, Administrators.

The files I can't see are shared with Authenticated users, System, Administrators, Users.

I've tried deleting the share and reapplying it but it still gives the same result. Any ideas how I get round this?
find quote
aragorn Offline
Junior Member
Posts: 17
Joined: Dec 2008
Reputation: 0
Post: #4
You need to alter the permissions on the files themselves, not the share.

Alternatively, turn off guest access and have the XBMC system log into your share with a valid username and password that does have permission to view the files.
find quote
blm14 Offline
Senior Member
Posts: 166
Joined: Nov 2009
Reputation: 0
Post: #5
Right click on the folder(s) you're sharing, get properties, go to the sharing tab, click advanced sharing, click permissions, make sure that the user that XBMC is logging in with has read permissions.
find quote
drivesoslow Offline
Fan
Posts: 477
Joined: Aug 2008
Reputation: 5
Post: #6
Or you can connect to the computer using your Windows username and password
find quote