Bay Trail-D motherboards

  Thread Rating:
  • 8 Vote(s) - 4.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rocktale Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Location: Munich, Germany
Post: #796
Hey, does anyone of you have a J1900 mainboard and suspend to ram working with linux? I bought a Asrock Q1900-ITX and I really like it. However, suspend to ram does not work with Arch (stock and LTS kernel) nor with Ubuntu LTS 14.04. The odd thing is, that resuming works if I resume within a minute after putting the system to suspend. If I wait longer however, the system reboots or hangs on resume. This is quite odd, usually suspend/resume either works or it does not.

Any ideas? Or recommendations? I would like to stick with the Asrock board since I need the 4 SATA ports. However, I'd also like to have suspend to ram capability...
find quote
htpcero Offline
Senior Member
Posts: 103
Joined: May 2009
Reputation: 0
Post: #797
(2015-02-25 02:10)rocktale Wrote:  Hey, does anyone of you have a J1900 mainboard and suspend to ram working with linux? I bought a Asrock Q1900-ITX and I really like it. However, suspend to ram does not work with Arch (stock and LTS kernel) nor with Ubuntu LTS 14.04. The odd thing is, that resuming works if I resume within a minute after putting the system to suspend. If I wait longer however, the system reboots or hangs on resume. This is quite odd, usually suspend/resume either works or it does not.

Any ideas? Or recommendations? I would like to stick with the Asrock board since I need the 4 SATA ports. However, I'd also like to have suspend to ram capability...


I am using a mini ITX mobo - Asrock Q1900-ITX - BIOS: 1.30 since late last year.
With ubuntu 14.04 as my living-room HTPC with kodi. I always suspend it, never had an issue. I use FLIRC and a harmony smart remote to wake it up.

The below may help you out or give you some hints on what to fix:


[/code]
Quote:FLIRC will advertise via USB that it can wake up the machine, and this can be verified by querying the “power” capabilities of “Bus 05, Port 4”:

ls /sys/bus/usb/devices/5-4/power
active_duration control runtime_enabled wakeup_active wakeup_max_time_ms
async level runtime_status wakeup_active_count wakeup_total_time_ms
autosuspend persist runtime_suspended_time wakeup_count
autosuspend_delay_ms runtime_active_kids runtime_usage wakeup_hit_count
connected_duration runtime_active_time wakeup wakeup_last_time_ms

If “wakeup” shows up in the listing, all is good. With the original “non-wakeup” firmware, no wakeup capability was showing up.

Note: the old (pre udev) way of activating wakeup (sh -c 'echo "USB4" > /proc/acpi/wakeup') no longer works in ubuntu 12.04+

Now we can manually test if wakeup works:
echo enabled > /sys/bus/usb/devices/5-4/power/wakeup

This could be added to rc.local - the problem with this approach is that if the FLIRC is moved to a different USB port, wakeup won’t work.

The best approach is to create a new udev rule:

cd /etc/udev/rules.d/
vi 90-flircwakeup.rules
SUBSYSTEM=="usb", ATTRS{idVendor}=="20a0", ATTRS{idProduct}=="0001" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

This will allow wake for the FLIRC no matter where it is connected.

Note that for wake up to work, the “wake up” key has to be recorded using the “flirc_util” utility.
find quote
rocktale Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Location: Munich, Germany
Post: #798
Quote:I am using a mini ITX mobo - Asrock Q1900-ITX - BIOS: 1.30 since late last year.
With ubuntu 14.04 as my living-room HTPC with kodi. I always suspend it, never had an issue. I use FLIRC and a harmony smart remote to wake it up.

The below may help you out or give you some hints on what to fix:

Thanks for the reply, it is good to hear that somebody got it working with the same mobo I have. However, that leaves me to figure out why it isn't working in my case. Sadly, the fix for FLIRC doesn't help in my case because the system is getting the wake up signal. It even tries to power on (in all cases) but simply nothing happens. And it doesn't matter how I trigger the wake up event (power switch, wake on lan, keyboard, ...). Did you change anything in the BIOS settings? What kind of RAM do you use? Thanks a lot for your help.

Edit: Well, it appears I found the source of the problem: I ran some tests with RAM borrowed from my laptop and it seams to work. It's still strange though since the original memory passes several rounds of memtest with flying colors.
(This post was last modified: 2015-02-25 14:09 by rocktale.)
find quote
htpcero Offline
Senior Member
Posts: 103
Joined: May 2009
Reputation: 0
Post: #799
(2015-02-25 11:07)rocktale Wrote:  
Quote:I am using a mini ITX mobo - Asrock Q1900-ITX - BIOS: 1.30 since late last year.
With ubuntu 14.04 as my living-room HTPC with kodi. I always suspend it, never had an issue. I use FLIRC and a harmony smart remote to wake it up.

The below may help you out or give you some hints on what to fix:

Thanks for the reply, it is good to hear that somebody got it working with the same mobo I have. However, that leaves me to figure out why it isn't working in my case. Sadly, the fix for FLIRC doesn't help in my case because the system is getting the wake up signal. It even tries to power on (in all cases) but simply nothing happens. And it doesn't matter how I trigger the wake up event (power switch, wake on lan, keyboard, ...). Did you change anything in the BIOS settings? What kind of RAM do you use? Thanks a lot for your help.

Edit: Well, it appears I found the source of the problem: I ran some tests with RAM borrowed from my laptop and it seams to work. It's still strange though since the original memory passes several rounds of memtest with flying colors.

Good to hear

I am using - G.SKILL 4GB 204-Pin DDR3 SO-DIMM DDR3 1600 (PC3
find quote
Post Reply