Transparency! SVN for XBMC nightly builds

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
minimoe Offline
Senior Member
Posts: 225
Joined: Feb 2011
Reputation: 3
Post: #271
ronie Wrote:thanx for the report!
fixed in svn now.

Perfect, thank you!

There is a small thing that bothers me with T! I don't know if it's been mentioned before but any video I'm watching pauses for a split second when I move the mouse to bring up the OSD. I doesn't happen with the other skins I've tried. I can't see anything wrong in the log:
Code:
21:58:35 T:1052 M:874102784   ERROR: CRemoteControl::Connect - failed to connect
21:58:37 T:2224 M:877846528 WARNING: XFILE::CVideoDatabaseDirectory::GetLabel - Unknown nodetype requested 12
21:58:40 T:2224 M:881672192  NOTICE: DVDPlayer: Opening: G:\TV\Fringe\Fringe.S03E17.720p.WEB-DL.Rus.Ukr.Eng.HDCLUB.mkv
21:58:40 T:2224 M:881664000 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
21:58:40 T:2180 M:881647616  NOTICE: Creating InputStream
21:58:40 T:2180 M:881610752  NOTICE: Creating Demuxer
21:58:40 T:1052 M:878272512   ERROR: CRemoteControl::Connect - failed to connect
21:58:41 T:2180 M:873021440  NOTICE: Opening video stream: 0 source: 256
21:58:41 T:2180 M:873017344  NOTICE: Creating video codec with codec id: 28
21:58:41 T:2180 M:873250816  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
21:58:41 T:2180 M:873189376  NOTICE: Creating video thread
21:58:41 T:2180 M:873189376  NOTICE: Opening audio stream: 1 source: 256
21:58:41 T:2180 M:873201664  NOTICE: Finding audio codec for: 86019
21:58:41 T:2180 M:873201664  NOTICE: Creating audio thread
21:58:41 T:2180 M:873201664  NOTICE: Opening Subtitle stream: 4 source: 256
21:58:41 T:1140 M:873181184  NOTICE: running thread: CDVDPlayerAudio::Process()
21:58:41 T:1140 M:873222144  NOTICE: Creating audio device with codec id: 86019, channels: 6, sample rate: 48000, no pass-through
21:58:41 T:3520 M:873193472  NOTICE: running thread: video_thread
21:58:41 T:3520 M:867651584  NOTICE:  fps: 23.976024, pwidth: 1280, pheight: 720, dwidth: 1280, dheight: 720
21:58:41 T:3520 M:869433344  NOTICE: Display resolution DESKTOP : 1280x800 @ 60.00 - Full Screen (12)
21:58:45 T:1052 M:858365952   ERROR: CRemoteControl::Connect - failed to connect
21:58:48 T:3520 M:859148288 WARNING: CDVDVideoCodecFFmpeg::Decode - avcodec_decode_video didn't consume the full packet. size: 17374, consumed: 0
21:58:49 T:3520 M:859312128 WARNING: CDVDVideoCodecFFmpeg::Decode - avcodec_decode_video didn't consume the full packet. size: 17115, consumed: 0
21:58:50 T:1052 M:860532736   ERROR: CRemoteControl::Connect - failed to connect
21:58:51 T:3520 M:861794304 WARNING: CDVDVideoCodecFFmpeg::Decode - avcodec_decode_video didn't consume the full packet. size: 4482, consumed: 0
21:58:51 T:2224 M:861126656  NOTICE: CDVDPlayer::CloseFile()
21:58:51 T:2224 M:859983872  NOTICE: DVDPlayer: waiting for threads to exit

Is there something I can do to fix this?
find
ronie Offline
Team-Kodi Member
Posts: 9,437
Joined: Jan 2009
Reputation: 165
Post: #272
minimoe Wrote:There is a small thing that bothers me with T! I don't know if it's been mentioned before but any video I'm watching pauses for a split second when I move the mouse to bring up the OSD. I doesn't happen with the other skins I've tried.

thanx, just tested it myself and can confirm.
will look into it in a bit.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
dynaflash Offline
Senior Member
Posts: 167
Joined: Nov 2010
Reputation: 0
Post: #273
dynaflash Wrote:One other thing that seems to be of a bit of issue is that when starting a movie it doesn't ask you to start from where it left off before ... just starts over. Though no worries as it could also be an xbmc issue.

Disregard above ... is working now. Smile
find
ronie Offline
Team-Kodi Member
Posts: 9,437
Joined: Jan 2009
Reputation: 165
Post: #274
minimoe Wrote:Perfect, thank you!

There is a small thing that bothers me with T! I don't know if it's been mentioned before but any video I'm watching pauses for a split second when I move the mouse to bring up the OSD. I doesn't happen with the other skins I've tried. I can't see anything wrong in the log:
Code:
21:58:35 T:1052 M:874102784   ERROR: CRemoteControl::Connect - failed to connect
21:58:37 T:2224 M:877846528 WARNING: XFILE::CVideoDatabaseDirectory::GetLabel - Unknown nodetype requested 12
21:58:40 T:2224 M:881672192  NOTICE: DVDPlayer: Opening: G:\TV\Fringe\Fringe.S03E17.720p.WEB-DL.Rus.Ukr.Eng.HDCLUB.mkv
21:58:40 T:2224 M:881664000 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
21:58:40 T:2180 M:881647616  NOTICE: Creating InputStream
21:58:40 T:2180 M:881610752  NOTICE: Creating Demuxer
21:58:40 T:1052 M:878272512   ERROR: CRemoteControl::Connect - failed to connect
21:58:41 T:2180 M:873021440  NOTICE: Opening video stream: 0 source: 256
21:58:41 T:2180 M:873017344  NOTICE: Creating video codec with codec id: 28
21:58:41 T:2180 M:873250816  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
21:58:41 T:2180 M:873189376  NOTICE: Creating video thread
21:58:41 T:2180 M:873189376  NOTICE: Opening audio stream: 1 source: 256
21:58:41 T:2180 M:873201664  NOTICE: Finding audio codec for: 86019
21:58:41 T:2180 M:873201664  NOTICE: Creating audio thread
21:58:41 T:2180 M:873201664  NOTICE: Opening Subtitle stream: 4 source: 256
21:58:41 T:1140 M:873181184  NOTICE: running thread: CDVDPlayerAudio::Process()
21:58:41 T:1140 M:873222144  NOTICE: Creating audio device with codec id: 86019, channels: 6, sample rate: 48000, no pass-through
21:58:41 T:3520 M:873193472  NOTICE: running thread: video_thread
21:58:41 T:3520 M:867651584  NOTICE:  fps: 23.976024, pwidth: 1280, pheight: 720, dwidth: 1280, dheight: 720
21:58:41 T:3520 M:869433344  NOTICE: Display resolution DESKTOP : 1280x800 @ 60.00 - Full Screen (12)
21:58:45 T:1052 M:858365952   ERROR: CRemoteControl::Connect - failed to connect
21:58:48 T:3520 M:859148288 WARNING: CDVDVideoCodecFFmpeg::Decode - avcodec_decode_video didn't consume the full packet. size: 17374, consumed: 0
21:58:49 T:3520 M:859312128 WARNING: CDVDVideoCodecFFmpeg::Decode - avcodec_decode_video didn't consume the full packet. size: 17115, consumed: 0
21:58:50 T:1052 M:860532736   ERROR: CRemoteControl::Connect - failed to connect
21:58:51 T:3520 M:861794304 WARNING: CDVDVideoCodecFFmpeg::Decode - avcodec_decode_video didn't consume the full packet. size: 4482, consumed: 0
21:58:51 T:2224 M:861126656  NOTICE: CDVDPlayer::CloseFile()
21:58:51 T:2224 M:859983872  NOTICE: DVDPlayer: waiting for threads to exit

Is there something I can do to fix this?

it seems to be related to the svn version not having a Textures.xbt file, but using the source images instead.

if you create a textures file, the issue disappears.

i'm seeing the same in other svn skins that don't come with a textures file (although to a much lesser degree, it's hardly noticeable but it's there).

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
minimoe Offline
Senior Member
Posts: 225
Joined: Feb 2011
Reputation: 3
Post: #275
ronie Wrote:it seems to be related to the svn version not having a Textures.xbt file, but using the source images instead.

if you create a textures file, the issue disappears.

i'm seeing the same in other svn skins that don't come with a textures file (although to a much lesser degree, it's hardly noticeable but it's there).

There is a textures.xbt file (~80MB) in AppData\Roaming\XBMC\addons\skin.transparency.svn\media\. I'm not sure if this is the file you mean.
find
ronie Offline
Team-Kodi Member
Posts: 9,437
Joined: Jan 2009
Reputation: 165
Post: #276
minimoe Wrote:There is a textures.xbt file (~80MB) in AppData\Roaming\XBMC\addons\skin.transparency.svn\media\. I'm not sure if this is the file you mean.

yes...guess i'll have to take another look at the problem then.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
ronie Offline
Team-Kodi Member
Posts: 9,437
Joined: Jan 2009
Reputation: 165
Post: #277
minimoe Wrote:There is a textures.xbt file (~80MB) in AppData\Roaming\XBMC\addons\skin.transparency.svn\media\. I'm not sure if this is the file you mean.

ok, i installed skin.transparency.svn from passion-xbmc.org (think you got it from there), but i don't see any issues.

could you test with the stable version (3.11.1) from the xbmc repo and report back ?

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
minimoe Offline
Senior Member
Posts: 225
Joined: Feb 2011
Reputation: 3
Post: #278
ronie Wrote:ok, i installed skin.transparency.svn from passion-xbmc.org (think you got it from there), but i don't see any issues.

could you test with the stable version (3.11.1) from the xbmc repo and report back ?

The situation is a little better with the 3.11.1 version. It only pauses on SD videos, when DXVA2 isn't activated. With HD material, when DXVA2 is working it is more like a judder than a pause.
find
ronie Offline
Team-Kodi Member
Posts: 9,437
Joined: Jan 2009
Reputation: 165
Post: #279
new in T! svn, tv guide:

[Image: tvguide.jpg]

[Image: tvguideposters.jpg]


how do i get it to work?
1) enable the next aired scipt:
Skin Settings > Scripts > Enable NextAired Script
2) add the tv guide submenu to the TV Shows menu:
Skin Settings > Menu > TV Shows > Submenu > TV Guide

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
grote002 Offline
Member
Posts: 94
Joined: Jan 2004
Reputation: 0
Post: #280
ronie Wrote:new in T! svn, tv guide:

how do i get it to work?
1) enable the next aired scipt:
Skin Settings > Scripts > Enable NextAired Script
2) add the tv guide submenu to the TV Shows menu:
Skin Settings > Menu > TV Shows > Submenu > TV Guide

I am gonna try that this evening when I get home, looks cool Smile

Intel Core2Quad 3,2Ghz, 2Gb RAM, Nvidia GTS450 on Ubuntu 10.10, Denon AVR-2311, Denon POA4400A
find
eddiem Offline
Senior Member
Posts: 115
Joined: Oct 2010
Reputation: 0
Location: Edinburgh, Scotland
Post: #281
Ronie, Great idea and looks good. Just one point which you can see in your screenshots, March 29 is both Tuesday and Thursday. I have April 15
on Tuesday and April 3 on Tuesday and Sunday. Thanks again, Eddie.

Just checked some dates and the TV Guide seems to be using the original air DAY and the next aired DATE.
In your screenshot "Destination Truth" was aired on Thursday but has now changed to Tuesday.
In my case "Body of Proof" S01E01 was aired on Tuesday 29 March, S01E02 will be shown on Sunday 3 April.
Shows in TV Guide as Tuesday 3 April.
(This post was last modified: 2011-03-31 00:20 by eddiem.)
find
grote002 Offline
Member
Posts: 94
Joined: Jan 2004
Reputation: 0
Post: #282
Hey Ronie, the script doesn't seem to work correctly for me, it doesn't show any covers for tvseries.

TV Show Next Aired

I tried changing the 'view' for the addon to 'Poster', 'Banner' and 'Wide', but the covers dont show up. Any ideas?

Intel Core2Quad 3,2Ghz, 2Gb RAM, Nvidia GTS450 on Ubuntu 10.10, Denon AVR-2311, Denon POA4400A
find
ezechiel1917 Offline
Aeon Group
Posts: 745
Joined: Jun 2005
Location: Czech Republic
Post: #283
yup, I can confirm this. (I only see tv show logos, although I have them disabled in skin settings but no covers)

XBMCbuntu 13.0 | XBMC PRE-14.0 | VDR + VNSI @ Technotrend CT-3650 CI | Transparency! skin | trakt.tv
find
ronie Offline
Team-Kodi Member
Posts: 9,437
Joined: Jan 2009
Reputation: 165
Post: #284
eddiem Wrote:Ronie, Great idea and looks good. Just one point which you can see in your screenshots, March 29 is both Tuesday and Thursday. I have April 15
on Tuesday and April 3 on Tuesday and Sunday. Thanks again, Eddie.

Just checked some dates and the TV Guide seems to be using the original air DAY and the next aired DATE.
In your screenshot "Destination Truth" was aired on Thursday but has now changed to Tuesday.
In my case "Body of Proof" S01E01 was aired on Tuesday 29 March, S01E02 will be shown on Sunday 3 April.
Shows in TV Guide as Tuesday 3 April.

the next aired script fetches the info from tvrage.com

as you can see here: http://www.tvrage.com/Destination_Truth
the show is listed to air on thursdays.


guess the only things you can do is to report any incorrect listings
on the tvrage forum:
http://www.tvrage.com/forums_viewtopic.p...2&fid=2882

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
eddiem Offline
Senior Member
Posts: 115
Joined: Oct 2010
Reputation: 0
Location: Edinburgh, Scotland
Post: #285
ronie Wrote:the next aired script fetches the info from tvrage.com

as you can see here: http://www.tvrage.com/Destination_Truth
the show is listed to air on thursdays.


guess the only things you can do is to report any incorrect listings
on the tvrage forum:
http://www.tvrage.com/forums_viewtopic.p...2&fid=2882

Thanks for the quick reply. I'll just leave as is. If the day is changed again
(as I see it will be from ep03) I'll be back at where I started.
At least I learned something new. Big Grin
find
Thread Closed