Skin "JX 720" (MC360 remake / re-think)

  Thread Rating:
  • 2 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
XBMCG33K Offline
Skilled Skinner
Posts: 1,252
Joined: Dec 2008
Reputation: 4
Location: 4 8 15 16 23 42
Post: #46
Does this have a SVN so I can grab the most up to date version?
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #47
Indeed same place I linked for every thing else in this thread https://code.google.com/p/jezzxbmc/source/checkout

or more specifically the url for just this skin is
Code:
https://jezzxbmc.googlecode.com/svn/trunk/skin.jx720
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #48
NEW VERSION 0.0.2

This one has all reported bugs fixed and some nice new animations for the background. Please keep reporting bugs if you find any because once bugs are all gone I'll start on some new media specific views like TV shows. And then we can get onto adding translations then into the repo

CLICK TO DOWNLOAD

Change LOG:
Quote:Version 0.0.2

- Added a pretty raindrop splash animation to the background using various clever animation techniques and one 128x128 image Smile (on by default disable it in skin settings if you want)
- Added "Shine" animation to the weather and system card headers
- Fixed Sliderex control had no default font color so was blank
- Changed make the File Browser dialog slightly transparent when opened in full screen media playback (so you can see the video under it)
- Changed fade out the video settings dialog when the browse dialog is open (eg: fetching subtitles)
- Fixed Alignment of Disclaimer and broken text in the addon info dialog
- Fixed Indent on Edit controls was off
- Added skinned the windows for the rss editor script to match the skin
- Fixed wrong icon for pictures in settings (thanks xbs08 for pointing it out)
- Fixed Added the stuff needed for Karaoke (thanks hitcher for reminding me)
- Fixed Now playing video covers had some weird effects going on
- Changed removed gradient from the blade runner and made them a solid color. It was causing a mega amount of "banding" on my TV ay 1080p and looked crap
- Changed removed the black text shadow from the list and updated the code at the same time
- Fixed spelling error (Weather Page)
- Changed "Add-ons" text in Apps blade to "Add-on manger" to avoid confusion
- Fixed no default edit control made the text blank for them in the skin
- Fixed sliderx didn't have disabled text

Version 0.0.1

- First Public Version
find quote
The-Boxhead Offline
Donor
Posts: 958
Joined: May 2005
Reputation: 17
Location: Norway
Post: #49
The-Boxhead Wrote:Hi again Jezz !

Both issues reported corrected, wow it's surely christemas time Smile

Not 100% sure if it's a skin bug. But in Confluence this works totally ok.

When streaming movies and if buffering occurs, The text percentage indicator
seems to often just hang at 1% and also the graphical bar doesen't move correctly. If i just wait movies continues to play after some time of re buffering.

Some time the indicators jump from 1% to 7% then nothing more, sometimes
other positions, point is that it dos not seem to actually smoothly progress with the real buffering that occurs.

Seen this behavior in many different video plugins and it should be easy for you to spot as long as you get buffering Wink That is if it's nothing weird with just my setup. But as mentioned Confluence works ok on my system regarding this Wink

Did you have a look at this Jezz ?

PointOfView Nvidia ION Atom 330 - TRANSCEND 2GB DDR2 DIMM 800MHz - G.SKILL 64GB SSD 2.5
Open Elec Beta4 1.95.4
XBMC Online Manual - HOW-TO post about a problem in a useful manner - Create/View Bug Report
Setup/Fix correct resolution on XBMC/Ubuntu - Usefull linux terminal commands
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #50
nah thats the one thing I forgot to look at sorry Sad also hard to test
find quote
xbs08 Offline
Posting Freak
Posts: 1,744
Joined: May 2008
Reputation: 7
Location: Portugal
Post: #51
Very nice background animation Smile

  • Intel NUC Kit DN2820FYKH
  • Crucial DDR3L SO-DIMM 4GB
  • SanDisk ReadyCache 32GB SSD
  • Microsoft MCE model 1039 RC6 remote
find quote
The-Boxhead Offline
Donor
Posts: 958
Joined: May 2005
Reputation: 17
Location: Norway
Post: #52
another minor bug.
When on the system blade and when selected the appearance entry
you have some text describing what lies under that category.

*GUI Calibration, this is not under Appearance but under the
"System" category and "video calibration"

Unless you mean something else with GUI Calibration ?

PointOfView Nvidia ION Atom 330 - TRANSCEND 2GB DDR2 DIMM 800MHz - G.SKILL 64GB SSD 2.5
Open Elec Beta4 1.95.4
XBMC Online Manual - HOW-TO post about a problem in a useful manner - Create/View Bug Report
Setup/Fix correct resolution on XBMC/Ubuntu - Usefull linux terminal commands
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #53
heh yeah I need to edit those texts they are still left over from the xbox days I just copied and pasted them and didn't look back
find quote
Rocky5 Offline
Alaska Group
Posts: 564
Joined: Jun 2008
Location: Scotland
Post: #54
you may want to do what I done with SliK to remove the trailing white border for the Poster view.
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #55
The-Boxhead Wrote:Hi again Jezz !

Both issues reported corrected, wow it's surely christemas time Smile

Not 100% sure if it's a skin bug. But in Confluence this works totally ok.

When streaming movies and if buffering occurs, The text percentage indicator
seems to often just hang at 1% and also the graphical bar doesen't move correctly. If i just wait movies continues to play after some time of re buffering.

Some time the indicators jump from 1% to 7% then nothing more, sometimes
other positions, point is that it dos not seem to actually smoothly progress with the real buffering that occurs.

Seen this behavior in many different video plugins and it should be easy for you to spot as long as you get buffering Wink That is if it's nothing weird with just my setup. But as mentioned Confluence works ok on my system regarding this Wink
I just tried this (streaming 1080p trailers from apple) and didn't have any issue at all :\ unlike confluence this one doesn't have a separate progress bar for buffering, but the text smoothly went from 1 to 100% for me with no issues
find quote
DukeOfTheWicked Offline
Member
Posts: 82
Joined: Oct 2010
Reputation: 0
Location: USA
Post: #56
This looks real good.
those animations look pretty nice. It adds a bit of life to the skin.

One very small issue I noticed is that in the system blade the positioning for descriptive text for 'profiles' is off. And that is as of rev. 278 I think.

Something I thought about is that with Dharma and the new add-ons manager everybody is going to be able to get JX720 (once it makes it to the repo), even if they are not tech savvy. So they would not be going through pages on the forum to see that there is no mouse support. The average user may just think there is something wrong with your skin and avoid it. Maybe do something like Xperience did and instead of a pointer change it to a WARNING. Just a thought.

-DOTW
(This post was last modified: 2010-12-30 12:57 by DukeOfTheWicked.)
find quote
The-Boxhead Offline
Donor
Posts: 958
Joined: May 2005
Reputation: 17
Location: Norway
Post: #57
Jezz_X Wrote:I just tried this (streaming 1080p trailers from apple) and didn't have any issue at all :\ unlike confluence this one doesn't have a separate progress bar for buffering, but the text smoothly went from 1 to 100% for me with no issues

After the new version 0.0.2 text works ok but the bar stil acts up on me Wink

PointOfView Nvidia ION Atom 330 - TRANSCEND 2GB DDR2 DIMM 800MHz - G.SKILL 64GB SSD 2.5
Open Elec Beta4 1.95.4
XBMC Online Manual - HOW-TO post about a problem in a useful manner - Create/View Bug Report
Setup/Fix correct resolution on XBMC/Ubuntu - Usefull linux terminal commands
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #58
DukeOfTheWicked Wrote:This looks real good.
those animations look pretty nice. It adds a bit of life to the skin.

One very small issue I noticed is that in the system blade the positioning for descriptive text for 'profiles' is off. And that is as of rev. 278 I think.

-DOTW

Your going to have to be a bit more specific about that the only difference I see is its the only one that "Including." doesn't go onto a new line
find quote
XBMCG33K Offline
Skilled Skinner
Posts: 1,252
Joined: Dec 2008
Reputation: 4
Location: 4 8 15 16 23 42
Post: #59
Could you possibly constrain poster sizes so they match the sizes in poster big view? What I mean by this is in List view if you have a poster that's a different size (in my case one is a bit more square than the others) when switching between movies the poster change is very noticeable, however in Poster Big view all posters have the same layout they look great.
find quote
The-Boxhead Offline
Donor
Posts: 958
Joined: May 2005
Reputation: 17
Location: Norway
Post: #60
any1 had any problems with wrapping in list views ?
Seems like if i enter a new list view it wraps the first time i try but second
time it doesent wrap anymore. Maybe i'm just tired Wink

PointOfView Nvidia ION Atom 330 - TRANSCEND 2GB DDR2 DIMM 800MHz - G.SKILL 64GB SSD 2.5
Open Elec Beta4 1.95.4
XBMC Online Manual - HOW-TO post about a problem in a useful manner - Create/View Bug Report
Setup/Fix correct resolution on XBMC/Ubuntu - Usefull linux terminal commands
find quote
Post Reply