Kodi Community Forum

Full Version: opensubtitles.org no longer working - Tried everything i think?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
Hi Guys

I simply CAN NOT get my preferred subtitles addon opensubtitles.org to work anymore... 

1: I have been registered at their site for a long time, but using the official add-on ( keeps telling me that the user/pass is wrong.
2: Tried uninstalling and installing official add-on again without any luck.
3: Tried creating a new user with a new password to use with the official add-on without any luck
4: Tried downgrading the official add-on to without any luck
5: Installed the unofficial (5.2.14?) version from various threads and ran it without credentials without any luck
6: Tried using both mu profiles/accounts with the unofficial version, but also without any luck.
7: Have been testing this on Kodi 17.6 on three different machines (iMac, small OpenELEC machine and a nVidia Shield TV) without any luck.

Is the simply no way to use opensubtitles.org with Kodi anymore?
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
If you do some research you will notice that their webpage is down/no longer reachable.   Try using an alternative.
Working here. (the web page that is)
Are you reffering to opensubtitles.co ?  I don't see anywhere to login with my username from opensubtitles.org

Edit:  tried via my mobile, it seems they're blocked by my ISP similar to piracy sites.   Well technically subtitles are piracy as they are copies of intellectual piracy.
I had the same problem, but read somewhere that changing your DNS to Googles solved the problem, it did for a while, but it does not work anymore
Doesn't work for me although I was able to go to opensubtitles.org and download a subtitle by hand.  What's a good alternative?
I had the same problem....

my log file...

@Karellen- Log removed. Read the forum rules
(2018-03-23, 16:46)juanpnranjo Wrote: [ -> ]I had the same problem....
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.

PS: Please also read the big fat red text above the Post Reply button when submitting logs.
Ok I have also the problem. I only get error message "OpenSubtitles.org by OpenSubtitles Error Check the log for more information". Nothing else.

This error repeats with: New clean install of Kodi just downloaded from your site (in Win10, 64-bit), With Kodi isntalled from Winows store. With Kodi installed from Google Play store in Philips Android TV.. and this started to happen just this week.. so.. something broke! Was there an update to some Kodi addon functioanlity?

And yes, tryed also with addon downloaded from opensubtitle.org site.. (newer version), both with signed in to opensubtitles.org and without. Same end result every time.

And here is the log from a clean new install of Kodi:

@Karellen- Log removed. Read the forum rules
Same goes for the Turkish language. I think, I don't need to add detailed log for this since the symptoms are exactly the same, but here you go anyway;


19:14:59.656 T:1945072192   DEBUG: OnKey: 11 (0x0b, obc244) pressed, action is Select
19:14:59.656 T:1945072192   DEBUG: New Service [service.subtitles.opensubtitles_by_opensubtitles]
19:14:59.663 T:1439003552   DEBUG: StartScript - calling plugin OpenSubtitles.org by OpenSubtitles('plugin://service.subtitles.opensubtitles_by_opensubtitles/','28','?action=search&languages=Turkish&preferredlanguage=Turkish')
19:14:59.664 T:1343218592   DEBUG: Thread LanguageInvoker start, auto delete: false
19:14:59.664 T:1343218592    INFO: initializing python engine.
19:14:59.664 T:1343218592   DEBUG: CPythonInvoker(34, /storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles/service.py): start processing
19:14:59.717 T:1945072192   DEBUG: CMMALRenderer::RenderUpdate - vsync 73316 (+2)
19:14:59.741 T:1945072192   DEBUG: CMMALRenderer::RenderUpdate - vsync 73319 (+1)
19:14:59.772 T:1343218592   DEBUG: -->Python Interpreter Initialized<--
19:14:59.773 T:1343218592   DEBUG: CPythonInvoker(34, /storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles/service.py): the source file to load is "/storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles/service.py"
19:14:59.773 T:1343218592   DEBUG: CPythonInvoker(34, /storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles/service.py): setting the Python path to /storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles:/usr/lib/python27.zip:/usr/lib/python2.7:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/lib/python2.7/site-packages:/usr/lib/python2.7/site-packages/gtk-2.0
19:14:59.774 T:1343218592   DEBUG: CPythonInvoker(34, /storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles/service.py): entering source directory /storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles
19:14:59.774 T:1343218592   DEBUG: CPythonInvoker(34, /storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles/service.py): instantiating addon using automatically obtained id of "service.subtitles.opensubtitles_by_opensubtitles" dependent on version 2.1.0 of the xbmc.python api

19:15:22.082 T:1343218592   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'dict' object has no attribute 'sort'
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles/service.py", line 210, in <module>
                                              File "/storage/.kodi/addons/service.subtitles.opensubtitles_by_opensubtitles/service.py", line 43, in Search
                                                search_data.sort(key=lambda x: [not x['MatchedBy'] == 'moviehash',
                                            AttributeError: 'dict' object has no attribute 'sort'
                                            -->End of Python script error report<--
19:15:22.102 T:1945072192   DEBUG: ------ Window Init (DialogNotification.xml) ------
19:15:22.128 T:1945072192   DEBUG: CMMALRenderer::RenderUpdate - vsync 74662 (+1)
19:15:22.172 T:1945072192   DEBUG: CMMALRenderer::RenderUpdate - vsync 74665 (+1)
19:15:22.260 T:1945072192   DEBUG: CMMALRenderer::RenderUpdate - vsync 74670 (+1)
19:15:22.296 T:1945072192   DEBUG: CMMALRenderer::RenderUpdate - vsync 74672 (+1)
19:15:22.329 T:1945072192   DEBUG: CMMALRenderer::RenderUpdate - vsync 74674 (+1)
19:15:22.338 T:1343218592    INFO: Python script stopped
19:15:22.338 T:1343218592   DEBUG: Thread LanguageInvoker 1343218592 terminating
19:15:22.346 T:1439003552   ERROR: GetDirectory - Error getting plugin://service.subtitles.opensubtitles_by_opensubtitles/?action=search&languages=Turkish&preferredlanguage=Turkish
Stop posting logs in the thread please!
I have the same problem here.

@Karellen- Log removed... Even though the post immediately before yours, by @nickr, requests no more logs in the thread, you still chose to post a log....
OK we've established its an issue.  No need for more log files.  Just need a solution.
Pages: 1 2 3 4