Kodi Community Forum
[RELEASE] Twitch.tv - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Twitch.tv (/showthread.php?tid=134538)



RE: [RELEASE] Twitch.tv - frackz - 2018-02-02

Hmm strange. I literally cant play a stream on Twitch anymore.


RE: [RELEASE] Twitch.tv - anxdpanic - 2018-02-02

I've been running fine all day switching streams in the background, I did remove the top of my pi case due to other videos having issues(they are working now as well). So my issue may have been overheating, I haven't taken the time to confirm yet.
If you post a debug_log (wiki) I can take a look, though most issues after playback is initiated are out of our hands. Could be something on their end, or your route to them which wouldn't show. Being 3 days since you first reported, I think we'd be seeing more here or on github if this was widespread.


RE: [RELEASE] Twitch.tv - Chupz0r - 2018-02-03

Can you add setting for adjusting timeout to reconnect? 1 min too long for me.


RE: [RELEASE] Twitch.tv - frackz - 2018-02-03

(2018-02-02, 02:22)anxdpanic Wrote: I've been running fine all day switching streams in the background, I did remove the top of my pi case due to other videos having issues(they are working now as well). So my issue may have been overheating, I haven't taken the time to confirm yet.
If you post a debug_log (wiki) I can take a look, though most issues after playback is initiated are out of our hands. Could be something on their end, or your route to them which wouldn't show. Being 3 days since you first reported, I think we'd be seeing more here or on github if this was widespread.
 I have checked the debug log and did some tests with Ares, seems to be network-related. Sorry for the trouble.


RE: [RELEASE] Twitch.tv - Klojum - 2018-02-03

(2018-02-03, 14:30)frackz Wrote: I have checked the debug log and did some tests with Ares,
It only goes to show, banned add-ons are no good. Don't let it happen again Smile


RE: [RELEASE] Twitch.tv - anxdpanic - 2018-02-03

@Chupz0r Sorry, settings for reconnection times won't be made available. It's a static process so that our traffic doesn't cause any issues when a stream that has many viewers(in the add-on) drops.


RE: [RELEASE] Twitch.tv - jaynford - 2018-02-22

I am on Kodi v18, and I am having severe desyncs in audio and video. It gets worse and worse as playback goes on. It isn't occurring on other video content and I wasnt having this on 17, so maybe its that, but I don't believe so. Anyone else experience this?


RE: [RELEASE] Twitch.tv - Jim70 - 2018-03-05

I've been having the same Twitch problems as described in earlier posts from "frackz" on both Raspberry PI 2 & 3 running Libreelec, but on live streams only. Also have a Fire tv stick origional version with latest Kodi and that runs twitch perfectly.
Have found that with Twitch "Settings" -> "General" -> "Video Quality" set to "Always Ask" and "Settings" -> "General" -> "Use inputstream.adaptive" selected. Then when prompted if the last option in the list "Adaptive" is selected then the stream runs perfectly with no lags or freezing. Strange but true.


RE: [RELEASE] Twitch.tv - supersmilers - 2018-04-12

Props to the creator for the add on. It would be nicer if the add-on would fully support 1080p. I selected "Source" but it won't output in 1080p on my Samsung Galaxy S8 and my PC.

Otherwise, it's great!


RE: [RELEASE] Twitch.tv - blindhai - 2018-04-12

Quote:Props to the creator for the add on. It would be nicer if the add-on would fully support 1080p. I selected "Source" but it won't output in 1080p on my Samsung Galaxy S8 and my PC.

Otherwise, it's great!

1080p is possible with MPEG DASH.

https://www.reddit.com/r/kodi/comments/5sdpla/dash_has_now_been_added_to_kodi_17_1080p_60fps_on/


RE: [RELEASE] Twitch.tv - supersmilers - 2018-04-13

(2018-04-12, 20:43)blindhai Wrote:
Quote:Props to the creator for the add on. It would be nicer if the add-on would fully support 1080p. I selected "Source" but it won't output in 1080p on my Samsung Galaxy S8 and my PC.

Otherwise, it's great!

1080p is possible with MPEG DASH.

https://www.reddit.com/r/kodi/comments/5sdpla/dash_has_now_been_added_to_kodi_17_1080p_60fps_on/ 
 Really? I enabled MPEG-Dash, but I guess most of the streamers forgot to set 1080p or they might have a PC that couldn't handle both streaming and playing a GPU-demanding games at the same time. I guess that's why some streams are set to 480p or up to 720p as source.

But thanks anyway.


RE: [RELEASE] Twitch.tv - Steph09 - 2018-05-01

On the recent nightly builds of Kodi i cannot get this addon to work correctly. It will play a live stream for 5-10 seconds & then just stop, I've tried all the resolution options & it does the same regardless.


Nevermind i've fixed it.... Even though I had it set to use inputstream adaptive & had the default resolution set to adaptive it wasn't using it, Had to select the adaptive resolution manually when starting the video.


RE: [RELEASE] Twitch.tv - PnoT - 2018-05-30

(2018-03-05, 17:45)Jim70 Wrote: I've been having the same Twitch problems as described in earlier posts from "frackz" on both Raspberry PI 2 & 3 running Libreelec, but on live streams only. Also have a Fire tv stick origional version with latest Kodi and that runs twitch perfectly.
Have found that with Twitch "Settings" -> "General" -> "Video Quality" set to "Always Ask" and "Settings" -> "General" -> "Use inputstream.adaptive" selected. Then when prompted if the last option in the list "Adaptive" is selected then the stream runs perfectly with no lags or freezing. Strange but true.
 I'm on three different Kodi boxes (Vero 4K, Shield TV, and a RPi3) all of which started to stutter the last two days.  The symptoms are exactly as the quote suggests above and the workaround was to setup my addon to the settings above.  I've never had issues out of this on all 3 machines so I'm not sure what's changed and having to manually chose the quality every singe stream I want to watch is not ideal.  Anyone else having this issue?

I'm on the current 2.2.2 release.


RE: [RELEASE] Twitch.tv - anxdpanic - 2018-05-30

@PnoT You can change Settings - General - Video Quality to Adaptive to make adaptive the default quality. Note some streams may not work with adaptive, for those you'll have to set default quality or play (choose quality).


RE: [RELEASE] Twitch.tv - PnoT - 2018-05-30

(2018-05-30, 23:43)anxdpanic Wrote: @PnoT You can change Settings - General - Video Quality to Adaptive to make adaptive the default quality. Note some streams may not work with adaptive, for those you'll have to set default quality or play (choose quality).
 Ok, that makes it a bit easier but every stream isn't going to work the way it used to with me just making "source" the default and it working no matter.  What's changed that's causing this?  GitHub has issue #307 that's been opened for a while and in that thread there's still no mention of a "fix".

I also have PIA and another VPN service setup on my pfSense router in which I can selective route devices through either and still the same issues so my ISP isn't a factor at this point.

I'm a big Dota 2 fan and W33 stream on Twitch doesn't play with Adaptive or Source at this point and buffering / stalling out completely happens.


This forum uses Lukasz Tkacz MyBB addons.