Kodi Community Forum
Release Experimental Google Music Addon - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Release Experimental Google Music Addon (/showthread.php?tid=200640)



RE: Experimental Google Music Addon - dexdeadly - 2016-06-21

Hello foreverguest, yes this is now working. The audio track plays, however no artistart is being set as the fanart background. Possibly this is due to a limitation as to what is sent back when looking up the information?


RE: Experimental Google Music Addon - jmh2002 - 2016-06-21

@foreverguest

I just wanted to thank you again for this very good addon and your work here to keep it up to date Nod


RE: Experimental Google Music Addon - Shogun - 2016-06-24

Got an issue....
If i choose a playlist (e.g. under "Genres") it automatically starts...
That's fine, but after the first track changes automatically to the next one, i get this one:

Image

If i skip tracks manually, it works fine:

Image

This problem doesn't occur with other music addons.
Using Jarvis 16.1 and Aeon Madnox.

Edit:
Seems related to how container are handled.
If i open a container, where i can choose a track (e.g. "Tracks" under "Top-Charts"), it works flawlessly.

Edit 2:

Tried different older versions. Problem starts with 1.9. Earlier versions are allowing the selection of tracks within playlists.


RE: Experimental Google Music Addon - foreverguest - 2016-06-25

Have you noticed any errors in the log? Please share it.


RE: Experimental Google Music Addon - boucchar - 2016-06-26

Hi Foreverguest!

Thank you very much for the support of free radio station!

Work very well on my device!

Your a boss!

Best regards


RE: Experimental Google Music Addon - kobyboy - 2016-06-30

YEAH BOY what a fantastic addy and support as well THANK YOU !!!


RE: Experimental Google Music Addon - agoMiST - 2016-07-02

I've got the same (or a very similar) issue to Shogun above.

I'm using the spmc fork (16.1) on SHIELD TV, Aeon Nox Silvo skin, and today is the first time I've used this add-on.

So, here's what happens:

I go into GM EXP, my library, artists, pick a track, start radio: everything is fine

As soon as the next track plays naturally
1) It drops all metadata. Both artist and album fields are blank, title field displays artist and track name as if the file is untagged
2) Artist slideshow ceases to function leaving just the Google Play fanart as a fallback
3) Last.fm scrobbler completely craps out, it ceases to scrobble now playing and doesn't scrobble the previous track as played whatsoever

If you then skip back to the previous track and then manually skip forward everything is once again hunky dory...until it progresses naturally to the next track.

Here's my log http://bit.ly/29k5uCn (please excuse the flood of errors at the bottom, the spmc log uploader didn't want to play ball, hence the tinyupload host)
For the relevant part I played one track fully then let the next play partially before skipping back then forward to trigger metadata and other addons functioning properly again.

Thanks for the addon and I hope you can remedy this quibble ;o)


RE: Experimental Google Music Addon - foreverguest - 2016-07-08

I'm not able to reproduce the 'no-metadata-when-playing-radio' problem.

Are you (agoMiST, Shogun) subscribers or just uploaders?


RE: Experimental Google Music Addon - agoMiST - 2016-07-08

I'm a subscriber.

I've sort of found a "workaround"

If you start a radio from the context menu (or the listen now section) it stops reading metadata as above.

However if you then go to My Library > Stations and select the radio you tried to play, it will work from there.

I'm guessing it has something to do with trying to direct play a radio playlist as the only difference is that when you select a station in the My Library section it brings up the song list first and then requires a further click to start playing.


RE: Experimental Google Music Addon - zoula - 2016-07-12

Hi,

I have a family plan and I'm trying to login on of the family member. I have no difficulty at all for all but one user of my family plan. I could login with this user but when I try to play some music I always get an error message that I can't receive the stream. I could see the specific library for this particular user witch tells me that I am really login in the account, but I can't play any music. Again, with all the others members of my family plan I could the plugin fine...Huh?

Thank you,
Zoula


RE: Experimental Google Music Addon - Abbaskip - 2016-07-13

This is awesome. Love the add on.

Two things I would like to see it's a "play all and shuffle on YouTube" option for playlists, and possibly some way off better identifying authentic/original videos of songs on YouTube. I got quite a few live versions and covers.

But the basic functionality of all of the Google play aspects seems great!


RE: Experimental Google Music Addon - foreverguest - 2016-07-14

@zoula, failure to play a song usually is related to the user streaming from another device at the same time, more than 10 devices registered or no Android device registered.

@Abbaskip, thanks, I'll try to improve Youtube feature in next version.


RE: Experimental Google Music Addon - zoula - 2016-07-15

Thank you for the advice "Foreverguest", But unfortunately, this is not the case. This is a brand new account with no mobile device link to the account. Everything play fine from her laptop or an other computer, I also make sure to logout before trying to use the Kodi plugin. I'm 99.999999% sur this is not related to a second device playing at the same time.

Thank you,


RE: Experimental Google Music Addon - foreverguest - 2016-07-15

Try to register an Android device to her account.


RE: Experimental Google Music Addon - Director83 - 2016-07-19

Hello,

I am quite excited to be able to use a google play app, so thank you for all of the hard work, but this is not working for me on either my raspberry pi 3 with osmc, or on my laptop with windows 10.

In both cases, it seems to bring in my library (thought not all of it), but when I try to play a song it gives me several error popups. "Playback Failed- One or more items failed to play. Check the log for more information about this message." and a Google Music EXP error Check the log for more information popup in the bottom right corner. The issues are the same on both devices. The addon was installed using the foreverguest zip file repository.

Can anyone help?


This forum uses Lukasz Tkacz MyBB addons.