Kodi Community Forum
Release Experimental Google Music Addon - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Release Experimental Google Music Addon (/showthread.php?tid=200640)



RE: Experimental Google Music Addon - foreverguest - 2017-09-08

I had the same problem, I guess something changed on Google side, please check if version below works for you:
plugin.audio.googlemusic.exp-1.12beta1


RE: Experimental Google Music Addon - Abbaskip - 2017-09-08

(2017-09-08, 14:23)foreverguest Wrote: I had the same problem, I guess something changed on Google side, please check if version below works for you:
plugin.audio.googlemusic.exp-1.12beta1

Unfortunately not. I still get Invalid Credentials or Connectivity Problems.

I tried Uninstall the add-on, deleting my settings file, and installing from scratch to get this error.

The logs say:
Code:
22:48:34.396 T:20408   ERROR: XFILE::CDirectory::GetDirectory - Error getting return
22:48:34.396 T:20408   ERROR: CGUIMediaWindow::GetDirectory(return) failed
22:48:48.296 T:20408   ERROR: Control 50 in window 10502 has been asked to focus, but it can't
22:48:48.558 T:18748  NOTICE: [GoogleMusicEXP-1.12beta1]  ARGV: ['plugin://plugin.audio.googlemusic.exp/', '10', '']
22:48:49.988 T:18748  NOTICE: [GoogleMusicEXP-1.12beta1] Checking init data
22:48:49.989 T:18748  NOTICE: [GoogleMusicEXP-1.12beta1] Cache database error, clear OperationalError('no such table: songs',)
22:49:06.898 T:18748  NOTICE: [GoogleMusicEXP-1.12beta1] Trying to fetch the device_id
22:49:06.898 T:18748  NOTICE: [GoogleMusicEXP-1.12beta1] Logging in
22:49:07.974 T:18748  NOTICE: [GoogleMusicEXP-1.12beta1] Login in with device_id failed, trying with MAC
22:49:08.719 T:18748  NOTICE: [GoogleMusicEXP-1.12beta1] Login failed

Let me know if I can help any further.

I'm running 17.4 on a Windows machine if that is relevant or helps.


RE: Experimental Google Music Addon - foreverguest - 2017-09-08

You can try to obtain the device_id from your Android mobile (install a Device ID app) and manually add a line to your settings.xml:
Code:
<setting id="device_id" value="xxxxxx" />



RE: Experimental Google Music Addon - Abbaskip - 2017-09-09

(2017-09-08, 17:49)foreverguest Wrote: You can try to obtain the device_id from your Android mobile (install a Device ID app) and manually add a line to your settings.xml:
Code:
<setting id="device_id" value="xxxxxx" />

How do I find the device_id? Everything I google on it refers to the IMEI - should I use my IMEI?


RE: Experimental Google Music Addon - foreverguest - 2017-09-09

It is an internal code used only by Google to identify an Android device.
In Google Play Store you can find several Device ID apps that show the device_id of your mobile, I use this: https://play.google.com/store/apps/details?id=com.redphx.deviceid


RE: Experimental Google Music Addon - Abbaskip - 2017-09-09

Added the Device ID, still get the same error Sad

Is it currently working for you? I don't understand what could possibly have changed to make it not work on mine, but nobody else reporting issues? (especially with 2 google accounts)

If so, could it possibly be worth me trying the 2-step verification? If so - what is the process to get the app specific password etc that you mention?


RE: Experimental Google Music Addon - Abbaskip - 2017-09-09

Does this login error help?
Code:
10:40:12.195 T:12116   ERROR: Control 50 in window 10502 has been asked to focus, but it can't
10:40:12.258 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1]  ARGV: ['plugin://plugin.audio.googlemusic.exp/', '21', '']
10:40:12.486 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1] Initing addon data
10:40:12.619 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1] Trying to fetch the device_id
10:40:12.619 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1] Logging in
10:40:13.090 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1] Login in with device_id failed, trying with MAC
10:40:13.642 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1] Login failed
10:40:14.916 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1] ERROR: TypeError('exceptions must be old-style classes or derived from BaseException, not NoneType',)
10:40:14.923 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1] PATH: root
10:40:14.923 T:20136  NOTICE: [GoogleMusicEXP-1.12beta1] Assembling menu for subscriber=False and library=''
10:40:30.422 T:13196   ERROR: Unable to find plugin
10:40:30.422 T:12116   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://
10:40:30.422 T:12116   ERROR: CGUIMediaWindow::GetDirectory(plugin://) failed
10:40:46.404 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1]  ARGV: ['plugin://plugin.audio.googlemusic.exp/', '22', '']
10:40:47.627 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1] Initing addon data
10:40:47.795 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1] Trying to fetch the device_id
10:40:47.795 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1] Logging in
10:40:48.397 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1] Login in with device_id failed, trying with MAC
10:40:48.973 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1] Login failed
10:40:51.192 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1] ERROR: TypeError('exceptions must be old-style classes or derived from BaseException, not NoneType',)
10:40:51.200 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1] PATH: root
10:40:51.200 T:17428  NOTICE: [GoogleMusicEXP-1.12beta1] Assembling menu for subscriber=False and library=''

Mainly referring to the "ERROR: TypeError('exceptions must be old-style classes or derived from BaseException, not NoneType',)"


RE: Experimental Google Music Addon - luke7 - 2017-09-09

Hi all,

seems that Google has changed something. I am getting the same login error out of sudden:

08:51:37.261 T:1440949232 NOTICE: [GoogleMusicEXP-1.11.1] ARGV: ['plugin://plugin.audio.googlemusic.exp/', '365', '']
08:51:38.955 T:1440949232 NOTICE: [GoogleMusicEXP-1.11.1] Checking init data
08:51:39.837 T:1440949232 NOTICE: [GoogleMusicEXP-1.11.1] Trying to fetch the device_id
08:51:39.837 T:1440949232 NOTICE: [GoogleMusicEXP-1.11.1] Logging in
08:51:40.137 T:1440949232 NOTICE: [GoogleMusicEXP-1.11.1] Login in with device_id failed, trying with MAC
08:51:40.309 T:1440949232 NOTICE: [GoogleMusicEXP-1.11.1] Login failed

I am interested if it's working for someone.
I am not currently using any android device, so I will check to setup device id directly after I get one.

Thanks for any hints in advance.

UPDATE:
I did the test with new beta, set or unset device_id taken from adroid tablet where I was able to subscribe with same credentials and it's still the same.
09:54:20.428 T:1938813936 NOTICE: [GoogleMusicEXP-1.12beta1] Checking init data
09:54:58.804 T:1938813936 NOTICE: [GoogleMusicEXP-1.12beta1] Initing addon data
09:54:59.694 T:1938813936 NOTICE: [GoogleMusicEXP-1.12beta1] Trying to fetch the device_id
09:54:59.695 T:1938813936 NOTICE: [GoogleMusicEXP-1.12beta1] Logging in
09:54:59.983 T:1938813936 NOTICE: [GoogleMusicEXP-1.12beta1] Login in with device_id failed, trying with MAC
09:55:00.182 T:1938813936 NOTICE: [GoogleMusicEXP-1.12beta1] Login failed
09:55:03.059 T:1938813936 NOTICE: [GoogleMusicEXP-1.12beta1] ERROR: TypeError('exceptions must be old-style classes or derived from BaseException, not NoneType',)

I am running osmc 17.2 on rpi3.


RE: Experimental Google Music Addon - jmh2002 - 2017-09-09

Strangely enough it's still working for me without any problems. Tested on a windows device.


RE: Experimental Google Music Addon - MKANET - 2017-09-09

Works for me. I use this addon every day. Addon Version 1.11 running on Kodi for Windows. I'm on the Google Music Family subscription.


RE: Experimental Google Music Addon - Abbaskip - 2017-09-10

So strange that it's working for some and not others.

For the people it's working for, are you using 2 factor authentication?

I'm on a Family Subscription and on a windows device and not working with either of my Google accounts (both have Android device registered and it was working until last week).


RE: Experimental Google Music Addon - MKANET - 2017-09-10

I'm using single factor authentication. The only other thing I can think of is the below setting (which I had enabled a while back for another app I use). Let me know, if these of those settings makes a difference.

Image


RE: Experimental Google Music Addon - Abbaskip - 2017-09-11

(2017-09-10, 23:00)MKANET Wrote: I'm using single factor authentication. The only other thing I can think of is the below setting (which I had enabled a while back for another app I use). Let me know, if these of those settings makes a difference.

Image

I have that one enabled already Sad

So strange that it worked for so long, then suddenly just stopped.


RE: Experimental Google Music Addon - spoco2 - 2017-09-11

Ditto here for the login issue, just started also, with no changes that I know of Google side or Kodi side


RE: Experimental Google Music Addon - Abbaskip - 2017-09-11

(2017-09-11, 06:57)spoco2 Wrote: Ditto here for the login issue, just started also, with no changes that I know of Google side or Kodi side

What version of Kodi are you running, and Windows?

I'm on 17.4 and Windows.

I wonder if it's perhaps another addon/repo that us guys have installed causing the issue some how (a dependency etc).

Any ideas @foreverguest ?


This forum uses Lukasz Tkacz MyBB addons.