Kodi Community Forum
Beta Spotify for Kodi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Beta Spotify for Kodi (/showthread.php?tid=265356)



RE: Spotify for Kodi - Oineri - 2016-09-04

(2016-09-04, 20:27)marcelveldt Wrote:
(2016-09-04, 18:16)werewolf80 Wrote: same issue here on a windows machine... first couple of seconds playing music, than silence. Restarting the track and it plays fine, but couple of tracks later same problem... silence.

I've just uploaded version 1.0.21 to the repo which will fix the playback issue. Please test.

Note that the playback issue on Kodi Krypton is still being worked on, that will be fixed in Kodi's code.

I still have playback issues with version 1.0.21 on OSMC , on windows it works great.


RE: Spotify for Kodi - marcelveldt - 2016-09-04

(2016-09-04, 21:58)Oineri Wrote: I still have playback issues with version 1.0.21 on OSMC , on windows it works great.

Did you restart Kodi/your device after installing the update ?
Also, is the issue still the same ? Only several seconds of each track ?


RE: Spotify for Kodi - ViZZY - 2016-09-04

First of all, allow me to thank you for your continued efforts on this wonderful addon! I use it almost daily and truly appreciate all the work you put into it! Big Grin

I'm running Windows 8 (I know lol, was a gifted laptop so...) on my main Kodi laptop that I use with my receiver and sound system and after installing the update yesterday noticed the same bug others are commenting on, playback starts so fast now (no more opening track dialog box delay!!) but sadly the playback turns to silence about 12 seconds into the track. If I let it be until the next track starts, it usually lasts a little longer, about 30 seconds but still turns to silence. I just installed the new update and restated and issue persists. Thank you for reading and all you're doing to fix these issues in your free time! You ROCK! Big Grin


RE: Spotify for Kodi - marcelveldt - 2016-09-04

Hmmm, strange... My libreelec httpc had the same issue but that one is working fine now with the latest update.
My windows 10 dev machine never had the issue in the first place.

I will look into it again and if I can spot the solution I'll post a new version asap.

Can one if you post a kodi debug log for me to investigate ?


RE: Spotify for Kodi - ViZZY - 2016-09-04

(2016-09-04, 23:30)marcelveldt Wrote: Hmmm, strange... My libreelec httpc had the same issue but that one is working fine now with the latest update.
My windows 10 dev machine never had the issue in the first place.

I will look into it again and if I can spot the solution I'll post a new version asap.

Can one if you post a kodi debug log for me to investigate ?


Thank you for the blazing fast response and dedication! Here's a log of the error happening after reproducing, hopefully I did this right!

Log


RE: Spotify for Kodi - bebox - 2016-09-05

works again after updating. Great!![/align]


RE: Spotify for Kodi - Oineri - 2016-09-05

(2016-09-04, 22:35)marcelveldt Wrote:
(2016-09-04, 21:58)Oineri Wrote: I still have playback issues with version 1.0.21 on OSMC , on windows it works great.

Did you restart Kodi/your device after installing the update ?
Also, is the issue still the same ? Only several seconds of each track ?

Yep have restarted raspberry.

Did enable debug logging. This happens when i start a song and then wait it do the thing.
Log

Setup:
OSMC 2016.08-1 Raspberry Pi 3
Spotify version 1.0.21

Issue:
Song start and lasts max 12 sec, press next song same thing happens.


I have even installed osmc from scratch and the problem persist. Big Grin

Do you need something more? Smile


RE: Spotify for Kodi - marcelveldt - 2016-09-05

(2016-09-04, 23:43)ViZZY Wrote: Thank you for the blazing fast response and dedication! Here's a log of the error happening after reproducing, hopefully I did this right!

Log

New version 1.0.22 will be available on the repo within a few minutes. Please test again with that version, it should be fixed now


RE: Spotify for Kodi - britishopen93 - 2016-09-05

Tested 1.0.22 on Openelec 6.0.3 and it works again!
Thank you, you are the best!


RE: Spotify for Kodi - Oineri - 2016-09-05

(2016-09-05, 20:04)marcelveldt Wrote:
(2016-09-04, 23:43)ViZZY Wrote: Thank you for the blazing fast response and dedication! Here's a log of the error happening after reproducing, hopefully I did this right!

Log

New version 1.0.22 will be available on the repo within a few minutes. Please test again with that version, it should be fixed now


Music Thank you, it works ! Smile


RE: Spotify for Kodi - ViZZY - 2016-09-06

(2016-09-05, 20:04)marcelveldt Wrote:
(2016-09-04, 23:43)ViZZY Wrote: Thank you for the blazing fast response and dedication! Here's a log of the error happening after reproducing, hopefully I did this right!

Log

New version 1.0.22 will be available on the repo within a few minutes. Please test again with that version, it should be fixed now

Updated and working great again!!! Thank you for all you do, marcelveldt!!!! Big Grin


RE: Spotify for Kodi - marcelveldt - 2016-09-06

Good news for Kodi Krypton users, the issue has been fixed by @FernetMenta and the next nightly build should contain the fix


RE: Spotify for Kodi - sanity - 2016-09-06

(2016-09-06, 09:47)marcelveldt Wrote: Good news for Kodi Krypton users, the issue has been fixed by @FernetMenta and the next nightly build should contain the fix

Nice! I will try the build when it's out tomorrow Smile


RE: Spotify for Kodi - bite_your_idols - 2016-09-06

cool!! now it is working in krypton!!!
Thanks!


RE: Spotify for Kodi - macardi - 2016-09-06

Kodi hangs for me with latest nightly build when trying to play a song.

log

/Marcus