Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-12-18

(2017-12-18, 16:59)wheemer Wrote: I have an ACPI error on an older machine I'm running this on, is there some way to hide those errors at bootup?

What kind of ACPI error? What problem do these errors cause? How old is your "older machine"? Do you get these ACPI errors with LibreELEC 8.2.1?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - wheemer - 2017-12-18

Yes they occur in the official build too, no they cause no problems at all.

It's an old HP with no bios update that I can find (which I found would likely fix the issue)

I found something about changing the loglevel to 3 to get rid of these messages, but I just can't figure out if that's possible.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2017-12-18

(2017-12-18, 17:19)wheemer Wrote: Yes they occur in the official build too, no they cause no problems at all.

It's an old HP with no bios update that I can find (which I found would likely fix the issue)

I found something about changing the loglevel to 3 to get rid of these messages, but I just can't figure out if that's possible.

Where are those messages appearing? Once at boot (hidden behind the splash) or constantly?

mount /flash rw edit the relevant config add quiet loglevel=0 behind it - try


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - wheemer - 2017-12-18

They are appearing just at boot but right before the splash screen... I will try your fix and report back, thanks!


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - NNate - 2017-12-19

(2017-12-18, 07:09)Milhouse Wrote:
(2017-12-17, 23:12)NNate Wrote: Unfortunately, I don't think #1216 fixed the colorspace issue Sad

Could you be more specific - does it make the problem worse, or no change at all? Have you tried changing between limited and full in Settings > System > Display? What is your system - this is specific to Intel GPUs. Can you post a link to the output from "/usr/bin/xrandr -display :0 --verbose | pastebinit"   

It looks like no change at all. Yes, I've tried changing between limited and full under the Display settings. "Limited" is closer to being correct in video. "Full" crushes the brights and darks.

In the interface and static images "Full" is brighter and closer to the proper colorspace.

I'm running on an Intel Asus Chromebox

https://pastebin.com/t6EjYw4S


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - wheemer - 2017-12-19

(2017-12-18, 19:05)fritsch Wrote:
(2017-12-18, 17:19)wheemer Wrote: Yes they occur in the official build too, no they cause no problems at all.

It's an old HP with no bios update that I can find (which I found would likely fix the issue)

I found something about changing the loglevel to 3 to get rid of these messages, but I just can't figure out if that's possible.

Where are those messages appearing? Once at boot (hidden behind the splash) or constantly?

mount /flash rw edit the relevant config add quiet loglevel=0 behind it - try 
 Thanks that worked perfectly, now my libreelec no longer looks broken!


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - wheemer - 2017-12-19

I am using an Nvidia 460 GTX and an hevc video I am playing is software decoding. Is this expected? about a dozen other videos all playback with hardware decoding.

The options for which decoding to enable or disable is slightly confusing. I have the three top ones on and the last off... is that right?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-12-19

(2017-12-19, 05:44)wheemer Wrote: I am using an Nvidia 460 GTX and an hevc video I am playing is software decoding. Is this expected? about a dozen other videos all playback with hardware decoding.

Enable debugging, reboot, play the video, post the link to your debug log.

(2017-12-19, 05:44)wheemer Wrote: The options for which decoding to enable or disable is slightly confusing. I have the three top ones on and the last off... is that right?

Assuming you mean the "Processing" options (ie. hardware acceleration), that sounds about right (Nvidia/AMD GPUs use VDPAU, Intel GPUs use VAAPI).


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-12-19

New LibreELEC.tv Leia build #1218: Generic
(Supercedes previous build)

SHA256 Checksum: d4498e80da57eb68e498ef2d655f1a7debab85ca9690d5719f9ba9e63ed86767 (Generic)

Code:
# uname -a
Linux NUC 4.14.7 #1 SMP Tue Dec 19 04:00:07 GMT 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20171219035841-#1218-g31a943b [Build #1218]

# Kodi version
(18.0-ALPHA1 Git:71a7780). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (31a943b, changelog) and tip of XBMC master (71a7780, changelog) with the following modifications: Build Highlights:
  1. New 4.14.7 kernel
  2. Update to systemd-236
  3. wayland support
Build Details:
  1. LibreELEC.tv:
    • Updates for S905 (PR:2319, 22 commits, 51 files changed)
    • wayland support (PR:2232, 17 commits, 22 files changed)
  2. XBMC:
    • AESinkPULSE: Check if module-allow-passthrough is loaded and warn if not available (PR:13210, 2 commits, 1 file changed)
    • fixed: the JobManager.Add/CancelJob tests are racy (PR:13212, 1 commit, 1 file changed)
    • [win32] Fix missing window icon on switching from fullscreen mode (PR:13209, 1 commit, 1 file changed)
    • Wayland: Fix VAAPIRegisterRender implementation when vaapi disabled (PR:13214, 1 commit, 1 file changed)
    • remove old ThumbnailCache.cpp/h (PR:13215, 1 commit, 3 files changed)
  3. inputstream.adaptive:
    • Fix segmentNumber based live streams (seg_start -> seg_end) (564981a)
  4. pvr.stalker:
    • [win10][depends] libxml2: fix deprecated uwp api (PR:104, 1 commit, 5 files changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2317 (perma): linux: update to linux-4.14.8
    • Updated: [env] PR:2323 (perma): buildsystem: source functions earlier, validate project/arch earlier, refactor show_config
    • Added: [env] patch: samba: Fix linking issues
    • Added: [env] PR:2331 (perma): systemd: update to 236



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - turbobuickguy - 2017-12-19

(2017-12-18, 13:25)Milhouse Wrote: This looks like it is crashing in ffmpeg.

Does this only happen with certain files, or everything?

Can you upload a sample file that triggers the crash? 
It has crashed with anything.  I am thinking that there may be an issue with the hardware.  I have seen freezing in the bios now, and installed windows 10 as a test.  I had BSOD while installing WIN 10, and also with the OS after completely installed.

Knowing that others use this box without issue, makes me think I have something else going on.  Rather than waste anyone's time at this point, I am going to test fully with WIN 10.

If I can get windows 10 stable, and still have issues with LE, I will post back.  Thanks for the help.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2017-12-19

(2017-12-19, 05:44)wheemer Wrote: I am using an Nvidia 460 GTX and an hevc video I am playing is software decoding. Is this expected? about a dozen other videos all playback with hardware decoding.

The options for which decoding to enable or disable is slightly confusing. I have the three top ones on and the last off... is that right?
 If it's hevc-10 bit: Yes, that's expected.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-12-19

(2017-12-19, 14:18)turbobuickguy Wrote: If I can get windows 10 stable, and still have issues with LE, I will post back.  Thanks for the help.

Run https://www.memtest86.com in case it's a faulty stick of RAM.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - wheemer - 2017-12-20

(2017-12-19, 06:14)Milhouse Wrote:
(2017-12-19, 05:44)wheemer Wrote: I am using an Nvidia 460 GTX and an hevc video I am playing is software decoding. Is this expected? about a dozen other videos all playback with hardware decoding.

Enable debugging, reboot, play the video, post the link to your debug log.
(2017-12-19, 05:44)wheemer Wrote: The options for which decoding to enable or disable is slightly confusing. I have the three top ones on and the last off... is that right?

Assuming you mean the "Processing" options (ie. hardware acceleration), that sounds about right (Nvidia/AMD GPUs use VDPAU, Intel GPUs use VAAPI). 
 I rebooted and suddenly it was hardware decoding, thanks!


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-12-20

New LibreELEC.tv Leia build #1219: Generic
(Supercedes previous build)

SHA256 Checksum: cffeace7df29279930874bb74efb3cb6370af33ae97aaa05729363db46f8c8cb (Generic)

Code:
# uname -a
Linux NUC 4.14.7 #1 SMP Wed Dec 20 08:54:29 GMT 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20171220085302-#1219-gd63f060 [Build #1219]

# Kodi version
(18.0-ALPHA1 Git:7b1ff23). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (d63f060, changelog) and tip of XBMC master (7b1ff23, changelog) with the following modifications: Build Highlights:
  1. [PVR] Fix CPVREpgContainer::CreateChannelEpg not to change channel's
Build Details:
  1. LibreELEC.tv:
    • projects/S905: enable hw decoding in kernel config (PR:2337, 3 commits, 3 files changed)
    • samba: fix link issues when rebuilding (PR:2338, 1 commit, 1 file changed)
    • chromium: security fix to 63.0.3239.108 (PR:2333, 1 commit, 2 files changed)
    • adafruit-libraries: 2 updates (PR:2339, 1 commit, 4 files changed)
  2. XBMC:
    • [Win10] fix windows store certification errors. (PR:13211, 3 commits, 7 files changed)
    • Dvd autoplay during active player (PR:13142, 1 commit, 1 file changed)
    • [PVR] Fix CPVREpgContainer::CreateChannelEpg not to change channel's (PR:13216, 1 commit, 1 file changed)
    • [cleanup] windows doesn't use GL anymore (PR:13217, 1 commit, 1 file changed)
    • [Windows] Fix BuildSetup.bat after #13211 (PR:13218, 2 commits, 3 files changed)
    • kill g_powerManager global (PR:13190, 3 commits, 13 files changed)
    • [cmake] remove force disabling vaapi for gbm (PR:13220, 1 commit, 1 file changed)
    • Remove Travis badge, update Kodi banner image URL (PR:13204, 0 commits, 0 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2298 (perma): Kodi updates for Jan 2018
    • Updated: [env] PR:2323 (perma): buildsystem: source functions earlier, validate project/arch earlier, refactor show_config



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-12-20

Weekly Linux 4.15-rc4 build #1219x: Generic

Packages disabled/not included:
Code:
RTL8192CU
RTL8192DU
RTL8192EU
RTL8812AU
bcm_sta
DVB Driver Addons
Packages added/updated:
Code:
RTL8188EU
Known issues:
Code:
wireless-regdb is not working - needs upstream fix