Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



RE: [WINDOWS] External Player Support Thread - brazen1 - 2015-06-17

(2015-06-17, 19:36)dragons4life Wrote: How can I make it so that it automatically chooses the player in playercorefactory.xml, instead of having to choose it every time.

This may help http://forum.kodi.tv/showthread.php?tid=229692


RE: [WINDOWS] External Player Support Thread - HighStream - 2015-06-23

(2015-06-17, 19:36)dragons4life Wrote: How can I make it so that it automatically chooses the player in playercorefactory.xml, instead of having to choose it every time.
Are you trying to play an ISO in the external player? If so, try this:
in Kodi system settings go to: Video - Discs - BluRay playback mode and select Play main movie.
If you don't change this, kodi will play the movie in the default player and the external player will not be triggered automatically.

Any other file type should start the external player automatically if the playercorefactory is configured correctly.


RE: [WINDOWS] External Player Support Thread - boogie - 2015-06-28

hello all, this is my current playercorefactory.xml
Code:
<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\Media Player Classic - Home Cinema\mpc-hc.exe</filename>
<args> /fullscreen /close</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv|mp4|avi|ts|m2ts" player="MPC-HC"/>
</rules>
</playercorefactory>

The issue i'm having is that when i start up kodi, mpc-hc starts up in full screen mode without me playing a video. I can't remember the exact time this little occurrence started happening but I think it happened when i updated to the latest version of kodi. When i completely remove the code from the playercorefactory.xml, kodi starts up fine but once i re-insert he code it acts up again.


RE: [WINDOWS] External Player Support Thread - pagali - 2015-06-28

I think the problem is that the filename is not being sent to MPC-HC. You need to add "{0}" before the args.

Code:
<args>"{0}" /fullscreen /close</args>



RE: [WINDOWS] External Player Support Thread - richnanaimo - 2015-07-22

(2015-05-19, 21:53)Animal_Freeride Wrote:
(2015-05-18, 20:50)rmilyard Wrote: This is the code I am trying right now:

powercorefactory:
Code:
<playercorefactory>
    <players>
           <player name="ISO_BDMV_Player" type="ExternalPlayer" audio="false" video="true">
            <filename>C:\Users\Ray\AppData\Roaming\Kodi\userdata\PlayISO.bat</filename>
            <args>"{1}"</args>
            <hidexbmc>false</hidexbmc>
                        <hideconsole>True</hideconsole>
                        <warpcursor>none</warpcursor>                
        </player>
        </players>
        <rules action="prepend">
        <!-- Bluray ISO -->
                <!-- Bluray ISO/BDMV -->
        <rule filetypes="iso|bdmv|mpls" player="ISO_BDMV_Player"/>
                 
</rules>
</playercorefactory>

PlayISO.bat:
Code:
Set file=%1
Set dummy=%file:iso=%
IF NOT %dummy% == %file% (GOTO playiso) ELSE (goto next)

:next
Set file=%1
Set dummy=%file:mpls=%
IF NOT %dummy% == %file% (GOTO plaympls) ELSE (goto playbdmv)

:playiso
"D:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 %1
"C:\Program Files (x86)\CyberLink\PowerDVD15\Movie\PowerDVD Cinema\PowerDVDCinema.exe" H:
"D:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u
GOTO end

:plaympls
set pth=%1
set pth=%pth:~1,-25%

"C:\Program Files (x86)\CyberLink\PowerDVD15\Movie\PowerDVD Cinema\PowerDVDCinema.exe" "%pth%" exit
GOTO end

:playbdmv
set pth=%1
set pth=%pth:BDMV\MovieObject.bdmv=%
set pth=%pth:BDMV\index.bdmv=%

"C:\Program Files (x86)\CyberLink\PowerDVD15\Movie\PowerDVD Cinema\PowerDVDCinema.exe" %pth% exit
GOTO end

:end
exit

When it runs the iso mounts and PowerDVDCinema starts. However it's not playing the H: drive. I am getting this:
Image
As you can see it's looking at H: drive. Then I need to click the mouse and I will get this screen:
Image
From here if I select H: this screen comes up:
Image
If I click restart all works.

Also when I stop the movie it doesn't clock PowerDVD. I would like it to close to go back to Kodi.

If anyone knows what I might be doing wrong that would be great!

I've already told you, DONT USE THE CINEMA EXE FILE!!! If you bothered listening to what I said it should work. I had the exactly the same issues you are experiencing. As you are trying to use PDVD15 (I'm using PDVD14), the code needs to be changed from 14 to 15 & E: to H: (your virtual drive).

Try this, it should be fine.


Playercore Code


<playercorefactory>
<players>
<player name="PowerDVD" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Users\Ray\AppData\Roaming\Kodi\userdata\PowerDVD.bat</filename>
<args>"{1}"</args>
<hidekodi>false</hidekodi>
</player>
</players>
<rules action="prepend">
<rule filetypes="iso|bdmv|mpls" player="PowerDVD"/>
</rules>
</playercorefactory>


BAT File


Set file=%1
Set dummy=%file:iso=%
IF NOT %dummy% == %file% (GOTO playiso) ELSE (goto next)

:next
Set file=%1
Set dummy=%file:mpls=%
IF NOT %dummy% == %file% (GOTO plaympls) ELSE (goto playbdmv)

:playiso
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 %1
"C:\Program Files (x86)\Cyberlink\PowerDVD15\PowerDVD.exe" H:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u
GOTO end

:plaympls
set pth=%1
set pth=%pth:~1,-25%

"C:\Program Files (x86)\Cyberlink\PowerDVD15\PowerDVD.exe" "%pth%" exit
GOTO end

:playbdmv
set pth=%1
set pth=%pth:BDMV\MovieObject.bdmv=%
set pth=%pth:BDMV\index.bdmv=%

"C:\Program Files (x86)\Cyberlink\PowerDVD15\PowerDVD.exe" %pth% exit
GOTO end

:end
exit

Not Sure what I am doing wrong.
I can get Kodi to Play ISO no Prob using the above playercorefactory & bat.
When it comes to BDMV -- PDVD just sits there doing nothing.

Anyone else have this challenge?


BDMV - MPC-HC / ISO - DVDPlayer - richnanaimo - 2015-07-22

Hey folks,

looking to figure out the syntax for a rule that says
if bdmv play using MPC-HC
if ISO, play using DVDplayer


example of a failed attempt

<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\MPC-HC\mpc-hc.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule filename="*.bdmv" player="MPC-HC"/>
<rule filename="*.iso" player="DVDplayer"/>
</rules>

</playercorefactory>


RE: [WINDOWS] External Player Support Thread - JoeBlow42069 - 2015-07-30

I'd like to play video add-ons and local files to Videostream for Chromecast on Win7, and was wondering if anybody knows how to do this? Videostream doesn't use an exe, but it does have a web interface. The address in my browser shows chrome-extension://cnciopoikihiagdjbjpnocolokfelagl/app.html. Videostream has playlist support too, so I'm guessing if it works similar to other apps like Local Cast or BubbleUPnp this might be possible to do. Any help is greatly appreciated.


RE: [WINDOWS] External Player Support Thread - boogie - 2015-08-08

(2015-06-28, 18:07)boogie Wrote: hello all, this is my current playercorefactory.xml
Code:
<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\Media Player Classic - Home Cinema\mpc-hc.exe</filename>
<args> /fullscreen /close</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv|mp4|avi|ts|m2ts" player="MPC-HC"/>
</rules>
</playercorefactory>

The issue i'm having is that when i start up kodi, mpc-hc starts up in full screen mode without me playing a video. I can't remember the exact time this little occurrence started happening but I think it happened when i updated to the latest version of kodi. When i completely remove the code from the playercorefactory.xml, kodi starts up fine but once i re-insert he code it acts up again.

I'm still having this issue. I even deleted the xml file and created a new based off of this guide and mpc-hc is still starting in fullscreen when I launch kodi without a file being played.


RE: [WINDOWS] External Player Support Thread - ferl13 - 2015-10-06

Hello
Is it possible to define a rule that asks for the player to be used?
All my 3D mkv's are named with *.3D.* and i've got a rule defined to launch an external Player.

<rules action="prepend">
<rule filename=".*3D.*" player="Stereoscopic Player"/>
</rules>

Typically i play the movies with the internal player. But if the movie is 3D capable it would be nice if i could get the "play with" choice whenever the Filename matches the rule.
Thanks for any hint


ISO with windows - fullsun - 2015-10-07

I've maybe post that in the bad topic? I've not see this topic. Rofl


RE: [WINDOWS] External Player Support Thread - THX-UltraII - 2015-10-12

Guys, I managed to get it working that MPC-BE plays my .m2ts (2D) movies as external player. What do I need to add to my playercorefactory to make it work so it keeps running my 2D movies (.m2ts files) with MPC-HC and my .ISO (3D) movies with PowerDVD? My playercorefactory now looks like this:

Code:
<playercorefactory>
<players>
   <player name="MPC-BE" type="ExternalPlayer" audio="false" video="true">
     <filename>C:\Program Files (x86)\MPC-BE\mpc-be.exe</filename>
     <args>"{1}" /fullscreen /close</args>
     <hidexbmc>false</hidexbmc>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
   </player>
</players>
<rules action="prepend">
   <rule filetypes="mkv|m2ts|mov|bdmv|mpls" player="MPC-BE"/>
</rules>
</playercorefactory>



RE: [WINDOWS] External Player Support Thread - haydent - 2015-10-13

Hi all, just got a quad core 4k android media player, identifies as "Sunchip HE315035" in google play. It came with Kodi 14.2 but i cant get it to play any video off the windows network share (works off usb though), it just say "External Player Active", "Click ok when playback has ended" but no player opens.

I looked into external player settings file and this is the contents of userdata playercorefactory.xml
Code:
<playercorefactory>
<players>
    <player name="AWPlayer" type="ExternalPlayer" audio="false" video="true">
    <filename>com.softwinner.TvdVideo</filename>
    <hidexbmc>true</hidexbmc>
    </player>
</players>
<rules action="prepend">
    <rule video="true" player="awplayer"/>
</rules>
</playercorefactory>
In android settings>applications there is TvdVideo listed but, says 0 bytes.

I tried installing VLC and making the settings to this, but no change...
Code:
<playercorefactory>
<players>
    <player name="VLCPlayer" type="ExternalPlayer" audio="false" video="true">
    <filename>com.vlcforandroid.vlcdirectprofree</filename>
    <hidexbmc>true</hidexbmc>
    </player>
</players>
<rules action="prepend">
    <rule video="true" player="vlcplayer"/>
</rules>
</playercorefactory>

Any suggestions greatly appreciated.Angel


RE: [WINDOWS] External Player Support Thread - crawlers1977 - 2015-10-24

<playercorefactory>
<players>
<player name="VLC" type="ExternalPlayer" video="true">
<filename>C:\Program Files\VideoLAN\VLC\vlc.exe</filename>
<args>"{1}"</args>
<forceontop>false</forceontop>
<hidekodi>false</hidekodi>
<hideconsole>false</hideconsole>
<hidecursor>false</hidecursor>
</player>
</players>
<rules action="prepend">
<!- vlc rtmp ->
<rule filetypes="rtmp" player="VLC"/>
</rules>
</playercorefactory>

this is what im using for the external vlc i see straight away your code is uing xbmc and not kodi as you said you have running..
<playercorefactory>
<players>
<player name="VLCPlayer" type="ExternalPlayer" audio="false" video="true">
<filename>com.vlcforandroid.vlcdirectprofree</filename> <---this section you must show the path of the player from inside your system/box
<hidexbmc>true</hidexbmc> <----this should be setup as <hidekodi>true</hidekodi>
</player>
</players>
<rules action="prepend">
<rule video="true" player="vlcplayer"/>
</rules>
</playercorefactory>

and then you see when you select the file your wanting to play in vlc after right clicking mine i select "play using" and vlc is in the options
<player name="VLC" type="ExternalPlayer" audio="false" video="true"> your player name line when setup like that you dont need to add a rule <rule video="true" player="vlcplayer"/> its already identified


RE: [WINDOWS] External Player Support Thread - haydent - 2015-10-26

cheers


RE: [WINDOWS] External Player Support Thread - jhunt21 - 2015-11-09

I'm trying to learn how to do this. I want to make powerDVD my player inside of kodi. I think I figured out where to put the code from above but have no idea where to put the bat file. I have a player now called powerdvd in kodi but obviously nothing happens when I click on it because I don't have the bat file. Where do I create this and put it? This would make my system perfect. Thanks


This forum uses Lukasz Tkacz MyBB addons.