•   
  • 1
  • 111
  • 112
  • 113(current)
  • 114
  • 115
  • 208
  •   
  Thread Closed
Artwork Downloader
(2013-09-17, 20:46)st graveyard Wrote: Currently, I even don't understand the use of saving non standard artwork locally if artwork downloader is not able to add it to the library without first checking onlineHuh?

like mentioned more than one time. it should not any more

https://github.com/XBMC-Addons/script.ar...lt.py#L316

that it possibly doesn't work now is another story.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
(2013-09-17, 20:13)MilhouseVH Wrote:
(2013-09-17, 19:27)hernandito Wrote: Does anyone know how I can basically do this as a Cron job? What would the script look like? How would the script be called?

http://forum.xbmc.org/showthread.php?tid=158373
Code:
./texturecache.py exec script.artwork.downloader silent=true mediatype=movie

Thank you Millhouse... It looks like a lot to digest... basically I have you use your Texture Cache Maintenance utility to launch the AWD script? Is there a way to launch AWD directly with parameters similar to your code above....

Thanks again,

H.
Image
@everyone except Buzniak:

Try updated version for local artwork scraping fix
https://github.com/XBMC-Addons/script.ar...downloader

scraping
<moviename>-poster.jpg (and so on) is still on to-do list
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
(2013-09-17, 21:18)Martijn Wrote: @everyone except Buzniak:

Try updated version for local artwork scraping fix
https://github.com/XBMC-Addons/script.ar...downloader

scraping
<moviename>-poster.jpg (and so on) is still on to-do list

Just tried this out and all i can say is it works!!!! Thank you Martijn
(2013-09-17, 21:46)Elky Wrote:
(2013-09-17, 21:18)Martijn Wrote: @everyone except Buzniak:

Try updated version for local artwork scraping fix
https://github.com/XBMC-Addons/script.ar...downloader

scraping
<moviename>-poster.jpg (and so on) is still on to-do list

Just tried this out and all i can say is it works!!!! Thank you Martijn

Can anyone share how to update from OpenElec? I'm guessing I can use git or something but the syntax would be helpful. Then I can test it out.
(2013-09-17, 22:34)voip-ninja Wrote:
(2013-09-17, 21:46)Elky Wrote:
(2013-09-17, 21:18)Martijn Wrote: @everyone except Buzniak:

Try updated version for local artwork scraping fix
https://github.com/XBMC-Addons/script.ar...downloader

scraping
<moviename>-poster.jpg (and so on) is still on to-do list

Just tried this out and all i can say is it works!!!! Thank you Martijn

Can anyone share how to update from OpenElec? I'm guessing I can use git or something but the syntax would be helpful. Then I can test it out.

download and install this zip
https://dl.dropboxusercontent.com/u/7435...loader.zip
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
(2013-09-17, 21:18)hernandito Wrote: Is there a way to launch AWD directly with parameters similar to your code above....

Directly? As a cron job? Sure, write a script that executes the JSON request which runs the add-on. Oh wait...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2013-09-17, 20:41)voip-ninja Wrote: Martin,

Thanks for the response. I've noticed the reference to refreshing a single show but when I select the contextual menu for a single show or season in Aeon Nox I don't have a selection for "refresh". Is there some other way to do it?

Sounds like you're pressing C and not I for Information, which is where the Refresh button is.
HTPC: Dell Optiplex 7040 Small Form Factor i7-6700 quad-core, 3.4GHz, 16GB
NAS: Synology DS1813+ and DX513, RAID 6 (29TB usable space)
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
(2013-09-17, 22:38)Martijn Wrote:
(2013-09-17, 22:34)voip-ninja Wrote:
(2013-09-17, 21:46)Elky Wrote: Just tried this out and all i can say is it works!!!! Thank you Martijn

Can anyone share how to update from OpenElec? I'm guessing I can use git or something but the syntax would be helpful. Then I can test it out.

download and install this zip
https://dl.dropboxusercontent.com/u/7435...loader.zip

Thanks!

Unfortunately still not working. It is acting like it is not obeying "use local files" option (which I have turned on) as I see this kind of stuff in the logfile when debugging is turned on;

Code:
20:52:01 T:2766203712 WARNING: Artwork Downloader: Could not copy file (Destination may be read only), skipping: u'smb://BOGART/TV/Homeland/extrafanart/953485.jpg'
20:52:01 T:2766203712 WARNING: FileSmb::OpenForWrite() called with overwriting enabled! - smb://BOGART/TV/Homeland/extrafanart/953491.jpg

It's like it's ignoring the local files option?

Interestingly I see it trying to do these writes to my file share (which is read only) even though I have the local files option selected. I can pastebin the whole log if that is helpful. I see it trying to collect the fan art but never seems to do anything about season posters.

For TV shows I have "season posters" selected and as an example have this in the SMB share;

/Homeland/season02-poster.jpg

but neither Frodo or Artwork Downloader ever seem to pick up on this artwork being present. When I initially scraped and ran AE after initial system setup it got the TV seasons that were there at the time but it can't add any new ones.

(2013-09-17, 22:57)CaptainKen Wrote:
(2013-09-17, 20:41)voip-ninja Wrote: Martin,

Thanks for the response. I've noticed the reference to refreshing a single show but when I select the contextual menu for a single show or season in Aeon Nox I don't have a selection for "refresh". Is there some other way to do it?

Sounds like you're pressing C and not I for Information, which is where the Refresh button is.

You sir are a scholar and a gentleman. I never even knew that option existed. So I did refresh and it asked me to re-identify the series but the good news is that it picked up the artwork!

So I guess I have a couple of small questions. When this is done is it over-writing the info I've already provided via my .nfo files for the show? And..... is this causing Frodo to simply pick up artwork I've already put in for the show or would running artwork downloader still be needed?

Thanks
(2013-09-17, 21:18)Martijn Wrote: @everyone except Buzniak:

Try updated version for local artwork scraping fix
https://github.com/XBMC-Addons/script.ar...downloader

scraping
<moviename>-poster.jpg (and so on) is still on to-do list

I'm gonna test this tomorrow. I think you are my hero ;-)

Thank you so much for this!
Thanks for update - has applied all of my local clear logos Smile Great work.

Having said that, still not sure why it didn't pick them up online - entourage and sleepy hollow - clearlogo's are on fanart.tv. It downloaded the rest of the artwork.[/quote]
Martin, thanks for all the great work! Haven't tried new version but have experienced no issues whit any version. Keep up great work and thanks for working on the app in your spare time!

Local artwork works great for me, have no problems with some of the artwork I haven't felt like uploading to fanart or that got denied ha.
HTPC Basement: i3 3225, Asrock z77 pro4m, 8gb Crucial DDR3 1600, Samsung 840 120gb SSD, Silverstone GD05B Case

HTPC Livingroom: WIP

Server: UnRaid: Intel G550, Asrock B75 pro3m, 4gb ram, Parity Drive 3tb WD Red, Data 2 x 2tb WD Red, Cache 1tb WD Blue, Fractal Design XL R2 Case
(2013-09-17, 22:43)MilhouseVH Wrote: Directly? As a cron job? Sure, write a script that executes the JSON request which runs the add-on. Oh wait...

Millhouse thanks again.... I tried by using your code, and I am happy to report that the command line works perfectly... I am waiting to see if the CRON works.

Thank you very much.

Hernando
Image
Hey Martijn,

Updated to the latest version using smartgit.

1) is there a way to distinguish this version to the official one - version nr perhaps?
2) have local artwork switched on, have artwork in movie section set to enabled (and only logo, clearart and discart) active. However when updating the artwork of the freshly imported movies, AWD searches for logo, clearart and 16:9 thumb (no disc artHuh?).
3) it still runs very very slowwwwwwww ... for me that is ... I think it takes about 2 hours for 650 movies to scan ... with local artwork ...

What can I do to help? I don't see much in the log ...

Grave

EDIT : did another pull and sync, started scanning from the program itself, and now it is scanning logo, clearart and discart like requested. Still slow, but it is going. So ignore my comments above. I'm scanning again as I write. I'll keep you posted and let you know how it goes! Thanks.
Hello Martijn,

The scan of my first HD is finished. It took artwork downloader 1 hour and 37 minutes for 356 movies to scan the logo, clearart and discart using local artwork. 19 new items were downloaded (artwork which I did not have since my last scan and which is now nicely placed locally).
The amount of time the application needs is incredible, even for a local scan. If you compare this to 2012 it is unbelievable, unless I am doing something wrong.

I will import my second HD tomorrow (another 300 movies) and let you know if I encounter new problems.

So far, there doesn't seem to be any difference between the new version and the old one (unless my update did not work correctly).

cheers
  •   
  • 1
  • 111
  • 112
  • 113(current)
  • 114
  • 115
  • 208
  •   
  Thread Closed
 
Thread Rating:
  • 18 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
Artwork Downloader4.4418
This forum uses Lukasz Tkacz MyBB addons.