•   
  • 1
  • 14
  • 15
  • 16(current)
  • 17
  • 18
  • 52
  •   
  Thread Closed
libstagefright - Experimental hardware video decoding builds
02 build is silky smooth with 1080p on nexus 7!
(2013-02-03, 10:04)eden_orient Wrote:
(2013-02-03, 06:55)davilla Wrote: AmLogic SoC devices will not benefit from libstagefright work.
weird as i for the first time on this device could play a 4GB xvid (over Wifi) encoded 720p file at 24 frames /s solid using this libstagefright !!!!!!!!!
XVID acceleration is not enabled in stagefright Wink
From my N7 tests, it is picky regarding what it actually accepts but only tells late in the process, so it is no more possible to fall back on ffmpeg.

I never tried a 720p xvid, but plain SD xvid do not seem to need accel, anyway, at least on modern devices...
Tried 02 Feb Build.
Same problem exist, so I think no need submit log this time.

27 Jan Build problem which I post last time:

Every time I opened mkv and mp4 files it play audio for few seconds then XBMC stop responding. I need to press HOME key back to android HOME to end XBMC app.

I give it another try, here is what I got this time:
Teclast A10 / Android 4.1.1 / RK2918 chipset

latest version
mkv and mp4 unplayable (screen all black, play audio for few seconds and then freeze)
rmvb playable but shuttering

all files is playing fine with MX player with hw decoding
http://xbmclogs.com/show.php?id=31497
(2013-02-03, 13:39)DiscoDave Wrote: Odroid-u2.
Yeah, I know it doesn't solve odroid issue...
(2013-02-03, 13:27)Koying Wrote:
(2013-02-03, 10:04)eden_orient Wrote:
(2013-02-03, 06:55)davilla Wrote: AmLogic SoC devices will not benefit from libstagefright work.
weird as i for the first time on this device could play a 4GB xvid (over Wifi) encoded 720p file at 24 frames /s solid using this libstagefright !!!!!!!!!
XVID acceleration is not enabled in stagefright Wink
From my N7 tests, it is picky regarding what it actually accepts but only tells late in the process, so it is no more possible to fall back on ffmpeg.

I never tried a 720p xvid, but plain SD xvid do not seem to need accel, anyway, at least on modern devices...

If users take the time to actually read the posts in this thread ( a novel concept ), I've mentioned this at least twice now. Soooooooo...

Once more for the boys in the back who are not paying attention, AmLogic SoC devices will not benefit from libstagefright work. Do not say it works, it does not, you are using software decode which you would see by looking at xbmc.log ( another novel concept)

I know this because I'm the person that enabled hw decode for AmLogic devices in the 1st place. I know how it works, for both Android and Linux, from userland, into the kernel and off to the hw decoders. There is no stagefright based hw decode in AmLogic devices. Repeat after me and write it on the blackboard 1e6 times, there is no stagefright based hw decode in AmLogic devices. Should I say it again ? Smile



(2013-02-03, 15:58)davilla Wrote: AmLogic SoC devices will not benefit from libstagefright work.
And neither is Allwinner, AFAIK.
See this thread for this: http://forum.xbmc.org/showthread.php?tid=154492
(and bug the guy so that he releases a PR)
Sigh. I can't seem to be able to create a debug log in xbmc.
Some mkv's play nicely.
Some mkv's just stop playing and make xbmc go back to the main page.
Some mkv's stop xbmc altogether.
Some mkv's crash the device and make it restart.

This is all on a minix neo x5
@jacuzzi

if you could upload the crashing bitstream or a sample that also crashes that would be nice, so far no 720p stream crashed here Smile

did you tried the test bitstreams does one of those 720p ones crash http://www.auby.no/files/video_tests/ ?

ahh just realized there was a update, testing... Smile

Zelda-Medley Youtube (1080p) still crashes it seems to hold longer when Sync to display is enabled without it it crashes always @ this Cpullup part, though the behavior is so strangely random it's always a little different depending on the Sync to display option Sad

With Video sync to display (Audio Clock) i could make it a little further into the stream before it crashed, not sure though if this was random again with Video drop/dupe it froze not crashed also a little further but not as far in the stream as with Audio Clock Smile

Though even with all those freezing and crashing i didn't saw the White Fog Render artifacts yet before it froze or crashed Smile

But it wasn't as stable as the run with the Artifacts i luckily was able to get here

http://forum.xbmc.org/showthread.php?tid...pid1312883

Though it seems i dont get that strange line on top anymore Smile need to further test also with the monsters 1080p clip

videoplaback.flv is still squished decoded (wrong stride issue)

http://forum.xbmc.org/showthread.php?tid...pid1313925
(2013-02-04, 05:17)jacuzzi Wrote: harry potter just ends xbmc
suzmiya ends xbmc
planet ends xbmc
monsters ends xbmc
birds ends xbmc
hddvd doesn't stop xbmc, but is choppy and audio is not all over
matrix runs alright

tested on a minix neo x5 rockchip 3066

looking at the cpu load it seems that once the cpu load goes to 100%, the video stops (or after a second)



with the newest build now ? that looks really bad from experience i didnt tried all the test streams yet i gone straight for the Zelda Medley stability test Wink

but at least all of these 720p streams where stable on the 27.01 build for me on this stock 4.1.1 firmware and only the 1080p where giving me trouble.
im gonna check now if that is still the case

I did the other 720p tests now

720p playback @ least is still unchanged so pretty stable here with the newest build, though it seems their was a performance boost or better thread handling as with the Overlay Gui Playback the background video stays now very smooth Smile

The monsters (1080p) stream also doesn't show the strange line on top anymore but freezes now again @ the same Happy Birthday part

so 1080p playback state is pretty unchanged for me but overall 720p decoding state subjectively improved.

Runs absolutely smooth in the Background Smile

Image

Image

Runs smooth without GUI but not smooth with GUI Overlays though is Mpeg-2 1080p ffmpeg decoded but RK 3066 supports Mpeg-2 accelerated as well but XBMC seems to doesn't use it like with the VC-1 decoder

Image
The rockchip device should reach me in the coming days Smile

For the next version, I'll implement "tweaks" via advanced settings (e.g. SW renderer, XVID decoder, ...), so that we could test different settings with the same build.
The Feb-2 version is working great for me - even 720p videos taken by my Panasonic ZS-3 camera, which MX Player could only play in software mode slowly on my Nexus 10, is playing very very smoothly. Although it still crashes occasionally, it's no big deal. Good work!
(2013-02-04, 13:36)Koying Wrote: The rockchip device should reach me in the coming days Smile

For the next version, I'll implement "tweaks" via advanced settings (e.g. SW renderer, XVID decoder, ...), so that we could test different settings with the same build.

Please don't do this, we should be able to blacklist/whitelist these things. If you have not gotten the dev memo, creating a bunch of "tweaks" via advanced settings is something we as a rule, resist. It might make sense for development but these things have a habit of sticking past the development point and sneaking into production.

Generally you should be working on a) stabilize for best performance under common devices, then b) clean up for mainline injection. Hardware codec development is never 'done'. There's always something to fix or add, it's a never ending process. I know, I've done a few Smile
(2013-02-04, 16:28)davilla Wrote:
(2013-02-04, 13:36)Koying Wrote: For the next version, I'll implement "tweaks" via advanced settings (e.g. SW renderer, XVID decoder, ...), so that we could test different settings with the same build.

Please don't do this, we should be able to blacklist/whitelist these things.
Well, it might translate in "device profile" or whatever in final version, but I'm afraid it is illusory to assume we'll find a "one size fits all" for a fragmented world as android.
I mean, with latest version, Exynos 5250 is working (N10) and Exynos 4412 is not (U2).
Even different devices with same Rockchip seems to behave differently Wink

Also, keep in mind that some devices just will never work under libstagefright as they would require too much in quirks. Take for example the iphone 3G, not a platform that we ever supported but it is capable of hardware device via videotoolbox. It was just too different from the others to fold under one umbrella.

Exynos 4412 was working well at one time, what did you break ? Smile
Well, the quirks I have in mind are just 4 bools:
- Sort input packets
- Use pts or dts from input
- Use output pts or let dvdplayer generate them
- Use SW renderer
+ enable/disable XVID/MPEG2/VC1/VPX codecs

No intention of going further.

4412 was probably working because of a combination of bugs Wink
  •   
  • 1
  • 14
  • 15
  • 16(current)
  • 17
  • 18
  • 52
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
libstagefright - Experimental hardware video decoding builds4.510
This forum uses Lukasz Tkacz MyBB addons.