•   
  • 1
  • 27
  • 28
  • 29(current)
  • 30
  • 31
  • 86
  •   
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
(2014-03-02, 23:58)dgterk Wrote:
(2014-03-01, 14:18)Wotsie Wrote:
(2014-03-01, 03:27)AddonScriptorDE Wrote: Hey,
first - sorry for the late reply. I'm just too busy last weeks.
Netflix changed some small thing on login, so the addon wasn't working for new users.
To fix this, change line 473 of default.py to:
Code:
content = opener.open("http://movies.netflix.com/Login").read()

I'll try to answer/solve the other questions/problems (and release an update) next week...

Greetings,
asde

Yes, for me just adding `Login` to that line of code solved the login problem too! Thanks ASDE! For those who search for that line 473 in default.py: just look for 'Def login' and then add `Login` to the next line....



I am wondering where co can access the code on my computer to edit it to fix this issue. Could not find it in the rest of response and my hunting around under the program files was useless. Thanks for the great program and all the help.

xbmc folder/addons/plugin.video.netflixbmc
Open default.py with notepad
edit: The xbmc folder with your addons is in users/YOURUSERNAME/AppData/Roaming. You must be able to see hidden files to get to the AppData folder.
Reply
I am running Windows 8.1 and when I use Chrome as the Browser for netflix everything works fine with the Remote Config that I have set up, the thing is, netflix is usually jittery for me in Chrome. I run it through IE(Internet Explorer) and netflix is not jittery, but the only Remote Config key that works is the exit back to XBMC. The Fast forward and Rewind key bindings never work. Not sure what to do to fix this, any ideas would be great.


Awesome add on by the way. Thank you for all your hard work!!

EDIT: I figured out this issue is because the IE Explorer is playing Netflix through HTML5 and Chrome is playing through silverlight. This explains why the quality is better in IE and also why the controls do not work. It does not seem like Netflix has any keyboard controls for HTML5 except the space bar being pause and stop. Please correct me if I'm wrong.

Thank you,
Reply
Can I ask a very dumb question because its strange that I can't find the answer, when we clear our the cache and cookies it said to restart the add..........how do you restart the add on??
Reply
(2013-12-25, 03:31)Spd-Kilz Wrote: Hey, great add-on, it works about 95% perfect for me on a Windows 7/XBMC Frodo set up. There is an issue I'm having though I thought I would ask and see if there is a solution or if others are having the same concern.

I will boot into the app, select a program to watch and away it goes no problem (awesome). Pause/play works with the defined controls I set up..as does the "Alt+F4 exit" key (in my case it's the back button on my MCE remote). Pressing that back button exits the browser and brings XBMC back up. Great...but if I go to watch a second program, the back button no longer works. The video plays fine, and I can pause/play it no problem, but the back button no longer exits the browser back to XBMC. ONLY happens if I watch another program after I went back to XBMC the first time.

Very strange and annoying as I don't use a keyboard, so at this point I pretty much have to reboot/shutdown after the second show is done as I can't even find a way to exit the browser using my "remote mouse" app on my iPhone.

Any input would be much appreciated.

Cheers and Merry Christmas.

So I am having a similar issue. I am new to XBMC so still learning, however whenever I go to Netflix/Chrome via this add-on I am pretty much stuck there. I cannot get back into XBMC. I have tried using both my keyboard and the iPhone remote control app from XBMC. I can close the Chrome/Netflix browser window and get back to my desktop, but then the media center will not open back up and I need to reboot to get things working again. Also - the iPhone remote app does not seem to work when Netflix/Chrome is up and running, is this expected, can I fix this?

I am running Frodo and Windows 7 Home Premium 64 Bit; if you need other specs let me know. Thanks again for this great add-on.
Reply
Hello,

I am trying to figure out or this will work on a raspberry running on openelec.. I have it running on my laptop, bud i can't get it working on my raspberry.

The simple question is, is it possible or not??

Thanks in advance.

Gr. Nick
Reply
Just FYI gentleman, to workaround the OSX+Silverlight+fullscreen video stuttering issue I've added the following code to about line 405 of default.py and it works great. Simply invokes fullscreen a few times.. problem solved. Looks great.

Code:
xbmc.sleep(5000)
subprocess.Popen('cliclick c:500,500', shell=True)  
os.system("""osascript -e 'tell application "System Events" to keystroke "f"'""")
xbmc.sleep(5000)
subprocess.Popen('cliclick c:500,500', shell=True)
os.system("""osascript -e 'tell application "System Events" to keystroke "f"'""")
xbmc.sleep(5000)
subprocess.Popen('cliclick c:500,500', shell=True)
os.system("""osascript -e 'tell application "System Events" to keystroke "f"'""")


(2013-12-16, 07:16)BrennanD Wrote: Also, I noticed that when you load Chrome in kiosk mode, the frame rates of Netflix are slightly choppy. The only fix to this is to use the mouse to click on the full screen button. This is at 1080P in Mavericks and Frodo 12.2 w/Mavericks fix.
It's not related to the kiosk mode. I also noticed it on 1 of 2 osx testing systems when not in fullscreen mode, but it's the same when running Chrome normally.
You can also press the 'f' key to enter fullscreen mode...

(2013-12-16, 07:16)BrennanD Wrote: Is there a way to force an automatic full screen shortcut/keystroke script upon load of a video through NetfliXBMC when Chrome launches?
Unfortunately not under OSX, except with simulating the mouse (but if i implement automation, i would only do it by sending keystrokes).
Cliclick can only send some special keys. If you know some other app, which runs on most used osx versions and is able to simulate mouse/keyboard, let me know.
[/quote]
Reply
I apologize right off the bat, as I'm new to the board, thread and Netflixbmc. I've been reading and searching for the last two hours, and I can't find the location where the default.py file is.

I've installed XBMC on a fresh install of LinuxMint (16). From within XBMC's Filemanager I can find the "plugin.video.netflixbmc" folder... but the path displayed is not one that exists in the Linux environnement since it gives: special://profile/addon_data/plugin.video.netflixbmc

Can someone point me in the right direction, as I also have the "Not logged in" issue... off of a brand new install.
Reply
(2014-03-04, 07:13)minktea Wrote: I apologize right off the bat, as I'm new to the board, thread and Netflixbmc. I've been reading and searching for the last two hours, and I can't find the location where the default.py file is.

I've installed XBMC on a fresh install of LinuxMint (16). From within XBMC's Filemanager I can find the "plugin.video.netflixbmc" folder... but the path displayed is not one that exists in the Linux environnement since it gives: special://profile/addon_data/plugin.video.netflixbmc

Can someone point me in the right direction, as I also have the "Not logged in" issue... off of a brand new install.

/home/youruser/.xbmc/addons/plugin.video.netflixbmc
Reply
Hi - been trying to use Netflixbmc but keep getting Info: You are not logged in please restart the add-on.

Running OSx Maverick - Frodo - Chrome

My netflix email has a - in it, so not sure if it is a similar issue form a few pages back where there was a + in the users email address.

Checked my Netflix account and deffo not using the wrong details.
Reply
thebishop, please see fix on page 28 easy to do

to nick44888 I would like the same. It looks like the raspberry team is coming up with something maybe, involving streaming the browser from PC over. Not sure if it can be done any other way than that. I also have playon that the raspberry can grab the upnp from pc, but the quality takes a hit.
Reply
I am having an issue where the add-on keeps saying that I am not logged in and I need to restart the add-on. I have tried wiping the cache, reinstalling the plugin, changing my netflix password, everything I can think of. However, it still won't work. I am on Windows 8.1 and Frodo if that changes anything. Thank you for any help you can give me!
Reply
(2014-03-04, 21:32)ozymandiasynwa Wrote: I am having an issue where the add-on keeps saying that I am not logged in and I need to restart the add-on. I have tried wiping the cache, reinstalling the plugin, changing my netflix password, everything I can think of. However, it still won't work. I am on Windows 8.1 and Frodo if that changes anything. Thank you for any help you can give me!

Have you read the last couple of posts directly above yours?Huh
Reply
Hah! I didn't look very far because I was on mobile but I see it now! Thanks!
Reply
I've applied the fix of adding login as seen on page 28, but I'm still showing that I'm not logged in.
Reply
I'm having the same problem with the login. I too have applied the fix, but no go. Still "Info: you are not logged in. Restart the addon!" Thanks for any help!
Reply
  •   
  • 1
  • 27
  • 28
  • 29(current)
  • 30
  • 31
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.