•   
  • 1
  • 15
  • 16
  • 17(current)
  • 18
  • 19
  • 20
  •   
[AirPlay][Warning] Don't update to iOS8 if you want AirPlay
Hi guys,

I'm a big fan of XBMC / Kodi and recently installed the openELEC on a laptop to test how it will work as a HTPC.

I didn't read the full thread, but i thought I'd just share my experience here:

Airplay on openELEC /w Kodi 14 won't play back any audio. On my iPhone 4 with iOS 7.XX it will turn off airplay instantly after pressing play or just wont start playback.
In the current iTunes version, it says "not compatible with the current version". This happens regardless of iOS8 support enabled or not.

Hope to see a fix soon, keep up and thanks for the awesome work Smile
Reply
you will not see a fix without providing a debug log (wiki) - i stream audio and internet radio via airplay on a daily basis to my openelec box without issues.
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
Hi Memphiz,

I pasted a changelog, though i doubt it will be much help, there isn't really any valuable information in there.

Sometimes airplay works fine, other times it doesn't (like it did when i created the debug log below).

What I did: On my iPhone, started playback of a normal mp3 file, then airplay streamed it to my ATV2, which worked fine. However when selecting the Kodi center, it instantly stops and disables airplay on the iPhone. Nothing happens at all on the Kodi end.

http://pastebin.com/xRWMgKpj
Reply
you need to enable the airtunes component logging in system->system->debug so it logs airtunes printouts...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
for the first 1-2 logs i did i enabled component wise debugging but for this one it was disabled, i.e. all messages should show messages of all components?

it even says in the log file: 20:38:05 T:140063613237120 INFO: AIRPLAY: Cleaning up photoassetcache

My current guess is, that the iPhone just refuses the connection. It's jailbroken so I'm gonna have a look if has any logs on the phone side.


danke.

EDIT: Sorry maybe I got the wiki wrong and component wise debugging actually extends debugging behaviour instead of limiting it. Here's a new log, but not much more info there either
http://pastebin.com/MneetBYc
Reply
that log is cut ... don't cut at the end ... when you reproduced the issue - reboot openelec and then provide kodi.log.old ...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
yes it's cut, but all i deleted was literally key strokes.

But since I can see you're having a hard time trusting me... here's a full log with a single try:
http://pastebin.com/eY4u3qtb

and here's another one with iOS8 comp. disabled:
http://pastebin.com/v91Sm9GT

again: the logs aren't much help, the logging isn't verbose enough. I'll have a look at the source when my exams are through.
Reply
It has nothing to do with trust ...

1. the mac address of this mashine looks strange 00:01:02:03:04:05
2. everything else doesn't look that bad.
3. Looks like the client somehow doesn't like what libshairplay returns. Normally this is something i never saw anywhere else yet. Can you somehow ensure to use a proper mac adress on that network interface?
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
I am also having the Audio only when watching Netflix or Amazon Prime. Really hoping there is a fix to this at some stage as Kodi is the best media player by far for me and would be great to be able to use the AirPlay feature for TVOD.

On the positive side Spotify Airplay works perfectly.
Reply
Hi Memphiz,

the MAC Address is in fact weird... I SSHed into the system to run ifconfig, however the MAC Address displayed there is different. All other networking services work flawlessly.

openELEC currently runs on a mid-aged Lenovo T-series laptop.
Reply
(2015-01-06, 18:51)GrantXP Wrote: I am also having the Audio only when watching Netflix or Amazon Prime. Really hoping there is a fix to this at some stage as Kodi is the best media player by far for me and would be great to be able to use the AirPlay feature for TVOD.

On the positive side Spotify Airplay works perfectly.

TVOD and other DRM protected material will never work with Kodi - 99% sure about that.
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
(2015-01-07, 00:33)XaserIII Wrote: Hi Memphiz,

the MAC Address is in fact weird... I SSHed into the system to run ifconfig, however the MAC Address displayed there is different. All other networking services work flawlessly.

openELEC currently runs on a mid-aged Lenovo T-series laptop.

I see where the mac comes from. It means when Kodi starts and it starts the airtunes/airplay server there was not network interface up and running (yet?). What kind of network connection are you using. Also after Kodi was started -try to disable system->services->airplay and re-enable it afterwards. It should then be able toget the correct mac address (try this and report back with a new debug log (wiki))
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
Hi Memphiz,

spot on. It seems that neither network-interface (ETH / WLAN) is up before the AirPlay Service. After Reenabling Airplay however, it works fine.

Here's another debug log: http://pastebin.com/tj5vsuB0
Procedure: Enable Debugging - Reboot - Try to Playback via AirPlay - (not working) - dis/enable Airplay - Try to Playback via Airplay - (now working) - disable debugging - copying debug log.

I once saw an option somewhere in the settings which said something like "wait for network devices before starting Kodi" but I can't find it anymore.

Thanks!
Reply
In confluence Skin go to System (only Highlight it - do not enter) - in the submenu there are "openelec settings" - i expect the Setting you are looking for somewhere in there
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
(2015-01-07, 12:48)Memphiz Wrote:
(2015-01-06, 18:51)GrantXP Wrote: I am also having the Audio only when watching Netflix or Amazon Prime. Really hoping there is a fix to this at some stage as Kodi is the best media player by far for me and would be great to be able to use the AirPlay feature for TVOD.

On the positive side Spotify Airplay works perfectly.

TVOD and other DRM protected material will never work with Kodi - 99% sure about that.

What a shame, thanks for your response. Oh well having Spotify working in this version is a big win for me so thankyou for all your work.
Reply
  •   
  • 1
  • 15
  • 16
  • 17(current)
  • 18
  • 19
  • 20
  •   
 
Thread Rating:
  • 1 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
[AirPlay][Warning] Don't update to iOS8 if you want AirPlay41
This forum uses Lukasz Tkacz MyBB addons.