Music albums not found

I just registered here to tell you about a problem I'm having in the hope that someone will have a solution ^^

From my PC (windows 10) I share a music folder on the local network (+/- 600 artists). All files were analyzed and saved with the MusicBrainz Picard software.

Kodi is installed on my PC, also on a Raspberry Pi with the latest version of Librelec)

On the PC, all artists and albums seem to be detected.

On the other hand on Librelec, some albums are not detected (For example, I own 2 albums of the artist Amon Tobin: ISAM and Long Stories, on PC no problem they are well detected, but on Librelec impossible to detect Long Stories)
From Kodi on the Rpi , if I go to see in Files, the folder appears but is empty.

I tried a lot of things: Remove / Put the source back, tag the album again with MusicBrainz, change the scrapper... But nothing to do, the album (and others) remain invisible.... Namely that I also had Kodi with the Recalbox distribution (v17) and the problem was also present.

So, even if it may only concern a few albums, I would still like everything to work well.... Do you have a solution?

Here are the logs, I've just keep the lines corresponding to my example, tell me if you need something else Smile

Thank you in advance!

(Please excuse me if I made languages mistakes, I used a translate service to write this post)
Your log snippet appears to show that you can't access either of those albums by Amon Tobin.  It also shows network errors. So some questions -
  1. Are you connected to the network by wifi or cable ?
  2. Have you turned on 'Wait for network' in the libreELEC settings ? Probably won't make a difference for you, but worth a try - see
  3. Are any of the albums you can access on the same share from your PC ?
  4. Can you please get a debug log of you playing a track from an album you can access, followed by trying to play one you can't ?
If you are not sure on how to get the debug log please see this link debug log (wiki)

Learning Linux the hard way !!
Thank you for your answer!
I tried something I hadn't done yet: Access the folder via the local network from another computer and... Amon Tobin's Long Stories folder also appears empty!

So the problem comes from my computer and not from Kodi, it's a good start ^^
After some research, I see that in the properties of the files accessible on the network, in the security tab there is the WMPnetworkSvc line. None of the files not found have it.

WMPnetworkSvc has a connection with the sharing of music, videos....

I don't know if this is a good lead, and I also don't know how to modify all the files not found automatically.

What do you think of that?
I think I don't know an awful lot about sharing stuff from Windows (as I use Linux) but WMPnetworkSvc would appear to be a method of sharing the Windows Media Player library over a network.

So I think two things.  Perhaps you have added the files that you can see to Windows Media Player before ?  If that is so, then try adding the ones you can't see to it and see if that helps.
Learning Linux the hard way !!
Well, I think I found a solution...
I created a new folder, moved all my music to it and finally created a new share on the local network.....
I didn't expect anything...... But it worked! ^^^

Thank you for taking the time to help me! Smile
(2019-11-21, 20:30)Nhibel Wrote: Thank you for taking the time to help me!

You are welcome.  Glad that you have a solution! Smile
Learning Linux the hard way !!

Logout Mark Read Team Forum Stats Members Help
Music albums not found0
This forum uses Lukasz Tkacz MyBB addons.