Linux [Solved]TVHeadend crashing on startup
#1
Hi all,

Hope its ok for me to get help with this here, the tvheadend forums seem pretty quiet. I've been using XBMC and tvheadend for about 6 months and until a few days ago it was all working fine. On startup tvheadend now crashes totally, the errors output I've pasted below.

[INFO]:dvr: Creating new configuration 'Std'
[ALERT]:CRASH: Signal: 11 in PRG: /usr/local/bin/tvheadend (git-8f76d0c) [54a95c68574e8b7c69120e61bfbfe72e11cd92cd] CWD: /home/datty
[ALERT]:CRASH: Fault address (nil) (Address not mapped)
[ALERT]:CRASH: Loaded libraries: /lib64/librt.so.1 /lib64/libdl.so.2 /usr/lib64/libavahi-common.so.3 /usr/lib64/libavahi-client.so.3 /usr/lib64/libssl.so.1.0.0 /usr/lib64/libcrypto.so.1.0.0 /lib64/libpthread.so.0 /lib64/libm.so.6 /lib64/libc.so.6 /lib64/ld-linux-x86-64.so.2 /usr/lib64/libdbus-1.so.3 /lib64/libz.so.1 /lib64/libnss_compat.so.2 /lib64/libnsl.so.1 /lib64/libnss_nis.so.2 /lib64/libnss_files.so.2
[ALERT]:CRASH: Register dump [23]: 00007f02405429d0 00007f02405429f0 0000000000000064 a3d70a3d70a3d70b 000000004f95db6c 000000004f95e5f8 00007f0240ab1b70 00007f0240aa0680 00007f0240aa0640 0000000000000000 00000000019afdb0 00007f0240aa0680 00007f0240a98ce0 0000000000000000 0000000000000000 00007fff85568cc8 00007f024915b93a 0000000000010283 0000000000000033 0000000000000004 000000000000000e fffffffe7ffbfa17 0000000000000000
[ALERT]:CRASH: STACKTRACE
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/trap.c:139 0x421b88
[ALERT]:CRASH: ??:0 0x7f02497037d0
[ALERT]:CRASH: ??:0 0x7f024915b93a
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_db.c:271 0x4268bc
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_db.c:359 0x426c3a
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_db.c:379 0x426c9d
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_autorec.c:509 0x429166
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_autorec.c:374 0x4295fc
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dtable.c:86 0x406bbb
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_db.c:921 0x42781d
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/main.c:414 0x4051df
[ALERT]:CRASH: __libc_start_main+0xec (/lib64/libc.so.6)
[ALERT]:CRASH: ??:0 0x404749
Segmentation fault

I have recently updated my box, as shown its running tvheadend from opdenkamp built this morning (git 8f76d0c). Not sure if its relevant but I have glibc 2.14.1 installed (just because it mentions libc in the crash).

Would greatly appreciate any help with this!

Edit:
Just to let anyone know who's having similar problems, if i remove epgdb from the .hts userdata folder it is able to start up fine. There seems to be an issue with tvheadend and the data supplied by tv_grab_dvb_plus, using EIT data works fine.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average


Messages In This Thread
[Solved]TVHeadend crashing on startup - by datty - 2012-04-22, 10:06


Logout Mark Read Team Forum Stats Members Help
[Solved]TVHeadend crashing on startup00