•   
  • 1
  • 276
  • 277
  • 278(current)
  • 279
  • 280
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
The test version works for me. Before I couldn't log in on Gotham (Openelec 4).

so thanks for this.
OSMC Vero 4K, Intel NUC Celeron 847, Raspberry Pi3 LibreELEC. Amazon Fire TV
Sony 5.1 Surround sound
Panasonic 50EX750B
Thank you for repairing this plugin.
I deactivated 2-step verification and use this new version youtube plugin and after 1,5 year I am conect ...
Thank you BlushBlushBlush
(2014-05-18, 12:49)Skipmode A1 Wrote: I've tested the login stuff on a xbmc 12 (update through install from zip) and on a fresh xbmc 13.0 (install from zip). Login worked on both.

Fiddled a bit with a polish xbmc 13 and youtube and that seemed to work. However i'm not really sure i tested the exact bug...

Anyway here's a testversion: http://www.mediafire.com/download/txbtxv...ersion.zip

Please test Smile

Works for me.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Right, seems like testversion is good enough. Thanks for the testing folks Smile

Martijn/Kib, I'll push it to the xbmc repo soonish, if that's allright....
@Skipmode
Thank you for your hard work, you have my respect and keep up the good work. Thanks to ppl like you Internet is a better place.
Hi,

I have still login problem, but it seems it is something different. Look at the logs:

20:39:00 T:2812277824 NOTICE: [StorageClient-2.5.4] '__init__' : 'Setting table to : YouTube'
20:39:01 T:2812277824 NOTICE: CommonFunctions-2.5.1
20:39:02 T:2812277824 NOTICE: [YouTube-4.4.6] __init__ : ''
20:39:02 T:2812277824 NOTICE: [StorageClient-2.5.4] '__init__' : 'Setting table to : Downloader'
20:39:02 T:2812277824 NOTICE: [YouTube-4.4.6] __init__ : 'Done'
20:39:02 T:2812277824 NOTICE: [YouTube-4.4.6] getXBMCVersion : '13.0'
20:39:02 T:2812277824 NOTICE: [YouTube-4.4.6] login : ''
20:39:07 T:2812277824 NOTICE: [YouTube-4.4.6] login : 'refreshing token: False'
20:39:07 T:2812277824 NOTICE: [YouTube-4.4.6] _oRefreshToken : ''
20:39:07 T:2812277824 NOTICE: [YouTube-4.4.6] _oRefreshToken : 'didn't even try'
20:39:07 T:2812277824 NOTICE: [YouTube-4.4.6] authorize : 'token not refresh, or new uname or password'
20:39:07 T:2812277824 NOTICE: [YouTube-4.4.6] _httpLogin : 'HTTP LOGIN'
20:39:08 T:2812277824 NOTICE: [YouTube-4.4.6] _httpLogin : 'Step : 0'
20:39:08 T:2812277824 NOTICE: [YouTube-4.4.6] _httpLogin : 'fetch options: {'link': 'http://www.youtube.com/'}'
20:39:08 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'called for : {'link': 'http://www.youtube.com/'}'
20:39:08 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'got default: http://www.youtube.com/'
20:39:08 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'connecting to server... http://www.youtube.com/'
20:39:28 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'URLError : <urlopen error [Errno -2] Name or service not known>'
20:39:31 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'called for : {'link': 'http://www.youtube.com/', 'error': 1}'
20:39:31 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'got default: http://www.youtube.com/'
20:39:31 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'connecting to server... http://www.youtube.com/'
20:39:51 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'URLError : <urlopen error [Errno -2] Name or service not known>'
20:39:54 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'called for : {'link': 'http://www.youtube.com/', 'error': 2}'
20:39:54 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'got default: http://www.youtube.com/'
20:39:54 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'connecting to server... http://www.youtube.com/'
20:40:14 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'URLError : <urlopen error [Errno -2] Name or service not known>'
20:40:17 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'called for : {'link': 'http://www.youtube.com/', 'error': 3}'
20:40:17 T:2812277824 NOTICE: [YouTube-4.4.6] _fetchPage : 'giving up'

Looks like plugin cannot fetch youtube page.

Do you have any idea whats wrong ?
Still no fix for the "inappropriate content " message I get?
We will get our team of Engineers on it immediately.
@nulon. Looks like you can't connect to youtube at all.

@RGB_Gamer. It might be fixed in the 4.4.7 version.
I think the login problem was fixed in here

https://code.google.com/p/youtubexbmc/is...ail?id=115
Quote:In YouTubeLogin.py:

At the top, alongside the other imports, add:
import urlparse
(needed further down)

As per #9 replace:
nick = self.common.parseDOM(ret["content"], "p", attrs={"class": "masthead-expanded-acct-sw-id2"})
with:
nick = self.common.parseDOM(ret["content"], "span", attrs={"id": "yt-masthead-user-displayname"})
(needed to check logged-in state)

Replace:
new_part = self.common.parseDOM(ret["content"], "form", attrs={"name": "verifyForm"}, ret="action")
with:
new_part = self.common.parseDOM(ret["content"], "form", attrs={"id": "gaia_secondfactorform"}, ret="action")
(DOM changed)

On the next line, replace:
fetch_options = {"link": new_part[0].replace("&amp;", "&"), "url_data": url_data, "referer": ret["location"]}
with:
fetch_options = {"link": urlparse.urljoin(ret["location"],new_part[0]), "url_data": url_data, "referer": ret["location"]}
(extracted URL from new_part is relative. Needs to be converted to absolute URL using urlparse.urljoin, from import above)

Replace:
form = self.common.parseDOM(content, "form", attrs={"name": "verifyForm"}, ret=True)
with:
form = self.common.parseDOM(content, "form", attrs={"id": "gaia_secondfactorform"}, ret=True)
form[0] = form[0].replace(self.common.parseDOM(form, "div", attrs={"id": "newcode-content"}, ret=True)[0],"")
(DOM changed, second replacement line removes from the inputs from the form that are used for alternative methods of getting the code)

Works for me but after I login none of the Youtube Videos are playing now.. Any help guys?
The Youtube app on my Android phone wants me to enter a pairing code to pair it with the app on my TV/STB but I can't see any way to generate such a code with the XBMC Youtube app.

Is there any way to acheive this, so that I can search for videos on a phone/tablet and then 'throw' them to the TV to let friends watch?
you don't need to pare the device. just use a remote (i sue yatse)
just share the video from android and you will find the icon of the remote to send the video to xbmc
Peppe
Sorry, you've lost me. How do I send video from the Android youtube app to XBMC?
no problem, it is really easy.
just install yatse remote from playstore (the official xbmc remote has some problem with latest version of the youtube app).
configure yatse (i think this is necessary)
from the android youtube app on your device search a video. tap on the three vertical dots and tap again on share (shoud be share, i use the italian version of the app that said "condividi").
you will see a list with all the app you could use to share the link of the video. tap on yatse icon and the video will start on your xbmc.
that's all Nod
tell me if you need more help via MP here we are out of topic
Peppe
Even when I use Yatse to send a YouTube video with age restrictions to my XBMC PC (running OpenElec), I still get the "inappropriate content" message...
  •   
  • 1
  • 276
  • 277
  • 278(current)
  • 279
  • 280
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428