•   
  • 1
  • 55
  • 56
  • 57(current)
  • 58
  • 59
  • 86
  •   
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
(2014-09-21, 07:14)ravenxx Wrote:
(2014-09-21, 07:01)jawilljr Wrote: Read the comments.
The article also says that you need Chrome-dev ver 37 to get Netflix in Linux to work. Now that it is stable, no problem. Like I said I don't know about Windows.
As you (and the linked article) say, you'll need Chrome dev or beta. Stable Chrome versions are currently not working!

Comment from the link:

Quote:With Chrome 37 stable it works perfectly. Just don't forget about restarting Chrome. There is no actual need for Dev anymore since the latest update. Don't forget to enable EME chrome://flags/#enable-encrypted-media

another comment:

Quote:works perfectly using stable chrome on a debian/unstable
Reply
(2014-09-20, 13:46)rjonesdj Wrote:
(2014-09-20, 05:42)dversion Wrote: Woah hey! did internet explorer support get taken out!?

I needed it because i have my pc hooked up to my tv as a second monitor (where xbmc runs) and internet explorer opened up on the tv when i used this app, I also had a program that would automatically switch the default playback device to the tv if it saw IE open up.

Unless this is put back in does anyone have a solution for a two monitor setup?

^Exactly This.

I use the same setup, xbmc on second monitor with IE running on second monitor, Chrome used as my standard browser on other monitor.
At the moment, I have to just drag chrome between screens depending on what Im doing. Previously had issues with remote control and IE, noticed Chrome works fine with remote control, so thats a plus!

Would love to work out a way of NetfliXBMC launching chrome on second monitor, then for standard chrome use it opens on first monitor... but so far cant find any way of doing this. IE was my workaround...
Anyone have any ideas or suggestions? thanks (and thanks for this great add on btw)


Things back to normal for me again since the latest update. Appreciate you taking the time to make these changes!
Thanks again for a great add on
Reply
How use Xbmc player for Netflix, ( i dont use chrome launcher) beacuse i want put other subtitles in netflix.
Reply
v1.3.2:
- Changed notification (Chrome beta is not required anymore)

(2014-09-21, 04:18)jawilljr Wrote: Even with your stupid warning, it still works with the latest Chrome stable in Linux.
I thought it might be useful to inform the users about a required software version.
But thanks: Because of you I tested latest stable Chrome again under Win/OSX/Linux and it now works. So I changed the notification...

(2014-09-21, 05:09)ivwshane1 Wrote: You say you added support for Iexplorer back with win 8.1, how do we use it? I didn't see anything in the settings to change the preferred browser.
Should be available again. Maybe you just did not received the update at that moment.

(2014-09-21, 06:16)jawilljr Wrote: What is is wrong with the Dev?
I don't know. Tell me!

(2014-09-21, 15:39)gabieva Wrote: How use Xbmc player for Netflix, ( i dont use chrome launcher) beacuse i want put other subtitles in netflix.
Not possible. Netflix is using DRM, which XBMC can't handle. That's why a browser is required.
Reply
(2014-09-20, 19:43)ullms Wrote: This was working perfectly with ie on win8 before the update to 1.3. Now I can't get chrome to launch most of the time. Or I get multi tabs open error. Remote control commands that I had set up through eventghost don't work anymore either. I've updated chrome to beta version 38+ too.

Any suggestions? Any way to get version 1.2.9 back?
I seem to have found a solution to my own problems with chrome. I un-installed / removed ie and now chrome works. Decided to try removing it because Netflix wouldn't work in ie11 with html5 player, only silver light worked.

I have not reinstalled ie11 yet, to see if I works or not again with a fresh install.
Reply
(2014-09-21, 03:41)AddonScriptorDE Wrote: v1.3.1:
- Added more personal stuff to Suggestions
- Fixed Suggestions for multi-profile accounts
- Fixed bug with empty search results
- Readded support for IExplorer (HTML5 only supported in combination with Win 8.1)
- Added notification to inform users about new HTML5 Player / required Chrome version
- Webremote: changed xdotool key-definitons
- Improved downloading of tmdb content
......

(2014-09-20, 00:33)mr.willem Wrote: I don't know if anyone else is expecting the problem that audio is not working on Linux (xbmc, ALSA) but to suspend the audio I made a small workaround last night in the code of the plugin.
(2014-09-20, 01:06)kubax Wrote: still can't get audio from my videos. The interesting thing here is, that when i start chrome with xpra (X window redirection) i get sound over HDMI when i head over to netflix and start streaming a movie on my wifes notebook.
You can try turning "Keep audio device alive" off via "Settings->System->Audio Output".
This would be a solution in my case but not a good one because then I don't here any gui sounds at all. This is because my AV receiver probably takes to long to recognize that some audio signal is played.
Reply
Adding movies to the Library does not work.

First adding MyList to the Library does not work. I found I was able to get the function def addMyListToLibrary(): to work if I added:

pDialog = xbmcgui.DialogProgress()
pDialog.create('NetfliXBMC', translation(30142)+"...")
if not singleProfile:
setProfile()
xbmcplugin.setContent(pluginhandle, "movies")

to the beginning of the method.

Second, and more importantly, when I launch Netflix movies from the Library, it will launch the movie in Chrome as expected but it will also play the next movie in the Library.That's if the "Play the next video automatically" setting is set to true. Otherwise, it will attempt to launch 100 tabs in chrome!!

From reading the XBMC source, I guess it reads the launch from the movie.strm as failed and moves on to the next item on the playlist. With the "Play the next video automatically" setting off then it appears there is only one item on the playlist and it will loop it 100 times.

This is on Windows in XBMC 13.2.
Reply
Late to this addon, but wanted to add my deepest thanks for your work on this. I'd been contemplating getting one of the Android settops to be able to have Netflix & XBMC all in one box, this thing basically just saved me $100+ dollars.

Edit: One issue that I'm seeing is that programming seems to only playing in 2 channel, not surround. Is there some setting somewhere that I missed?
I have a 7.1 Pioneer AVR settting s to pass thru, and my NAS'd movies play in full surround.
Nvidia ShieldTV+Matrix
Reply
I'm trying to get NetfliXBMC to work with a 360 controller. What I would like to do is have it launch an Auto Hotkey script when it launches the Chrome window for video playback, and then end the script when the chrome browser closes. Can I do this by replacing the NetfliXBMC_SendKeys.exe with an autohotkey script that has the same filename? I wasn't using it anyway since it doesn't seem to work with HTML5.

In addition, are there any hotkeys when using the HTML5 playback? That would make the AHK script much easier to use.

EDIT: What does NetfliXBMC_Utility.exe do other than move the mouse? Does it handle the key mappings as well? I just notice that it seems to keep running even if I exit XBMC, and it then prevents me from launching XBMC again unless I end the process. If I can replace it with an AHK script, then that would solve all my problems.
Reply
Hi,

great Plugin! But i get always a "script failed" Error by playing any content. I Use Openelec latest Build (4.2.6) with NetfliXBMC, Chrome-Launcher and Chromium Browser installed. Any chance to get this working?

Any help would be appreciated!!!

Thanks in advance,
cheers
Peter
Reply
from the topicstart:
Quote:- Does this addon work under RPi / OpenElec / iOS / Android? In short: No.

If you want to sideload other applications, I suggest using XBMCbuntu instead Smile
Using XBMCbuntu on Intel NUC DN2820FYKH
Reply
Thanks for answering! I read about, but i hope there are any news on running under OE...
Reply
Canonical updated the libnss files this morning to 3.17. So the leonbo/nss PPA is no longer needed.

Source.

If you were using that PPA all you need to do is ppa-purge that repository.

Code:
sudo apt-get install ppa-purge
sudo ppa-purge ppa:leonbo/nss

And update your system:

Code:
sudo apt-get update && sudo apt-get upgrade

You still the User Agent string.
Reply
Am I correct in assuming that I still need to change the UA in the current chrome stable when using Win7?

Edit:
So I tried EVERYTHING, but with Chrome Stable, I simply cannot get Netflix to load in HTML5. It just doesn't do it. With Chrome beta? Yeah, no problem whatsoever.
Need help? Check out my XBMC Frodo Guide. It contains full featured guides to Sickbeard and CouchPotato as well.

Image
Reply
Trying to use netflixbmc on xbmcbuntu but I only get empty lists when looking for movies.

If works for tv series but not movies.

And it also takes a lot time when browsing in tv series. I always get a "loading metadata" which takes between 10 and 30 seconds to complete.

Browsing through movies on my main win7 pc is super fast.

Is there any known issue regarding these two points ?
Reply
  •   
  • 1
  • 55
  • 56
  • 57(current)
  • 58
  • 59
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.