Thread Closed
playing 60 fps mkv on ATV2?
Sorry if this is already posted, but I couldn't find anything.

I'm having issues playing some recent MKV's. (specifically recent episodes of Conan, The Daily Show, and Colbert Report), and I've found that these are coded in 60 fps instead of 30 fps. I've had to either download SD formats when available, or convert with handbreak to an m4v at 29.97 to get them to play. The audio plays fine but the video is way out of sync on the original mkv files.

The videos play perfect on my PBO, but not always on my desktop mac running XBMC as well.

Any solutions for the ATV2 to play these right? I've played with all the settings I can think of as well as connected the ATV2 direct to my router instead of wifi...
Sorry to bump, but anyone else here on an ATV2 with XBMC play 60fps 720p mkv files with or without success?
redgrandam Wrote:Sorry to bump, but anyone else here on an ATV2 with XBMC play 60fps 720p mkv files with or without success?

There's at least three major builds of XBMC for ATV2/iOS floating around here, there are several possible combinations of media types and data rates and such for the movies you are trying to play, and so much more information. If you don't tell us what version you are using, what the media info is on the files, and most importantly a log file, we can't help you. We don't have enough information to help you.

Read that, follow it's instructions and advice, and then we might be able to move forward with this.
My Apologies! I was just probing to see 'if' this was a wide spread problem, I wasn't going to worry about it too fast, but seems it isn't, so I'll follow those directions the best I can, thanks Smile

Here is my XBMC log file for trying to play 'The.Daily.Show.with.Jon.Stewart.2011.06.21.Cameron.Diaz.HD.TV.mkv'

The media file info that VLC gives me is:
Codec: H264 MPEG-4 AVC
Frame Rate:59.941256

A52 Audio
384 kb/s

This isn on ATV2, Build 20110515-8b3a9fc
AFAIK it's the official XBMC release
Installed by SSH @ copied

All other media files I've tried to play so far (including mkv files) have played great. It just seems to be these 60fps ones. I have audio sync turned on, and have tried all the different sync options, and none seemed to help.

Sometimes the unit tries to re-sync the audio, but often just the audio seems to play fine for a while, but the video is lagging behind from the start, and the video is not super smooth, but is playing.

I have it connected via wifi, but I've tried running a cable direct to it and it didn't help, same results. My Patriot Box Office is connected via wifi as well, and has no problem playing the file at 60fps.

One other note, I tried playing the file on my Mac Mini. It plays fine in VLC, but I tried on XBMC on here too and I get like digital static in the computer speakers, no show audio, while the video is playing. Not sure why on that either, but I don't really use XBMC on my Mac much, just the ATV2, so I'm not too concerned this second. Usually XBMC plays stuff fine on the mini though.

Please let me know if I've missed any information, I think I got it all . Smile

I hate to bump again, but I'm still stuck on this. Anyone have any ideas?
Unfortunately have no advice, but I can confirm the problem. Lots of sync issues and buffering.

iPhone 4 running iOS 4.2.6
XBMC 10.0-9: PRE-11.0 Git:20110623-62171b3 (Compiled: Jun 23 2011)
played over wireless-n and SMB share with a Macbook pro.

Media is the same specs as redgrandam (I think I found the same file) but here's the media info anyways:

Format                           : Matroska
File size                        : 451 MiB
Duration                         : 21mn 6s
Overall bit rate                 : 2 989 Kbps
Encoded date                     : UTC 2011-06-22 05:12:56
Writing application              : mkvmerge v4.0.0 ('The Stars were mine') built on Jun  5 2010 14:31:43
Writing library                  : libebml v1.0.0 + libmatroska v1.0.0

ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : [email protected]
Format settings, CABAC           : Yes
Format settings, ReFrames        : 5 frames
Format settings, GOP             : M=4, N=20
Codec ID                         : V_MPEG4/ISO/AVC
Duration                         : 21mn 6s
Bit rate                         : 2 545 Kbps
Width                            : 1 280 pixels
Height                           : 720 pixels
Display aspect ratio             : 16:9
Frame rate                       : 59.940 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.046
Stream size                      : 384 MiB (85%)
Writing library                  : x264 core 115 r2008 4c552d8
Encoding settings                : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=14 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=300 / keyint_min=30 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Language                         : English

ID                               : 2
Format                           : AC-3
Format/Info                      : Audio Coding 3
Mode extension                   : CM (complete main)
Codec ID                         : A_AC3
Duration                         : 21mn 6s
Bit rate mode                    : Constant
Bit rate                         : 384 Kbps
Channel(s)                       : 2 channels
Channel positions                : Front: L R
Sampling rate                    : 48.0 KHz
Bit depth                        : 16 bits
Compression mode                 : Lossy
Stream size                      : 58.0 MiB (13%)

XBMC log:

I will upload a sample of the video file in a bit
I'm pretty sure the answer to your problem is that the ATV2 does not have the processing power to properly play back 720p video at 60 fps.

*edited to make the "please be more specific"-police happy ;-)
SandmanCL Wrote:I'm pretty sure the answer to your problem is that the ATV2 does not have the processing power to properly play back video at 60 fps.

please be more specific with statements like this , 60 fps at what video res. I'm pretty sure I can do 60 fps @ 320x270 Smile
MediaInfo :
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
SandmanCL Wrote:I'm pretty sure the answer to your problem is that the ATV2 does not have the processing power to properly play back video at 60 fps.

That's what I'm wondering, but if true then this should be a common problem here.
I just looked through your debug log again.
Processing power aside, there may be a media detection bug that plays role here as well. Beginning on line 922:

18:34:21 T:195813376 M: 97816576   DEBUG: ReadEditDecisionLists - Assuming NTSC or 60i interlaced content. Adjusted frames per second from 59.940 (~59.940 fps) to 29.970

Further down in the log, though, (line 956) a few different refresh rates are mentioned, first a debug line saying the detected refreshrate is 29.99 hertz and then a notice line sating 59.94 fps.

18:34:22 T:1059943564 M: 79921152   DEBUG: CVideoReferenceClock: Detected refreshrate: 29.995801 hertz, rounding to 30 hertz
18:34:22 T:195813376 M: 79921152   DEBUG: CDVDPlayer::HandleMessages - player started 1
18:34:22 T:209805312 M: 78053376   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
18:34:22 T:1059943564 M: 76959744   DEBUG: CVideoReferenceClock: Detected refreshrate: 42.281361 hertz, rounding to 42 hertz
18:34:22 T:201007104 M: 77336576   DEBUG: GetPicture - VTBDecoderDecode dts(-4503599627370496.000000), pts(-4503599627370496.000000), old_pts(0.000000)
18:34:22 T:201007104 M: 77336576  NOTICE:  fps: 59.940060, pwidth: 1280, pheight: 720, dwidth: 1280, dheight: 720

Not sure where to get a copy of the April 17th nightly, but might want to try that to see if we have similar success for this more demanding file.
Ned Scott Wrote:

Not sure where to get a copy of the April 17th nightly, but might want to try that to see if we have similar success for this more demanding file.

I've uploaded the files:
I just downloaded another Daily Show episode in 720p/60 and from what I can tell there actually shouldn't be a hardware problem preventing playback. The video playback is quite smooth. But as redgrandam reported, the sound is way out of sync, and choppy.
I think it might depend on the sync settings. I think the first time I noticed the problems the audio played perfect and just the video was out of wack, I think playing in what would appear to be half speed slow mo (playing 60fps as though it was 30). The other night though I tried one and both the audio and video was choppy. I have played around with the sync settings so that may have something to do with it. I noticed when the audio was choppy to my receiver was going in and out of DTS mode, aging
I think ecause XBMC was all messed up with syncing.

I could try different versions of XBMC but I'm just a new with all this and afraid I might mess up my ATV, and we wouldn't want that. Doing SSH from the terminal on my Mac is totally new to me.
Is this something that should be submitted as an official bug report? I couldn't find anything submitted already regarding this....
  Thread Closed
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
playing 60 fps mkv on ATV2?00