•   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 11
  •   
[Release] Common plugin cache
#31
Here's an example on how I use it:
https://github.com/paddycarey/script.art...b/utils.py
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#32
Great, gonna look into it!
Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
#33
Someone suggested that I re-post the following to this thread for help... I'm also running XBMC Eden Beta 2 on atv2 and I do not receive this error. The error only occurs on my macbook running OSX 10.6.8:

leo gal Wrote:Hi,

I'm running Eden Beta 2 on Mac OSX and am receiving a common plugin cache error every time I open XBMC. I have tried uninstalling and reinstalling XBMC but I'm still receiving the same error.

Here is the log - I am not sure if this is what's needed since I'm new to this, so let me know if you need more. Any help would be appreciated:

12:01:27 T:2956091392 INFO: -->Python script returned the following error<--
12:01:27 T:2956091392 ERROR: Error Type: <class 'socket.error'>
12:01:27 T:2956091392 ERROR: Error Contents: (2, 'No such file or directory')
12:01:27 T:2956091392 ERROR: Traceback (most recent call last):
File "/Users/longfortravel/Library/Application Support/XBMC/addons/script.common.plugin.cache/default.py", line 44, in <module>
run()
File "/Users/longfortravel/Library/Application Support/XBMC/addons/script.common.plugin.cache/default.py", line 37, in run
s.run()
File "/Users/longfortravel/Library/Application Support/XBMC/addons/script.common.plugin.cache/lib/StorageServer.py", line 140, in run
sock.bind(self.socket)
File "<string>", line 1, in bind
error: (2, 'No such file or directory')
12:01:27 T:2956091392 INFO: -->End of Python script error report<--

Thanks for any and all help!
Reply
#34
leo gal Wrote:Someone suggested that I re-post the following to this thread for help... I'm also running XBMC Eden Beta 2 on atv2 and I do not receive this error. The error only occurs on my macbook running OSX 10.6.8:



Thanks for any and all help!

As ronie said, Full debug log please Smile
Reply
#35
debug log:

http:////pastebin.com/embed_js.php?i=EtEJgQD3

<script src="http://pastebin.com/embed_js.php?i=EtEJgQD3"></script>
Reply
#36
leo gal Wrote:debug log:

http:////pastebin.com/embed_js.php?i=EtEJgQD3

<script src="http://pastebin.com/embed_js.php?i=EtEJgQD3"></script>

system -> settings -> add-ons -> enabled add-ons -> services -> common cache plugin.

Then configure, make sure debug is checked, press ok. Restart xbmc.
Reply
#37
sorry... here's 2nd attempt w/ debug checked:

http://pastebin.com/embed_js.php?i=9UrMenBR
Reply
#38
Ok, i see what is wrong. And damn is that annoying.

ETA: On second look, i have no idea what is going on. :/
Reply
#39
Image
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#40
TobiasTheCommie Wrote:Ok, i see what is wrong. And damn is that annoying.

ETA: On second look, i have no idea what is going on. :/

OK - thanks for trying. let me know if you think of anything or need more info.
Reply
#41
leo gal Wrote:OK - thanks for trying. let me know if you think of anything or need more info.

Could you backup your ~/.xbmc/addons/script.common.plugin.cache/lib/StorageServer.py
and make a new file with this content.
http://paste.ubuntu.com/835245/

It should still fail, but hopefully the log will tell me why.
Reply
#42
sorry, just saw your post.

here's the log: http://pastebin.com/unk0Hcf9
Reply
#43
leo gal Wrote:sorry, just saw your post.

here's the log: http://pastebin.com/unk0Hcf9

Well, that was stupid(of me).

I introduced a new bug. *sigh*.

Same as before applies.

http://paste.ubuntu.com/845116/
Reply
#44
no worries... here you go:

http://pastebin.com/hdZRdTk9
Reply
#45
leo gal Wrote:no worries... here you go:

http://pastebin.com/hdZRdTk9

Try creating a ~/.xbmc/temp directory

You are the only one to report this problem, which is weird. And the log says that it can't create the file: /Users/longfortravel/.xbmc/temp/commoncache.socket

But the problem also hits for your weather addon

19:15:39 T:2959388672 WARNING: CreateDirectory, cant create dir </Users/longfortravel/.xbmc/temp/weather/>. trying lower case.
19:15:39 T:2959388672 ERROR: Create - Error creating /Users/longfortravel/.xbmc/temp/weather/

In any case, your problem is not specific to the cache service.

But try creating ~/.xbmc/temp (It is made automagically on my mac test machine) and hopefully it will work.

ETA: If creating the folder works for you, i will escalate this.

EETA: Could you please verify that your partition is NOT formated as case insensitive?
Reply
  •   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 11
  •   
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[Release] Common plugin cache51