Thread Closed
  •  Previous
  • 1
  • 52
  • 53
  • 54(current)
  • 55
  • 56
  • 189
  • Next 
Thread Rating:
  • 23 Vote(s) - 4.52 Average
How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs
Hi there! First thanx vor merging the new Audio enhancements in to this branch.
But now there is a problem. My HiFi Reciver is capable of DTS-HD and True-HD, but when playing movies with DTS-HD I experience slowdowns and stuttering (with no sound). Disabling DTS-HD Capabilty in System Settings removes this stuttering and the movies playback fine.
Anyone else ran in this problem?
I don't have a clue if this is an AE problem or maybe caused by this branch. I think the AE branch had been well tested befor reintegration into official trunk.

Anyway I can help U with deeper invastigation of this problem?

Huge props to wsnipex!!! How do I give him reps?? This instructional is amazing! Exactly what I needed. I had to tweak it to make my perfect minimal install, but this gave me the perfect starting point to do exactly what I wanted. Thank you so much!
hey guys
i have a little trouble with my xbmc
my configuration is:
Ubuntu Linux 12.04
Linux 3.2.0-26-generic on x86_64
AMD E-350 Processor, 2 cores
XBMC Eden 11

so the system works perfect after startup. i wached a HD movie -> no problems
i powered off my TV and let the xbmc run. (i always let it rum)
tomorrow morning i powered on the TV, but now i had a blackscreen and one of the CPU cores had 100%
nothing happend if i pushed a button. only the xbmc freezes! but not the ubuntu. i can still connect and wach the status with "htop"
now i have to reboot, than it works again for a while. how longe i can't say.

this problem i had a lot of times and i don't know whats wrong!
has anyone of you the same problem or can someone help me please?
@Janosh: thats a ati driver limitation. fglrx only provides 2 audio channels :/

@virus: sounds like the infamous asic hang in the ati driver. You could try to upgrade fglrx and also install the latest xbmc testing package.
i need to know the command or the steps to update the ati drivers please
can you join #xbmc-xvba? I don't want to give you a guide to 12.6beta, but 12.6 is not working without modification. With a short hack, you get everything up running fine, including aticonfig/amdconfig. As I currently do not have access to my AMD hardware, i won't write this to public for now.
i can't join. but you can write me a pm ?
Will check when i am at home and make it public then. <- perhaps this can make joining possible.
Okay verified this with two users.

1.) Backup /etc/ati/control and /etc/ati/signature from your current installed drivers.
2.) Install version 12.6 final as you always do. See the howto given by wsnipex some pages back.
3.) After it is finished copy back /etc/ati/control and /etc/ati/signature.
4.) Run all the aticonfig commands again, reboot and fine.

So 12.6 is fully functional only the control file was messed up. Have fun.
Disclaimer: We don't give support for people not fully reading this howto. If your brain already is in standby, wait till resume.

Detailed howto:

First install dependencies, you need to build fglrx (libc6-i386 is only needed on 64 bit systems):
sudo apt-get install dh-make dh-modaliases execstack libqtgui4 build-essential libc6-i386

Now continue (see legacy notes at the bottom for older amd gpus):

1. login in to the xbmc computer via ssh
2. sudo service lightdm stop
# backup signature and control to your home directory
3a. cp /etc/ati/signature /etc/ati/control $HOME
# if you have fglrx-updates fglrx-amdcccle-updates installed, remove it now
# the next command does not harm, it will just tell: package not installed, if you don't have it
# just go on with 3. in this case. This step might remove xbmc and xbmc-bin. We will install it later.
# on xbmcbuntu there is nvidia-current installed. This is not nice to us, when reinstalling fglrx later
# so we remove it, too.
3b. sudo apt-get remove fglrx* nvidia*
3. mkdir 12-6
4. cd 12-6
# if you have legacy hardware (HD2X, HD3X, HD4x)  continue with the instructions at the bottom.
5. wget
6. sudo sh --buildandinstallpkg
# should tell something about supported hardware not detected
# so we restore _only_ the control file to /etc/ati as the signature within 12.6b is not signed.
6b. sudo cp $HOME/control /etc/ati
7. sudo aticonfig --initial -f
8. sudo aticonfig --vs=on
9. sudo aticonfig --set-pcs-u32=MCIL,HWUVD_H264Level51Support,1
(Optional 9b. if you have black bars normally, disable underscan (always after lightdm has stopped): sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0)
# the next step is only needed if fglrx-updates was installed before
10. sudo apt-get install xbmc xbmc-bin
# finally reboot
11. sudo reboot

Legacy Instructions
If you have a card that is not supported by 12.6 anymore, these are all cards < HD5000. So: HD2XXX, HD3XXX, HD4XXX. You have to use the amd legacy driver. The steps are a bit different. Instead of step 5 and 6 you do:
5 legacy: wget
5b legacy: unzip
6 legacy: sudo sh --buildandinstallpkg
Now continue with step 7 from above.
(2012-04-14, 15:07)gsjosh Wrote: Earlier in this thread I cheered for getting this guide working on my setup, but maybe I cheered too early. It works pretty flawlessly up to the point that I go from the video player back into the menus (doesn't matter whether video is still playing or not). As soon as I start a new video, or perhaps go back to the video I was watching, it starts skipping frames backwards and forwards.

The problem has, I think, very much the same symptoms as described this ticket.

I could provide logs if needed, but at first I'm wondering if anybody has seen something like this with XVBA?

I'm having this issue - I followed the guide and have installed the Eden stable version. Some videos will play and a few times a second intersperse frames from earlier.

Certain of my x264 files exhibit this even on a fresh boot, but others will show it if played, stopped and played again as described above.

Any info I can provide, let me know!

Could you upgrade to at least xbmc-xvba ppa version? We do not have the man power to develop on the eden branch anymore, sorry about this.
(2012-07-01, 20:47)fritsch Wrote: @csmager:
Could you upgrade to at least xbmc-xvba ppa version? We do not have the man power to develop on the eden branch anymore, sorry about this.
No probs - will give it a go and report back. I think I tried it earlier in the day with the same result, but I'll try again to confirm!

xbmc.log doesn't seem to log anything once playback has started - is there anything else I should be looking at to gather any info? If I disable XVBA, the files work fine (subject to them being within the limits of what the CPU can decode in software!)
Best is to upload a sample, pastebin your xbmc.log with debugging turned on (complete one) and describe the error you are seeing.
Thanks for the solving issue with 5.1 and small comment:
I have Ubuntu 12.04 (upgraded from 11.10) with fglrx from Ubuntu repository, and command from the 1 message
sudo aticonfig --set-pcs-u32=MCIL,HWUVD_H264Level51Support,1
are not worked for me, no normal playing of L5.1 files, and
grep HWUVD_H264Level51Support /etc/ati/amdpcsdb
give empty result.
But if I use amdconfig instead aticonfig (I have both in the system)
sudo amdconfig --set-pcs-u32=MCIL,HWUVD_H264Level51Support,1
- all playing good.
May be it make sense to include information check command (grep) and possible usage of amdconfig in first message ?
  •  Previous
  • 1
  • 52
  • 53
  • 54(current)
  • 55
  • 56
  • 189
  • Next 
  Thread Closed

How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs4.5223