Problem with extrafanart and video plugin
#1
Hey, I'm not sure if this issue is specific to Nox or not but I can't seem to reproduce it in any other skins.

In my MMA Browser (video) plugin, i set the content type to tvshows with:

Code:
xbmcplugin.setContent(__addonidint__, 'tvshows')

and this works fine and allows me to set the right info for the items, use the tv show views etc. but it seems to have some bad side effects when extrafanart is enabled in Aeon Nox. Basically, as I add items to the directory Nox tries to load extrafanart for a plugin item by looking in the (non-existant) directory:

Code:
plugin://plugin.video.mmabrowser/extrafanart/

When the skin attempts to get the extrafanart it inadvertantly calls the plugin a second time:

Code:
14:03:19 T:3044574976   DEBUG: StartScript - calling plugin MMA Browser('plugin://plugin.video.mmabrowser/extrafanart/','1','')

This happens before the original directory listing has completed and thus causes XBMC to lock up completely. This doesn't occur with short/quick listings, only when a lot of items are being added to the list and it is taking a long time. This doesn't seem to happen with other skins whether or not extrafanart is enabled.

Debug log when run in Nox (with problems): http://paste.ubuntu.com/863459/
Debug log when run in T! (no problems): http://paste.ubuntu.com/863462/

I'd really appreciate any help in fixing this, I've tried to work around it in my addon with little success.

Thanks,
Paddy
Reply
#2
Could you test a fix I just pushed? I have no MMA browser so can't test it.
Reply
#3
Simular issue Wink

https://github.com/BigNoid/Aeon-Nox/issues/129
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#4
Thumbs Up 
Big_Noid Wrote:Could you test a fix I just pushed? I have no MMA browser so can't test it.

Works great Big Grin

Thanks for the quick fix.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Problem with extrafanart and video plugin00