GPU getting hot when idle
#1
I am not sure how long this has been happening but i checked my GPU temp yesterday and its a 91 Degrees.

It took me a while but i have now worked out that it is xbmc causing it, it is fine when i am watching something but when idle its causing the temp to creep up and up.

I am running Slackware Current with the latest driver from nvidia my card is a gt430 which is actively cooled and xbmc 11 rc2.

I have tried google for an answer but the best i have found is this

http://trac.xbmc.org/ticket/6727

I am running at 100fps just to display the screen, has any progress been made to slow this down?

I have tried setting the screen saver to black and opened xbmc around the time i started to register for the forum in the 3 mins before the black screen the gpu temp reached 84 degrees and is has still been climbing its now at 88 with the fan speed at 85%
Reply
#2
Does anyone have any ideas? We have just watched a couple of programs and i forgot to turn of xbmc after just looked and temp was upto 97 and after closing has taken 1 minute to drop back down to 78
Reply
#3
I've always experienced this phenomena with my boxes (current see signature)

box stays completely silent when watching movies but as soon as you're in the main menu without doing anything after awhile the fan goes on. always had this hypothesis that as the menu is rendered in OpenGL the GPU can't clock down but then again it should be busy when watching 1080p movies too...
OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sony 55" X85C Android TV (also with Kodi!)
Asus Chromebox EZ Script
Kodi on Sony Bravia Android TVs
Reply
#4
You should never run at 100fps. Make sure you have enable sync to vbalnk id 3D settings of nvidia driver. In XBMC check your setting of "vertical vblank sync" (video output). I prefer "Always enabled". That will limit fps to your choosen desktop resolution when in menu.
Enabling dirty regions would reduce gpu load when idle.
Reply
#5
Try enabling Dirty Regions if you're running Eden. I saw a significant drop in GPU usage/temp when idle after doing this.

How to:
http://wiki.xbmc.org/index.php?title=HOW...ty_regions
Reply
#6
Thanks,

Setting the Dirty Regions has helped, the sync made no difference at all and was syncing to the wrong display.
Reply
#7
Not extremely familiar with NVIDIA but with ATI I can go into settings and set any program to run at whatever refresh rate I want. Maybe setting yours to run XBMC at 24 or 60 refresh would stop that.
Reply
#8
I could not see any settings in the Nvidia util which could slow down individual apps but the dirty regions has took the temp down to 61 Degrees which is acceptable (its still annoying that that's higher than when watching something but hey hey).
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
GPU getting hot when idle00