Slow Transfer Speed with XBMC Live and NAS
I just ordered my Synology DS212j and am trying to transfer files from my HTPC which is a Zotac Ion N230 with gigabit and has been verified to have gigabit through ethtool. My question is I have no idea why my transfer speeds are stuck at 4.6MB. My router is a WNDR3700. Any help would be GREATLY appreciated, as I have right around 1TB of info I need to transfer.
Some NAS devices are pretty slow, although that's really slow. Have you tried from another computer? You could experiment between a windows PC and the Zotac and see how that goes.
I should also add that I am using putty to ssh into my htpc and do the rsync transfer. Could that have anything to do with it? I will try to plug my PC into the network to see if it helps as suggested also.
Embedded NAS devices are horrid on performance in general. Back in 2008 or 09, I beta tested Open PS2 Loader homebrew software. I spent forever transferring my games to it from my PC. Mind you, both systems had 100Mbit NIC's. So, in theory, transfers should have been around ~ 10MB/s give or take. That NAS maxed out at around ~ 2.5MB/s on large files. It done this regardless of hard drive installed, or computer transferred to/from it on different networks. What it is, the hardware of the embedded NAS isn't sufficient enough to support higher transfer rates.

Another example was when I built a NAS out of another old computer. Ran a 1.2GHz Intel Celeron processor, and about a Gig of RAM, installed a Gigabit NIC. Now, my main PC is an AMD Athlon X2 running at about 3.1GHz and has about 4GB RAM and has a built in Gigabit NIC. Running a decent Buffalo Gigabit router. The softwares used on the NAS PC - 1st tried FreeNAS. It maxed out at around 22MB/s. 2nd, tried OpenMediaVault when it was released. Same speed.

Eventually I wised up and monitored the hardware through status screens of the softwares. The processor was maxed out during transfers. Keep in mind that transfers were maxing at around 22MB/s. I realized quickly that slower processors simply couldn't handle the Gigabit bandwidth.

Then ordered a Asus E35M-1. That has a dual core AMD Fusion running at 1.6GHz. Meaning it has better than double processor power than my old NAS setup. Also installed 4GB RAM and installed the AMD64 version of OpenMediaVault Now transfers on files can reach upwards of 96MB/s. Of course small files will often do about 30MB/s average.

Now seeing the specs of your NAS,

CPU Frequency : 1.2GHz
    Hardware Encrypted Engine
    Memory : DDR2 256MB
    Internal HDD/SSD : 3.5" or 2.5" SATA(II) X 2 (With optional 2.5" Disk Holder) (Hard drive not included)
    Max Internal Capacity : 6TB (2X 3TB HDD) (Capacity may vary by RAID types) (See All Supported HDD)
    External HDD Interface : USB 2.0 Port X 2
    Size (HxWxD) : 165 X 100 X 225.5 mm
    Weight : 0.94Kg
    LAN : Gigabit X1

I'm assuming it's running a single core processor. Also, the RAM is (in my opinion) insufficient to obtain Gigabit speeds. My conclusion is that if you want power saving, you have to sacrifice performance. If you want performance, you have to go with more power.
I actually have exactly the same problem with nearly the same hardware. I have a synology 211j and an asrock ion pc and a 3700 netgear router. I've found that the slow speed is only in xbmc and not in ubuntu or windows. I am running XbmcBuntu 11.1.
I have a DS211J and can regularly get speed of 30-40MBps (byte not bit) read and write speeds using SMB. Rsync should be as fast if not a little faster due to less overhead. I'd check and make sure speed and duplex settings are correct and that the cabling is good.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Slow Transfer Speed with XBMC Live and NAS00