Local Lircmap.xml is not read. Only the global one.
#1
XBMC 10.1
Ubuntu 11.04 Natty Narwhal
Architecture: x86-64
Install method: PPA
Revision: "Git: Unknown"...
Debug log: http://pastebin.com/48SJkde9

I have this problem where whatever changes i make in ~/.xbmc/userdata/Lircmap.xml does not seem to have any effect.
If i do the exact same changes in /usr/share/xbmc/system/Lircmap.xml, it all works..

The log has the line "INFO: Loading special://profile/Lircmap.xml", so i have no idea of what goes wrong.
Any help will be appreciated.

My ~/.xbmc/userdata/Lircmap.xml looks like this:
Code:
<lircmap>
      <remote device="linux-input-layer">
    <altname>cx23885_remote</altname>
    <altname>devinput</altname>
        <myvideo>KEY_VIDEO</myvideo>
        <mymusic>KEY_AUDIO</mymusic>
        <mypictures>KEY_MHP</mypictures>
                <myvideo>KEY_TV</myvideo>
                <back>KEY_BACKSPACE</back>
    </remote>
</lircmap>
Reply
#2
Thankfully an upgrade to the new XBMC 11.0 Eden fixed this problem for me Smile
Reply
#3
I noticed this issue with Lircmap.xml and 10.1 and, like you, upgrading to 11.0 fixed this. But Ive just been mucking around with a remote.xml and have noticed something similar, with everything seeming ok from the logs. The changes to my local remote.xml are recognised but anything I comment out isnt. I renamed my /usr/local/share/xbmc/system/remote.xml to remote.xml.unused and now the commented out entries are ignored as should be...

Im wondering if I should file a bug report...
Reply
#4
I have the same issue with XBMC 12.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Local Lircmap.xml is not read. Only the global one.00